Eclipse não funciona em 16.04

58

O Eclipse estava funcionando tão bem quanto qualquer coisa em 14.04. Eu fiz uma instalação limpa do 16.04 e instalei o Eclipse. Mas ele executa um programa Java apenas uma vez, após o qual ele é interrompido durante tentativas subseqüentes antes de eu removê-lo e reinstalá-lo. Eu tentei muitas coisas, já que no começo eu também precisava do CDT. Agora, eu só quero remover tudo relacionado ao eclipse e fazer uma nova instalação (remova todas as configurações e dependências). Observe que usei o instalador do Eclipse para instalar o Eclipse e a imagem do ícone do eclipse também não está aparecendo (o padrão ubuntu? Está aparecendo).

    
por Ankur Lathwal 24.04.2016 / 05:55

7 respostas

114

Eu tinha algo parecido com o 16.04 e o Eclipse Mars. Eu pensei que tinha congelado, mas na verdade estava correndo muito, muito devagar. O problema é a versão do GTK + 3, enviada com o 16.04. Felizmente a solução é muito fácil. Abra um terminal e, em seguida, digite export SWT_GTK3=0 e inicie o Eclipse a partir do terminal. Se isso funcionar, uma correção mais persistente é colocar as duas linhas abaixo, conforme elas aparecem em eclipse.ini :

--launcher.GTK_version
2

antes da linha:

--launcher.appendVmargs

O bug é arquivado com o Ubuntu no bug 1552764

    
por NickT 24.04.2016 / 09:50
5

Obrigado pela dica.

Eu tive que mudar a versão necessária do java de:

-Dosgi.requiredJavaVersion=1.7

em

-Dosgi.requiredJavaVersion=1.8

e remova esta linha também:

-XX:MaxPermSize=256m

Codificação feliz!

    
por staplr 30.04.2016 / 15:54
3

Edite eclipse.desktop da seguinte forma:

Exec=env SWT_GTK3=0 eclipse
    
por Haozhe Xie 30.04.2016 / 05:58
1

Minha recomendação é que você instale o Eclipse Mars a partir da página da Web: link

Mas primeiro você precisa instalar o java8 (não o java9 porque o Eclipse Mars não funciona com essa versão). No Ubuntu você pode fazer isso com: sudo apt-get instalar openjdk-8-jre openjdk-8-jdk

E então .. e apenas se você tiver outra versão do java, você tem que selecionar java8 com este comando: sudo update-alternatives --config java

Voilà! Isso funcionou para mim! :)

    
por Gonzalo 16.05.2016 / 05:30
0

Aparentemente, esse é um conhecido bug no Ubuntu 16.04. Isso afeta não apenas o eclipse, mas vários outros aplicativos também.

Antes da correção ser lançada, é uma correção rápida que funciona. Abra o terminal e digite

$ initctl restart unity-panel-service

Isso trará de volta os Menus para a sessão atual. Mas você pode querer fazer isso novamente se reiniciar sua máquina.

    
por Anonymous Platypus 29.11.2016 / 10:57
0

Se você estiver recebendo um erro para libjavascriptcoregtk-4.0 ou WTFCrash , tente instalar o libwebkitgtk-3.0-0 :

sudo apt install libwebkitgtk-3.0-0

    
por wisbucky 26.01.2018 / 01:45
0

Ao iniciar o aplicativo a partir da linha de comando (o terminal), às vezes é possível obter mais informações sobre por que o programa falha ao iniciar. Por exemplo (supondo que o eclipse esteja em seu caminho, caso contrário, inicie-o na pasta onde ele está instalado / descompactado):

[email protected]:~$ eclipse
Unrecognized VM option 'MaxPermSize=256m'
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

Neste caso, parece que a linha

-XX:MaxPermSize=256m

no arquivo eclipse.ini é o problema. Basta remover essa linha (crie um backup do arquivo eclipse.ini primeiro) e tente iniciar o programa novamente.

A solução acima funcionou em Eclipse Version: Mars.2 Release (4.5.2) em uma máquina atualizada de 15.10 para 16.04

    
por Ronny Andersson 02.05.2016 / 00:44

Tags