Maior resolução de tela para o VirtualBox?

96

Eu tenho tentado isso por um tempo, mas sem sorte. Eu instalei ubuntu-11.10-desktop-i386 duas vezes. Também adições de convidado instaladas. No entanto, sempre obtenho a resolução máxima da tela como 1024 x 768 .

Preciso alterar alguma coisa no arquivo /etc/X11/xorg.conf ( exemplo )? Atualmente não existe tal arquivo nesse caminho. Além disso, você seria capaz de me informar qual deve ser o conteúdo do arquivo para a versão 11.10?

    
por iammilind 29.10.2011 / 20:25
fonte

17 respostas

88

Isso funcionou para mim e estou executando o VirtualBox 4.1.8 e o Ubuntu 11.10.

sudo apt-get install virtualbox-guest-utils virtualbox-guest-x11 virtualbox-guest-dkms

Encontrei neste site sob uma questão ligeiramente diferente Maior resolução de tela no VirtualBox?

    
por wfudge 09.03.2012 / 07:22
fonte
31

Consegui reproduzir esse problema repetidamente no host do Windows 7 com o convidado do Ubuntu 11.10. Instalando o Ubuntu a partir de uma imagem iso.

Esta edição acontece quando o Guest Additions não está instalado ou instalado a partir de fontes do ubuntu.

Para corrigir isso, adicione as adições dos convidados dos dispositivos da máquina virtual > Inserir a opção de imagem de CD de adições de convidado e executar o autoprompt. Se você já tiver as adições de convidado instaladas de uma fonte diferente, ele solicitará a remoção da existente e a instalação de novas adições de convidados, apenas diga "sim". Isso removerá os acréscimos de convidados se eles já estiverem instalados a partir de fontes do ubuntu e compilados a partir de fontes que acompanham a instalação do seu virtualBox.

Isso deve corrigir o problema.

    
por Sai Puli 09.08.2012 / 17:35
fonte
14

Acabei de instalar o Ubuntu 12.04 no VirtualBox 4.1.4, mas não consegui fazê-lo funcionar com resolução mais alta, mesmo depois de instalar e reinstalar o VBOXAdditions. Desesperado, instalei o VBOX 4.1.14 e reinstalei muitas vezes o VBOXAdditions, mas sem sucesso algum. Finalmente, a solução que resolveu o problema foi aumentar a memória de vídeo (na configuração VBOX para o Ubuntu) de 12 MB para 48 MB (que ainda não habilitava a resolução 1366x768) e 128 MB. Depois de reiniciar o Ubuntu tudo funciona perfeito, 1366x768 é a minha resolução padrão. Espero que isso ajude nos seus problemas. Felicidades!

    
por LowResolutionOnUbuntu12.04 28.04.2012 / 17:56
fonte
10

Eu estava preocupado com a resolução da tela no Virtual Box no Windows 7 x64 como host e no desktop Ubuntu 12.04 LTS como convidado. Eu tinha levantado a memória de vídeo para 128 MB, instalado o VirtualBox Linux Additions, mas ainda era um não ir. Ao verificar a configuração de exibição no Ubuntu, eu só poderia escolher entre 800x640 (4: 3) e 1024x768 (4: 3).

Marcar a caixa de seleção Ativar aceleração 3D nas configurações da máquina virtual fez com que funcionasse. Depois disso, quando a janela do convidado foi redimensionada, o tamanho foi refletido nas configurações de exibição do Ubuntu. Ao ativar o modo de tela inteira, eu poderia usar a resolução total de 1600x900 no Ubuntu.

Espero que isso possa salvar o cabelo de alguém.

ATUALIZAÇÃO: Depois de habilitar a aceleração 3D, o Ubuntu ficou extremamente lento. Por isso, desmarcou a aceleração 3D e ainda consegui desfrutar da resolução total da tela.

    
por John P 09.10.2012 / 17:12
fonte
7

Este é provavelmente um problema VirtualBox , em vez de um problema Ubuntu .

Eu tive o mesmo problema várias vezes antes. Às vezes, remover e reinstalar o Additions resolve isso. Ou simplesmente forçando o VirtualBox a carregá-los, e não apenas baixá-los.

Infelizmente, esse problema ocorre novamente. Eu descobri que atualizar o VirtualBox (para uma compilação mais nova) às vezes torna isso pior E às vezes resolve isso. Esta é uma questão recorrente ..

    
por david6 20.11.2011 / 00:24
fonte
7

Meu sistema é 64bit Windows 7 SP 1 rodando o Ubuntu 12.04 LTS 32 bit (i386). Eu tinha que fazer quase tudo para funcionar. Para resumir:

  1. Com o desligamento da máquina virtual, altere as "Configurações" da máquina virtual pertinente. Em "Display" - > 'Video' mova o controle deslizante da memória de vídeo para '128mb' e também marque 'Enable 3D Acceleration'.

  2. Agora carregue sua máquina virtual Ubuntu. Em "Dispositivos", clique em "Inserir imagem do CD de adições aos convidados". Espere que faça o seu trabalho.

  3. Reinicie a máquina virtual. Agora você deve conseguir atingir as resoluções mais altas. Caso contrário, pode ser porque a janela da máquina virtual não é grande o suficiente. Arraste o canto para aumentar ou simplesmente faça: 'Ver' - > 'Mudar para tela cheia'

Espero que isso ajude alguém. Obrigado a todas as outras respostas por me ajudarem.

    
por Calleniah 04.12.2013 / 20:42
fonte
2

Entrando no jogo ultimamente, não tenho certeza se essa resposta vai ajudar, mas tendo um problema de resolução similar (host Mac, Ubuntu como vbox), e depois de jogar com xrandr , xorg.conf etc ... eu tentei o seguinte

  • fechar caixa virtual
  • digite o comando do terminal host VBoxManage setextradata Linux CustomVideoMode1 1152x680x32 em que Linux é o nome da vbox, CustomVideoMode1 é um nome fornecido com 1 para uma nova resolução, 1152x680x32 para uma resolução de cores de 1152 x 680 x 32 bits (VBoxManage.exe no Windows)
  • inicie seu vbox
  • reinstalar as adições de convidado

funcionou imediatamente após a reinicialização da vbox.

mais informações

    
por Ring Ø 31.03.2013 / 12:47
fonte
2

Usando o VirtualBox 4.3 no Windows 8 e o convidado Ubuntu 12.04

Eu instalei adições de convidados do virtualbox do arquivo iso fornecido no diretório de instalação do virtualbox (usado autorun.sh) + restart guest.

Primeiro, achei que não funcionou: a resolução ainda era baixa e os parâmetros de tela não mostravam nenhuma resolução maior

Então eu percebi que a tela do convidado estava em "modo de escala" (host + c), mudei para tela cheia (host + F) e a resolução estava boa!

    
por ceco 14.05.2014 / 16:25
fonte
1

Basta executar o ubuntu na máquina virtual e instalar o "VirtualBox Guest Additions" (Dispositivos - > Instalar adições de convidado). Após a instalação, reinicie seu sistema convidado.

Agora, a resolução será alterada automaticamente, dependendo do tamanho da janela.

* Eu uso o Ubuntu 13.04 no VirtualBox 4.2.12 para Mac OS

Boa sorte.

    
por Roman Shamritskiy 04.06.2013 / 13:33
fonte
1

Teve problemas com a tela não em tamanho total após as atualizações. Executando o Ubuntu 12.04. Na mídia VBOXADDITIONS, eu simplesmente executei o autorun.sh - isto foi desinstalado e reinstalado, e depois reiniciei e tudo estava de volta ao normal.

    
por Richard 27.06.2013 / 07:43
fonte
1

Com o Ubuntu 12.04 como host e convidado, segui a resposta do wfudge.

Isso requer que outros pacotes sejam instalados:

sudo apt-get xserver-xorg-core

Depois disso, executamos esta linha modificada do wfudge sugerida pelo apt-get:

sudo apt-get install virtualbox-ose-guest-utils virtualbox-ose-guest-x11 virtualbox-ose-guest-dkms virtualbox-guest-x11

Depois disso, o convidado do Ubuntu não inicializou na GUI, então com Ctrl + Alt + F1, logado em um console e executado:

sudo apt-get install ubuntu-desktop

Reinicie e pronto. Agora posso obter resoluções mais altas até 1600x1200. Ainda não 1920x1080 (host), por isso não é em tela cheia, mas pelo menos é muito melhor do que eu tinha antes.

Eu acho que é um problema do VirtualBox, mas quando usado um host do Windows não tem esse problema ...

    
por Christian Vielma 25.09.2013 / 18:01
fonte
1

Para mim (Host: Mac El-capitan, Convidado: Ubuntu 14.xx LTS, VirtualBox: 5.0.12) o Ubuntu não irá reiniciar (preto ou a tela roxa padrão congelada) após instalações de convidados via apt-get as descrito na maioria dos posts deste tópico.

Por fim, usei as instruções oficiais do VirtualBox . Em uma nova instalação do Ubuntu. Trabalhou!

% bl0ck_qu0te%

Eu fiz um sudo reboot now no final apenas para estar seguro. No reinício, começou a mudar a resolução de acordo com o tamanho da janela.

    
por Kashyap 27.01.2016 / 16:22
fonte
0

A única solução que funcionou foi o download do último VBoxAdditions ISO do site da Oracle, já que os antigos não funcionam corretamente com o DKMS.

    
por Yatharth Agarwal 09.12.2015 / 21:43
fonte
0

Eu tenho o mesmo problema no meu notebook DELL M6600 com o Ubuntu 12.10. Eu tive que instalar adições de missões no modo de segurança do windows. Depois disso, a resolução da tela da área de trabalho era feita pelo tamanho da janela com o sistema operacional convidado.

    
por jafan 29.01.2013 / 20:41
fonte
0

Às vezes é muito simples (referindo-se a 12.03 / 4) Na janela da máquina virtual, aperte o botão maximizar e ele preencherá a tela e fará com que o Ubuntu detecte novamente a resolução da tela da VM.

Outra, a resposta de Christian Vielma, fazendo todos os três passos um após o outro, permitirá esta opção.

    
por ppostma1 30.10.2013 / 16:57
fonte
0
  1. Feche o VirtualBox.

  2. Cole isso no terminal do host:

    sudo VBoxManage setextradata NAME CustomVideoMode1 1152x680x32
    

    onde NAME pode ser encontrado em Configurações Geral Básico Nome .

  3. Reinicie o VirtualBox.

por Ajay 06.03.2014 / 17:00
fonte
0

Usando o X11 simples sem um cliente de desktop pesado, ratpoison no meu caso, o seguinte pacote é tudo o que é necessário:

virtualbox-guest-x11

Eu entendo que outros pacotes podem tornar seu kernel ciente de que ele está sendo executado em um ambiente virtual para alguns benefícios, mas este pacote parece lidar com os problemas de resolução.

    
por Asad Hasan 08.03.2014 / 20:23
fonte