Não é possível usar os atalhos de teclado IntelliJ IDEA no Ubuntu

121

Sou muito novo no Ubuntu e estou com um problema que não sei como consertar. Eu até tentei procurar na web por respostas, mas talvez eu não saiba os termos corretos para procurá-lo.

Eu trabalho com o IntelliJ IDEA , um aplicativo para desenvolvimento. E eu estou muito acostumado com os atalhos de teclado, mas quando eu fiz a mudança do Windows XP para o Ubuntu 13.10, alguns atalhos não funcionam mais. Por exemplo, como;

  • Ctrl + Alt + < (seta para a esquerda)
  • Alt + F8

Existe alguma razão por que? e há alguma correção para isso? Ou talvez apenas algo para me guiar na minha busca

Agradeço a todos com muita antecedência.

    
por Rodrigo Sasaki 28.01.2014 / 13:01
fonte

10 respostas

191

Como um pouco de leitura me ensinou que o Intellij IDEA é um IDE centrado no teclado. O que significa, é que um uso pode trabalhar com ele sem ter que tocar o mouse. Também gerencio encontrar a configuração do mapa de teclado.

Para o Ubuntu

Veja como alterar atalhos de teclado?

Veja uma lista de ajustes que você precisa fazer com as vinculações de teclas padrão do sistema para que eles não interfiram nas ações do IntelliJ IDEA (listadas entre colchetes).

% bl0ck_qu0te%

Espero que isso ajude!

Nota: Você sempre pode reverter os atalhos do Ubuntu de volta ao seu estado padrão. Basta se referir a Como posso restaurar os atalhos de teclado padrão? , caso você esteja perdido .

Fonte: - Mapa de chaves do Intellij IDEA

    
por AzkerM 28.01.2014 / 13:39
fonte
28

Eu me deparei com esse problema também, mas a minha solução foi diferente.

Não é necessário alterar ou alterar o mapa de teclado do sistema

O IntelliJ tem Keymaps diferentes, que você pode alterar de acordo com seu sistema operacional.

Você pode alterar seu IntelliJ Keymap das configurações.

Basta ir para Settings -> Keymap e selecionar o mapa de teclado desejado na lista suspensa. No meu caso, escolhi "Default for GNOME", já que estou usando o Ubuntu Gnome 16.04.

    
por Francisco C. 25.06.2016 / 07:18
fonte
16

Para o Ubuntu 18.04 LTS ctrl + alt + left (Conflito de atalho de ideia Intellij)

  • instale o Dconf Editor no software do Ubuntu
  • inicie o Dconf Editor, vá para / org / gnome / desktop / wm / atalhos de teclado / alternar para a área de trabalho restante

  • clique duas vezes como abaixo

  • use o valor padrão (clique em Desligado) - > Valor personalizado (como eu ou outra pessoa)

  • você poderia usá-lo na idéia do intellij agora

    
por think 06.05.2018 / 11:42
fonte
5

Eu criei este script que desativa todos os atalhos conflitantes entre o Ubuntu (testado com 15.10) e o IntelliJ (e provavelmente mais produtos Jetbrains). Desativa-os no Ubuntu.

Ele também cria um arquivo de backup para que você possa restaurar as configurações anteriores.

Para não ter alguns atalhos desativados, comente-os na matriz KEYS .

#!/bin/bash
set -euo pipefail

# Disables Ubuntu shortcuts that clash with IntelliJ Idea (and probably other
# Jetbrain products).
#
# Creates a backup file to restore the previous settings. To not have some
# shortcuts disabled, comment them out in the 'KEYS' array.
#
# Tested on : Ubuntu 15.10
# Author    : Jonas Gröger

readonly BACKUP_FILE="undo-fix-shortcuts-$(date +%s%N).sh"
readonly KEYS=(
    "/org/gnome/desktop/wm/keybindings/toggle-shaded"
    "/org/gnome/settings-daemon/plugins/media-keys/screensaver"
    "/org/gnome/settings-daemon/plugins/media-keys/terminal"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-down"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-up"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-left"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-right"
    "/org/gnome/desktop/wm/keybindings/begin-move"
    "/org/gnome/desktop/wm/keybindings/begin-resize"
    # To disable resetting a value, just comment out the line
)
readonly DISABLED_VALUE="['disabled']"

main() {
    # Make backup
    printf "#!/bin/bash\n" >>  "$BACKUP_FILE"
    for key in "${KEYS[@]}"; do
        local value
        value=$(dconf read "$key")
        printf "dconf write \"%s\" \"%s\"\n" "$key" "$value" >> "$BACKUP_FILE"
    done

    # Disable all Ubuntu shortcuts
    for key in "${KEYS[@]}"; do
        dconf write "$key" "$DISABLED_VALUE"
    done
}
main

Você pode obtê-lo daqui:

wget -O fix-shortcuts.sh https://gist.githubusercontent.com/JonasGroeger/94cfa1071fa12572f465/raw/fix-shortcuts.sh
    
por Jonas Gröger 16.12.2015 / 22:40
fonte
3

Veja aqui uma maneira de desativar os atalhos do Ubuntu programaticamente e somente se as janelas de certos aplicativos estiverem ativas.

Especificamente, use esses valores (presumindo que você use a Caixa de ferramentas JetBrains com seu caminho de instalação padrão; faça outra adaptação):

apppattern = "JetBrains"
backupfile = "~/.local/share/JetBrains/keymap_backup"

Enquanto o script é executado, os atalhos do Ubuntu sempre funcionam, exceto quando IDEA et al. tem foco.

Eu tenho uma coleção de atalhos específicos do JetBrains aqui ; entrada é apreciada.

    
por Raphael 22.12.2016 / 14:32
fonte
2

Apenas para expandir um pouco a excelente resposta do AzkerM:

% bl0ck_qu0te%   
  • Altere ou desative a ação Redimensionar janela, atribuída a Alt + F8 (avaliar expressão)      % bl0ck_qu0te%
  •        
    por WillC 24.02.2016 / 12:15
    fonte
    1

    Estou executando o Ubuntu 16.04 e o que estava acontecendo foi quando usei esses pressionamentos de tecla (ctrl-alt-left / right), a janela estava sendo redimensionada e posicionando-se à direita ou à esquerda da minha tela. Eu tentei desativar essas combinações de teclas em: Configurações / Teclado / Navegação, mesmo que eu não tenha espaços de trabalho ativados. Ainda não impediu o comportamento que eu estava vendo.

    Felizmente, abri o Compiz e deparei com o plug-in Window Management / Grid que estava mapeando essas chaves para colocar janelas em uma posição de grade. Desativei este plug-in e agora meus atalhos de teclas IntelliJ funcionam bem com ctrl-alt-left / right.

        
    por Jason White 14.06.2016 / 00:08
    fonte
    1

    Apenas uma solução rápida:
    Se você tiver uma chave " Windows " no seu teclado, basta adicioná-la à combinação inteira de atalhos - ela deve funcionar. Por exemplo:

    • Ctrl + Win + Alt + T (Surround com)
    • Win + Alt + F8 (expressão de avaliação )
    por guzoff 28.11.2017 / 21:53
    fonte
    0

    Eu uso o Xneur para alternar texto digitado para outro idioma. Meu idioma do sistema é controlado por Ctrl + Shift o que bloqueia teclas de atalho do Intellij como Ctrl + Shift + F (pesquisa global) e Ctrl + Shift + C (comentário). Então, o turno da esquerda é ignorado.

    • Uma solução é alterar o idioma usando Ctrl_L + Shift_L e uso Ctrl_R + Shift_R para Intellij . Mas é algum tipo de desconforto.

    • A outra solução é usar o Xneur ( sudo ap-get install xneur ) para redigite o texto digitado incorretamente em outro idioma. Você pode desativar qualquer alteração de langauge do sistema e atribuí-la a teclas de atalho xneur (o mesmo Ctrl+Shift ). O Xneur pode ser adicionado a aplicativos autogerados.

    por Zon 04.09.2018 / 07:28
    fonte
    0

    Para o Ubuntu 16.04 vá para configurações > Teclado e encontrar a combinação específica em conflito com o seu clique desejado e atualize a combinação para uma nova.

        
    por Cengkuru Michael 29.10.2017 / 10:22
    fonte