14.04 - 16.04 falhou; apt (= 1.0.1ubuntu2.13) 'não está instalado

51

(Esta questão não foi resolvida. Devido a restrições de tempo, o computador foi restaurado para as configurações de fábrica.)

Eu estava tentando atualizar de 14.04 para 16.04, mas apt jogou este erro:

The required dependency 'apt (>= 1.0.1ubuntu2.13)' is not installed.

O que isso significa e como posso corrigi-lo?

Quando eu digito o comando apt-cache policy apt

[email protected]:~$ apt-cache policy apt apt:
Installed: 1.0.1ubuntu2.11
Candidate: 1.0.1ubuntu2.11
Version table:
*** 1.0.1ubuntu2.11 0
100 /var/lib/dpkg/status
1.0.1ubuntu2 0
500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 
Packages

O erro acontece quando eu executo o comando:

sudo do-release-upgrade -d

e produz o seguinte:

Checking for a new Ubuntu release
Get:1 Upgrade tool signature [198 B]
Get:2 Upgrade tool [1,265 kB]
Fetched 1,265 kB in 0s (0 B/s)
authenticate 'xenial.tar.gz' against 'xenial.tar.gz.gpg'
extracting 'xenial.tar.gz'

Reading cache

Checking package manager
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done

Required depends is not installed

The required dependency 'apt (>= 1.0.1ubuntu2.13)' is not installed.
    
por Shageenth Sandrakumar 24.05.2016 / 22:45

3 respostas

45

Eu tive exatamente o mesmo problema hoje. Certifique-se de que sua versão é a mais recente versão do Ubuntu 14.04 antes da atualização. (Ubuntu 14.04.4 neste momento)

O meu ficou preso ao Ubuntu 14.04.3 devido a um mau espelho.

Então, primeiro execute:

sudo apt update
sudo apt dist-upgrade

Verifique se a versão é agora Ubuntu 14.04.4 (atualização de setembro de 2016: Ubuntu 14.04.5 ).

cat /etc/lsb-release

E inicie a instalação do Ubuntu 16.04 com

sudo do-release-upgrade -d
    
por cnxsoft 25.05.2016 / 08:56
10

Melhor sempre atualizar através dos procedimentos normais de:

sudo apt update
sudo apt dist-upgrade

Se o acima falhar, você pode passar manualmente pelo seguinte. Esta questão está desatualizada, mas você pode apenas alterar os números de versão, pois os links ainda devem ser os mesmos.

Para atualizar sua versão de apt de uma janela de terminal, digite o seguinte:

sudo apt-get download apt

Se o acima não funcionar, você também pode fazer o download com wget executando a seguinte linha:

wget http://security.ubuntu.com/ubuntu/pool/main/a/apt/apt_1.0.1ubuntu2.17_amd64.deb

digite

sudo dpkg -i apt*.deb

Apenas tentei isso no meu sistema aqui. Aqui está a saída:

[email protected]:~$ sudo apt-get download apt
[sudo] password for terrance: 
Get:1 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main apt amd64 1.0.1ubuntu2.17 [954 kB]
Fetched 954 kB in 0s (1,127 kB/s)
[email protected]:~$ ls
apt_1.0.1ubuntu2.17_amd64.deb  Documents  examples.desktop  Pictures  Templates
Desktop                        Downloads  Music             Public    Videos
[email protected]:~$ sudo dpkg -i apt*.deb
(Reading database ... 168376 files and directories currently installed.)
Preparing to unpack apt_1.0.1ubuntu2.17_amd64.deb ...
Unpacking apt (1.0.1ubuntu2.17) over (1.0.1ubuntu2.11) ...
Setting up apt (1.0.1ubuntu2.17) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.7) ...

Se, após os passos descritos, você vir uma falha devido a uma dependência do dpkg ausente, basta concluir os passos com dpkg e ..

wget http://security.ubuntu.com/ubuntu/pool/main/d/dpkg/dpkg_1.18.24ubuntu1_amd64.deb
sudo dpkg -i dpkg_1.18.24ubuntu1_amd64.deb

Todos os pacotes disponíveis para o Ubuntu podem ser encontrados aqui:

link

    
por Terrance 25.05.2016 / 01:02
0

Solução simples ... que funcionou para mim ...

Abra o seu gerenciador de pacotes Synaptic digite "apt" na caixa de busca que mostrará a versão atual instalada do apt. Vamos supor que "1.0.1ubuntu1.13" é só clicar com o botão direito e clicar em Marcar para atualizar. topo.

após a atualização ..

Certifique-se de fechar o gerenciador de pacotes synaptic antes de executar o seu

comando final

sudo do-release-upgrade  

e deve funcionar ..

    
por jax 06.09.2017 / 12:49