Como posso desativar o Bluetooth na inicialização do sistema?

283

Como posso desativar o Bluetooth na inicialização do sistema?

    
por Floqqi 16.10.2011 / 23:02
fonte

29 respostas

190

18.04+ usuários que não possuem um /etc/rc.local, você precisará criar um e torná-lo executável. Para facilitar as coisas, basta colar o seguinte comando em um terminal:

sudo install -b -m 755 /dev/stdin /etc/rc.local << EOF
#!/bin/sh
rfkill block bluetooth
exit 0
EOF

Execute sudoedit /etc/rc.local e adicione isso antes da linha com exit 0 :

rfkill block bluetooth

Você ainda deve ser capaz de ativar o Bluetooth através do miniaplicativo da barra superior.

Isso deve funcionar para a maioria dos sistemas, mas parece que existem alguns bugs ocultos na ACPI do kernel para Thinkpads. Se você estiver em um Thinkpad, inclua o seguinte em /etc/rc.local :

echo disable > /proc/acpi/ibm/bluetooth

Ou confira o ibm-acpi - Driver IBM ThinkPad ACPI Extras - alguns relatórios sugerem que o ibm-acpi inclui o controle bluetooth (entre outras coisas agradáveis). Mas eu não tenho o hardware, então estou completamente impossibilitado de verificar essas afirmações. Boa sorte.

    
por Oli 18.08.2010 / 11:00
fonte
76

Eu encontrei um tutorial com uma "solução alternativa" limpa aqui ( link do arquivo para a posteridade)

Mudar realmente /etc/bluetooth/main.conf foi o suficiente para mim.

Do artigo:

Procure a entrada:

InitiallyPowered = true

e altere o valor para:

InitiallyPowered = false

Foi o suficiente para mim, embora o artigo descreva alguns outros passos que podem ou não ser necessários.

Em Ubuntu 17.10 e Ubuntu 18.04 , a opção InitiallyPowered foi substituída por AutoEnable

    
por Stepbaer 25.06.2012 / 20:00
fonte
23

Para desativar o carregamento do driver bluetooth na inicialização:

sudo $EDITOR /etc/modprobe.d/blacklist.conf

adicione:

blacklist btusb

A ativação posterior deve ser apenas:

sudo modprobe btusb
    
por maco 18.08.2010 / 18:59
fonte
16

Passo 1: Vá para o terminal e digite o seguinte comando para editar o arquivo /etc/rc.local do sistema:

gksudo gedit /etc/rc.local

Etapa 2: adicione a seguinte linha antes da linha exit 0 :

rfkill block bluetooth
    
por Varun 04.05.2012 / 22:44
fonte
13

Do Ubuntu 16.04 em diante, o systemd gerencia serviços de inicialização como o bluetooth ... para visualizar o problema atual de status, seguindo um terminal

sudo systemctl status bluetooth.service 

para desativar o bluetooth durante a inicialização,

sudo systemctl disable bluetooth.service

em seguida, na próxima reinicialização, o bluetooth não estará ativo ... para ativar o problema do bluetooth

sudo systemctl enable bluetooth.service
    
por Scott Stensland 01.08.2017 / 17:08
fonte
7

Digite o seguinte em um terminal:

sudo gedit /etc/modprobe.d/blacklist.conf

Na parte inferior do arquivo, adicione a linha:

blacklist bluetooth

Salve o arquivo e reinicie - o Bluetooth agora deve estar desativado.

    
por Nathan Osman 16.10.2011 / 23:25
fonte
7

Você pode alterar os serviços iniciados na inicialização com a ajuda de BUM .

Instale: sudo apt-get install bum

Executar: sudo bum

Desmarque a caixa e clique em Aplicar .

    
por desgua 05.05.2012 / 02:09
fonte
6

1. bloquear bluetooth em rc.local

Adicione esta linha no final do arquivo /etc/rc.local logo antes da linha exit 0 :

rfkill block bluetooth

Isso fará o truque, mas apenas em versões antigas do Ubuntu usando o upstart .

2. reencaminhamento rc.local no systemd

No Ubuntu 15.10 com systemd como gerenciador de inicialização, o arquivo /etc/rc.local não é mais usado por padrão, então chame isso em um terminal:

sudo systemctl edit --full rc-local

O que abre um editor. No final do arquivo eu adicionei:

[Install]
WantedBy=multi-user.target

Essas alterações são ativadas por

sudo systemctl reenable rc-local

Agora, o arquivo /etc/rc.local é usado como você o conhece.

3. desativar o blueman-applet no início

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/blueman.desktop
gnome-session-properties

Agora o blueman-applet é visível e você pode desativá-lo nos programas de inicialização

4. Reinicialize para ver o efeito

    
por rubo77 10.11.2015 / 13:29
fonte
5

Acho que a melhor maneira é desabilitar o serviço de ser iniciado em primeiro lugar. Existe um método geral para desativar serviços que funciona perfeitamente:

sudo sh -c "echo 'manual' > /etc/init/bluetooth.override"

Isso funciona para o Ubuntu 13.10 e provavelmente também para versões anteriores.

    
por Felipe 18.01.2014 / 10:49
fonte
5

Eu adiciono

"/etc/init.d/bluetooth stop"

em

"/etc/rc.local" 

antes do comando "exit 0" para inicialização com o bluetooth desativado.

    
por Saeed Zarinfam 23.08.2012 / 15:00
fonte
4

Você pode editar suas configurações de update-rc.d . Eu usei algo parecido com:

sudo update-rc.d bluetooth remove

No Debian Wheezy. Confira man update-rc.d para mais informações sobre como usá-lo.

    
por Keith Smiley 13.02.2013 / 16:50
fonte
2

Talvez você possa desativá-lo nos aplicativos de inicialização. Mas esses aplicativos estão ocultos por padrão. Mostrar os aplicativos de inicialização ocultos em 12.04: Abra o terminal e execute estes dois comandos:

cd /etc/xdg/autostart/

sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop

Agora você pode desmarcar o bluetooth. (Não remova!)

    
por schiemanski 05.05.2012 / 10:50
fonte
2

Não. Nem sempre está na lista de aplicativos de inicialização. Acho que a melhor solução é adicionar o comando rfkill no script rc.local ou definir o parâmetro InitiallyPowered em /etc/bluetooth/main.conf .

    
por Robert 05.05.2012 / 02:06
fonte
2

1) Instale o pacote smbios-utils e adicione-o a Aplicativos de inicialização com:

sudo smbios-wireless-ctl --bt 0

2) No tipo de terminal:

sudo visudo

e adicione ao final do arquivo aberto /etc/sudoers da linha:

<your username> ALL = NOPASSWD: /usr/sbin/smbios-wireless-ctl

3) Para ligar o bluetooth durante a sessão, execute no terminal:

sudo smbios-wireless-ctl --bt 1

Isso funciona para mim no meu Dell D630 com o Ubuntu 13.10

    
por victor 15.03.2014 / 16:58
fonte
2

No Ubuntu 16.04, simplesmente desabilitei o serviço de iniciar usando systemctl.

Para fazer isso, abra uma janela de terminal e digite o seguinte:

sudo systemctl disable bluetooth

Você pode reinicializar, pois agora o Bluetooth será desativado ao inicializar ou, se você não quiser reinicializar e quiser interromper o Bluetooth imediatamente, digite:

sudo service bluetooth stop

    
por Ken 22.08.2017 / 05:57
fonte
2

Podemos desativar o início automático do Bluetooth dessa maneira:

sudo gedit /etc/bluetooth/main.conf

( gedit é meu editor fav, você pode substituir isso por xed ou o que estiver instalado em seu sistema.)

Na parte inferior desse arquivo, há essa linha:

#AutoEnable=false

Cancele comentários, assim:

AutoEnable=false
    
por Shayan 20.02.2018 / 15:47
fonte
1

Eu estou usando o Sputnik Kernel , que corrigiu isso no meu Dell Inspiron 14R N4110.

    
por Alex Wiedermann 25.09.2012 / 01:53
fonte
1

Acho que você deveria editar

/etc/default/bluetooth

e defina

BLUETOOTH_ENABLED=0

para desativar o serviço bluetooth na inicialização

    
por Fabio 06.03.2014 / 21:17
fonte
1

No Ubuntu Studio 16.04 você pode desativar o Applet Bluetooth na inicialização em:

% bl0ck_qu0te%

Aqui você pode clicar no campo para desativá-lo.

    
por ateymuri 26.08.2016 / 20:05
fonte
1

Para aqueles de você onde inserir a linha rfkill block bluetooth (ou qualquer outra) em /etc/rc.local não funcionar, tente incluir a mesma linha no final de ~/.bashrc

Na minha configuração (Ubuntu 14.04, Thinkpad W540), nenhuma opção funcionava inserindo-o em /etc/rc.local , mas o primeiro funcionava no bashrc. Observe que isso funcionará apenas para o usuário atual, não globalmente para todos os usuários.

    
por Sam 19.10.2014 / 14:10
fonte
0

Eu adiciono

"/etc/init.d/bluetooth stop"

em

"/etc/rc.local" 

antes do comando "exit 0" para inicialização com o bluetooth desativado.

    
por Saeed Zarinfam 23.08.2012 / 15:05
fonte
0

Solução para meu caderno

"BIOS - Configuração USB - EHCI2: desativado"

EHCI1 é para portas USB (na verdade, Meu notebook tem 2 portas USB 2.0)

    
por MSP 27.03.2014 / 19:46
fonte
0

Edite o /etc/default/grub :

sudo nano /etc/default/grub

e altere a seguinte linha:

GRUB_CMDLINE_LINUX=""

para dizer isso:

GRUB_CMDLINE_LINUX="bluetooth.blacklist=yes"

Em seguida, atualize o grub e reinicie:

sudo update-grub
    
por mchid 21.09.2015 / 07:58
fonte
0

Se você estiver usando o miniaplicativo Bluetooth no painel superior (blueman-applet), ele terá sua própria configuração que ativará o Bluetooth automaticamente, mesmo que você o tenha desativado em outros lugares (como / etc / bluetooth / main .conf ou / etc / default / tlp).

Para evitar que o Bluetooth seja ativado na inicialização usando a linha de comando:

gsettings set org.blueman.plugins.powermanager auto-power-on false

Ou através da GUI:

  1. Clique no miniaplicativo Bluetooth > Plugins > PowerManager > Configuração
  2. Desmarque a opção Auto power on

Na próxima vez que você reinicializar, o applet Bluetooth ainda estará visível, mas o Bluetooth estará desativado. Para ativá-lo:

Clique no miniaplicativo Bluetooth > Ativar Bluetooth

    
por bmaupin 27.07.2018 / 19:12
fonte
0

Isso deve impedir que o bluetooth inicie em sistemas baseados no Debian:

sudo chkconfig bluetooth off

ou em sistemas baseados em RedHat

systemctl disable bluetooth.service
    
por Stanislav 16.10.2017 / 22:18
fonte
0

Desde o Ubuntu 18.04 (com o GNOME) você precisa

  1. Edite /etc/bluetooth/main.conf e encontre

    AutoEnable = true
    

    e altere o valor para:

    AutoEnable = false
    

    Portanto, este dispositivo não está ligado no arranque.

  2. Edite o / etc / default / tlp e encontre:

    #DEVICES_TO_DISABLE_ON_STARTUP="bluetooth wifi wwan"
    

    Edite esta linha para ler:

    DEVICES_TO_DISABLE_ON_STARTUP="bluetooth"
    

    Portanto, este dispositivo está desativado na inicialização.

  3. Em seguida, abra o Dash e procure por "Aplicativos de inicialização". Desmarque todos os itens relacionados ao Bluetooth na lista. Clique em [Fechar] para salvar.

por naXa 25.10.2018 / 07:31
fonte
-1

Eu tive que usar um método de força bruta para impedir que o bluetoothd fosse iniciado automaticamente na inicialização. Eu renomeiei o executável para que ele não fosse encontrado.

    
por bluesdiva2001 06.07.2012 / 03:02
fonte
-1

Você também pode usar este aplicativo gráfico que também faz esse gerenciador de bluetooth

    
por deFreitas 27.12.2014 / 14:26
fonte
-3

Você precisa desativá-lo na lista de aplicativos de inicialização nas Configurações do sistema.

Clique no cog no canto superior direito da barra de menus e selecione Configurações do sistema.

Clique em Start Up Applications e role para baixo até encontrar a configuração do bluetooth, tire o carrapato da caixa e pronto.

    
por Mark Rooney 16.10.2011 / 23:13
fonte