Não é possível mudar mais da Intel para a GPU NVIDIA

41

[Ubuntu 14.04 64 bits]

Depois de alternar entre os gráficos Intel / NVIDIA e os diferentes drivers NVIDIA, de repente estou preso à Intel GPU. Não costumava haver nenhum problema em alternar entre os dois - não posso dizer com certeza o que de repente está causando o problema. Acho que a última coisa que fiz foi mudar para o driver "X.Org X server" - então algo quebrou. A mudança foi parte de mim tentando solucionar problemas com a configuração de uma tela secundária .

TodavezquetentomudarparaaNVIDIA,receboestamensagemdeerromuitoexpressivae,emseguida,elavoltaparaaIntel:/

Eupoderiausaralgumaajudaparasolucionarproblemasousugestõessobreoquetentar.

Atéagoraeu(un/re)instaleiosváriospacotes"nvidia-settings" / "nvidia-current" / "nvidia-current-updates" / "nvidia-331" / "nvidia-331-updates". Sem sucesso.

> lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107GLM [Quadro K2000M] (rev a1)

/etc/apt/sources.list: pode ser encontrado em pastebin.com

Em relação à sugestão de Qasim:

[email protected]~> sudo prime-select nvidia
[sudo] password for raffael: 
Error: alternatives are not set up properly
Error: nvidia mode can't be enabled
[email protected]~> sudo prime-select intel
Error: alternatives are not set up properly
Error: intel mode can't be enabled

Sobre a segunda sugestão de Qasim:

sudo apt-get purge nvidia*
[reboot]
sudo apt-get install nvidia-319-updates nvidia-settings-319-updates nvidia-prime
[reboot]
[tried to switch to NVIDIA]

Coisa estranha é - isso realmente funcionou na primeira vez! Então eu mudei de volta para a Intel - log off / on - Comutada de volta para a NVIDIA - log off / on - > sistema travado - erro como descrito acima.

Sobre a sugestão de Louis Matthijssen:

[email protected]:~$ sudo update-alternatives --set /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf /usr/lib/nvidia-331-updates-prime/ld.so.conf
update-alternatives: error: alternative name (/etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf) must not contain '/' and spaces
[email protected]:~$ ls -la /usr/lib/nvidia-331-updates-prime
total 44
drwxr-xr-x   2 root root  4096 Mai  2 22:45 .
drwxr-xr-x 196 root root 32768 Mai  3 10:57 ..
-rw-r--r--   1 root root     0 Apr  4 11:50 alt_ld.so.conf
-rw-r--r--   1 root root    60 Apr  4 11:50 ld.so.conf

Algo repetido duas vezes - não funcionou novamente: /

Agora parece funcionar:

[email protected]:~$ sudo update-alternatives --set x86_64-linux-gnu_gl_conf /usr/lib/nvidia-331-updates-prime/ld.so.conf 
update-alternatives: using /usr/lib/nvidia-331-updates-prime/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in manual mode

[email protected]:~$ sudo update-alternatives --set i386-linux-gnu_gl_conf /usr/lib/nvidia-331-updates-prime/alt_ld.so.conf
update-alternatives: using /usr/lib/nvidia-331-updates-prime/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in manual mode

Depois, eu poderia mudar para a NVIDIA - mas não foi oferecido o "NVIDIA X Server Settings" estendido - irá reiniciar agora e ver o que acontece. Acompanhamento: Ele mudou de volta para a Intel após a reinicialização e não pode alternar para a NVIDIA como de costume. Para mim, parece que o seu método, Louis, engana o sistema operacional, acreditando que ele usa a NVIDIA, enquanto isso não é o caso.

    
por Raffael 20.04.2014 / 15:15

6 respostas

18

Conforme você recebe o seguinte erro:

Error: alternatives are not set up properly

Você pode tentar definir as alternativas sozinho.

Quando eu alterno para a Intel, vejo:

update-alternatives: using /usr/lib/nvidia-331-prime/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in manual mode
update-alternatives: using /usr/lib/nvidia-331-prime/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in manual mode

Quando eu alterno para NVIDIA, vejo:

update-alternatives: using /usr/lib/nvidia-331/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in manual mode
update-alternatives: using /usr/lib/nvidia-331/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in manual mode

Você pode tentar mudar para Intel:

sudo update-alternatives --set x86_64-linux-gnu_gl_conf /usr/lib/nvidia-331-prime/ld.so.conf
sudo update-alternatives --set i386-linux-gnu_gl_conf /usr/lib/nvidia-331-prime/alt_ld.so.conf

Obviamente você deve substituir 331 pela sua própria versão.

Agora você pode tentar algumas coisas para acionar a mudança:

  • Faça logout e faça login novamente

    para reiniciar o servidor X como você faria normalmente

  • Reinicie todo o seu PC

    para o mesmo propósito do acima

  • Executar sudo prime-select nvidia

    como suas alternativas estão agora definidas para a Intel, espero que isso também corrija quaisquer outras configurações para que tudo esteja como deveria ser novamente (obviamente você ainda deve reiniciar o servidor X)

Espero ter interpretado o erro corretamente.

Além disso, você pode usar prime-select query para verificar qual placa está selecionada no momento e corrigir as alternativas para essa placa (por exemplo, NVIDIA), pois você pode ter alternativas para a outra placa (por exemplo, Intel), mas ferramenta ainda está pensando que você está usando o outro cartão (por exemplo NVIDIA), dando assim um erro dizendo que as alternativas não estão configuradas corretamente.

    
por Louis Matthijssen 03.05.2014 / 21:21
5

Acho que encontrei uma solução pelo menos .

É tudo sobre update-alternatives .
Eu notei que ambos

sudo update-alternatives --config i386-linux-gnu_gl_conf

e

sudo update-alternatives --config x86_64-linux-gnu_gl_conf

retorna a lista contendo /usr/lib/i386-linux-gnu/mesa/ld.so.conf ou similar.

De alguma forma, após cada reinicialização, o /usr/lib/i386-linux-gnu/mesa/ld.so.conf foi definido como escolhido, mesmo que eu tenha alterado antes manualmente.

Eu tentei alterar a ordem nessa lista, mas finalmente a solução foi removê-la por

sudo update-alternatives --remove x86_64-linux-gnu_gl_conf /usr/lib/x86_64-linux-gnu/mesa/ld.so.conf

e

sudo update-alternatives --remove i386-linux-gnu_gl_conf /usr/lib/i386-linux-gnu/mesa/ld.so.conf

Isso deve ser o suficiente.
Caso contrário, defina 'i386' e 'x86_64' para a mesma opção por

sudo update-alternatives --config x86_64-linux-gnu_gl_conf

e

sudo update-alternatives --config x86_64-linux-gnu_gl_conf

Reinicie depois.

Você sempre pode restaurá-lo para o estado original por

sudo update-alternatives --install /etc/ld.so.conf.d/i386-linux-gnu_GL.conf i386-linux-gnu_gl_conf /usr/lib/i386-linux-gnu/mesa/ld.so.conf 500  

e

sudo update-alternatives --install /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf x86_64-linux-gnu_gl_conf /usr/lib/x86_64-linux-gnu/mesa/ld.so.conf 500

Espero que também funcione para você.

    
por kcpr 29.01.2015 / 18:31
4

o que funcionou para mim, eu ainda estou tentando encontrar o seu post. Eu tinha tantos que eu estava vendo:

Aqui, isso é o que funcionou para mim:

Eu tentei:

sudo update-alternatives --config x86_64-linux-gnu_gl_conf
sudo ldconfig -n
sudo update-initramfs -u

e reiniciado, sem alterações. Então eu tentei:

sudo apt-get purge libvdpau-va-gl1 bumblebee* nvidia*
sudo apt-get install linux-headers-generic
sudo apt-get install nvidia-331 nvidia-settings nvidia-prime

Reinicie. Ainda assim, não há alterações, e a mesma mensagem de erro em branco na nvidia configurações quando eu tento mudar para mim cartão nvidia.

Eu tentei mudar manualmente, usando sudo prime-switch nvidia , e as informações de configuração foram atualizadas. Eu tentei novamente, e nvidia-settings me pediu para sair e entrar novamente e ... voilà! Eu trabalhei!

No meu caso, parece que antes de poder mudar usando a interface do usuário nvidia, eu tive que mudar manualmente primeiro como superusuário, para gerar a configuração correta!

Ainda bem que tentei, ou ainda estaria mexendo, instalando outros drivers! Espero que isso seja útil para outra pessoa!

    
por Michael 26.08.2014 / 05:54
4

siga as respostas pré, esta é a maneira como eu acertei no meu linux mint 17.2.

primeiro eu faço:

sudo update-alternatives --config x86_64-linux-gnu_gl_conf

selecione aquele com 'nvidia-prime':

sudo prime-select nvidia

depois reinicie:

sudo init 6
    
por realhu 12.09.2015 / 12:56
1

Eu tive um problema que parecia o mesmo, e a resposta foi que eu ainda tinha bumblebee-nvidia instalado.

Observe que você está eliminando "tudo NVIDIA" com sudo apt-get purge nvidia* , e o pacote acima não corresponde ao curinga.

Então, execute o comando:

apt-get purge bumblebee-nvidia nvidia*

Em seguida, reinicialize e instale os pacotes nvidia-xxx , nvidia-settings e nvidia-prime relevantes (atualmente, estou usando a versão 340.24 de xorg-edgers ).

Agora, durante esta instalação, você verá as mensagens update-alternatives relevantes sobre os arquivos *gnu_gl_conf .

    
por Dmitry 23.07.2014 / 14:59
0

Eu encontrei a solução.

Não sei qual foi exatamente o problema, mas esse problema parece ter desaparecido em uma nova instalação do 16.04. Talvez eles atualizaram as dependências corretamente? Não tenho certeza.

Mas posso confirmar pessoalmente que isso não é mais um problema em 16.04. Eu costumava ter o mesmo problema exato em 14.04. Mas agora com o 16.04 não é mais um problema.

    
por Rakshith Ravi 28.04.2016 / 14:41