Como configurar o cromo para abrir o URL do ímã com dilúvio?

36

Após a atualização para o Ubuntu 11.04 (natty) a partir de 10.10, não consigo mais abrir os links de ímã (torrent) no Chromium e configurar o dilúvio para abrir e aceitar automaticamente o URL.

(Editar: atualmente ".torrent" arquivos não são um problema, mas URL do ímã , por exemplo, do formulário " ímã:? xt = urn: ... ", agora são o único problema. Não tenho certeza se algo foi atualizado ...?)

Em vez disso, agora a transmissão somente abrirá automaticamente torrents , links magnéticos, etc. Não parece haver uma maneira de definir o dilúvio como o cliente de torrent padrão . (E, também não parece haver uma configuração de "aplicativo padrão" para o cliente bittorrent substituir a transmissão com dilúvio).

Notas:

  • Encontrei alguns tópicos antigos sobre esse assunto e apenas um um ou two mais novos. Os tópicos mais recentes parecem sugerir que o xdg-open é o culpado. Mas muitas pessoas não parecem se deparar com esse problema, então ... talvez seja só eu?
  • Não usando o firefox, então configurar manualmente os aplicativos para mime-types ou extensões não funciona (isso não é uma opção em chrome / chromium, afaik - você precisa confiar no SO)
  • Desinstalei a transmissão e, basicamente, nada aconteceu ao clicar em links de torrent / ímã.
  • a execução a partir do shell também abre a transmissão (não o dilúvio): xdg-open "magnet:? xt = urn: bt .. & tr = http: //tracker.....com/announce"

Meus manipuladores de URL atuais são:

$ gconftool -a /desktop/gnome/url-handlers/magnet
command = deluge "%s"
needs_terminal = false
enabled = true

A única solução alternativa que tenho (que funciona) é renomear /usr/bin/transmission-gtk{,.bak} e criar meu próprio / usr / bin / transmission-gtk:

$ cat /usr/bin/transmission-gtk
#!/bin/bash
deluge "[email protected]"

Alguém se depara com isso, sabe de um bug, solução alternativa ou ...?

    
por michael 24.05.2011 / 09:44

16 respostas

17

A resposta é na verdade um erro no empacotamento de dilúvio (ou, talvez o dilúvio seja o mesmo e tudo o mais mudou em torno dele ... depende da sua perspectiva, eu acho.) Veja o tópico do fórum aqui para detalhes.

Basicamente, configurar o xdg-open através do gconf-editor não fez nada para resolver o problema, já que a partir do Natty a funcionalidade file-open é gerenciada pelo gvfs-open, que não usa gconf settings. Em vez disso, o gvfs-open examina os arquivos ".desktop" que acompanham cada aplicativo para determinar quais tipos de arquivos podem ser manipulados (se não estiver instalado, execute sudo apt-get install gvfs-bin ).

Na postagem no fórum, o arquivo /usr/share/applications/deluge.desktop tem alguns problemas; ele deve dizer Exec=deluge-gtk %U (em vez de apenas " Exec=deluge-gtk" ) para que o argumento seja passado para o aplicativo. Segundo, em vez de apenas MimeType=application/x-bittorrent; , ele deve dizer MimeType=application/x-bittorrent;x-scheme-handler/magnet; .

A atualização deve chegar em breve ... Aqui está o link para o atualizou o arquivo desktop se você quiser fazer a alteração você mesmo; basta executar sudo update-desktop-database e tudo começa a funcionar (nem precisa reiniciar o chrome / cromo).

    
por michael 30.05.2011 / 11:16
32

Para 12.04 até 16.04

Em 12.04 e 13.04, dilúvio inclui x-scheme-handler/magnet=deluge.desktop; no arquivo da área de trabalho. No meu caso, a transmissão ainda estava abrindo os links magnéticos. Eu tive que dizer gvfs-open para preferir o dilúvio com:

gvfs-mime --set x-scheme-handler/magnet deluge.desktop

18,04

gvfs-mime foi reprovado e 'gio mime' foi usado:

gio mime x-scheme-handler/magnet deluge.desktop
    
por andrewsomething 10.03.2012 / 05:34
8

Ubuntu

Recentemente, também é necessário adicionar a seguinte linha a ~ / .local / share / applications / mimeapps.list em [Associações adicionadas]

x-scheme-handler/magnet=deluge.desktop;

Kubuntu

No Kubuntu, no entanto, você precisa criar o seguinte arquivo em ~ / .kde / share / kde4 / services / magnet.protocol

[Protocol]
exec=deluge "%u"
protocol=magnet
input=none
output=none
helper=true
listing=false
reading=false
writing=false
makedir=false
deleting=false

Observação: não esqueça de relogar após essas alterações.

    
por user163365 28.09.2011 / 21:36
4

Estou usando o Ubuntu 13.04 e, depois de instalar o Deluge, só preciso executar esse comando para que o Chromium use o Deluge para abrir ímãs:

xdg-mime default deluge.desktop x-scheme-handler/magnet

Espero que isso ajude:)

    
por jelies 04.06.2013 / 00:09
3

Eu fiz tudo isso e não funcionou.

Depois de ter tentado tudo o mais que vi, finalmente consegui abrir os links magnéticos em deluge não apenas alterando

MimeType=application/x-bittorrent;

para

MimeType=application/x-bittorrent;x-scheme-handler/magnet;

em /usr/share/applications/deluge.desktop , mas também removendo

x-scheme-handler/magnet;

de /usr/share/applications/transmission-gtk.desktop antes de executar

sudo update-desktop-database
    
por simon 28.01.2012 / 16:23
2

Isso deveria ser um comentário, mas eu precisava fazer o upload de uma foto, então aqui vai:

  • Na minha configuração, tanto o FireFox 3.6 quanto o Chromium 11.0 abriram o Deluge

  • O Chromium pediu uma confirmação que nos dá uma dica do que está acontecendo:

Isso mostra que o Chromium NÃO inicia o Deluge diretamente ... ele depende de xdg-open para isso. O que significa que tudo que deve ser pesquisado (e corrigido) é o sistema operacional, não o Chromium. Nada para consertar ou alterar no navegador.

Isso não é uma resposta, mas vai concentrar seus esforços no lugar certo ... o que você precisa corrigir não tem nada a ver com o Navegador, mas com o SO.

    
por MestreLion 30.05.2011 / 11:18
2

Faça o download e instale este userscript . Agora você deve ser capaz de adicionar rapidamente arquivos torrent ao Diluvium 1.2+ WebUI no Chrome!

Testado em 11.10. Para outros sistemas operacionais, você deve experimentar a si mesmo, mas espero que também funcione bem neles.

    
por Espen Lossius 17.02.2012 / 19:52
1

No Ubuntu 10.04 com Deluge e chrome eu tive que fazer:

gconftool -t string -s /desktop/gnome/url-handlers/magnet/command "deluge-gtk '%s'"
    
por jpgunter 12.02.2012 / 02:24
1

Eu estou no 10.10, tentei um monte de coisas, foi isso que funcionou:

gconftool-2 -t string -s /desktop/gnome/url-handlers/magnet/command "/usr/bin/deluge-gtk %s"
gconftool-2 -s /desktop/gnome/url-handlers/magnet/needs_terminal false -t bool
gconftool-2 -t bool -s /desktop/gnome/url-handlers/magnet/enabled true
    
por IndigoSunrise 29.02.2012 / 08:58
1

Eu não acho que isso realmente resolve o problema, mas pelo menos funciona para mim (lubuntu 12.04):

  • Passe o mouse sobre o link magnético até que o endereço do ímã seja exibido na parte inferior da tela.
  • Clique com o botão direito e selecione "Copiar endereço do link".
  • Abra a transmissão e, em "Arquivo", selecione "Abrir URL".
  • Cole o URL na caixa e comece a fazer o download.

A propósito, temo que estou necropostando um pouco agora, mas as soluções acima não funcionaram para mim e minha resposta pode ser útil para outras pessoas, já que essa página foi o primeiro resultado quando pesquisei essa questão Google.

    
por theFlyingDutchman 06.07.2013 / 00:48
1

No Linux Mint 16 Petra, tive que editar o arquivo Transmissions.desktop na pasta de aplicativos, mas também em /usr/share/applications/mimeinfo.cache, em vez de mimeapps.list

Além disso, há outro arquivo mimeinfo.cache em /home/[user]/.local/share/applications que também pode ser editado, mas presumo que isso afetaria apenas o usuário atual, onde, como no pasta de aplicativos afeta todos os usuários.

Espero que isso ajude.

EDITAR:

Haa, parece que essa funcionalidade foi incorporada nas versões mais recentes do Deluge. Você pode ir para Editar - > Preferências - > Outros - > e associar links magnéticos padrão ao Dilúvio.

    
por Jake Mitchell 02.05.2014 / 23:07
0

Parece que agora os últimos lançamentos ( ppa ) do Dilúvio abordaram os pontos dos selecionados responda. No entanto, isso não resolveu meu problema com o Google Chrome não lançar o Torrents no meu Ubuntu Precise 12.04.

Em vez disso, parecia que o xdg-mime usado por xdg-open não estava definido corretamente. Eu encontrei aqui uma solução de trabalho. ou seja,

$ xdg-mime default deluge.desktop x-scheme-handler/magnet
$ xdg-mime default deluge.desktop application/x-bittorrent

Em seguida, uma verificação rápida

$ xdg-mime query default x-scheme-handler/magnet
deluge.desktop
$ xdg-mime query default application/x-bittorrent
deluge.desktop

E agora está funcionando bem.

    
por Antonio 12.04.2014 / 22:17
0

para mim, o que funcionou é que eu fui ao arquivo mimeapps.list e adicionei o tixati como o manipulador de ímã padrão - é muito fácil e funciona rápido.

Crie um link de atalho na área de trabalho do cliente bittorrent.

Vá para este arquivo - ** (pressione Ctrl + H) para mostrar / ocultar os arquivos da visualização ..

/home/.local/share/applications/mimeapps.list

Abra o arquivo -mimeapps.list - digite este texto  * manipulador de esquema x / ímã = tixati.desktop

clique em salvar no aplicativo.

Eu uso tixati para torrent. se você usar outro cliente bittorrent - basta substituir tixati por outro - por exemplo, vuze, dilúvio,. (baixe tixati de tixati.com)

Se você quiser escolher a transmissão, substitua o tixati por   transmission-gtk.desktop

    
por frank 02.11.2015 / 02:09
0

Aqui está a resposta do @michael_n em um script:

# rewrite deluge's .desktop file
sudo tee /usr/share/applications/deluge.desktop > /dev/null <<'EOF'
[Desktop Entry]
Version=1.0
Name=Deluge
GenericName=BitTorrent Client
X-GNOME-FullName=Deluge BitTorrent Client
Comment=Download and share files over BitTorrent
TryExec=deluge-gtk
Exec=deluge-gtk %U
Icon=deluge
Terminal=false
Type=Application
Categories=Network;FileTransfer;P2P;GTK
StartupNotify=true
MimeType=application/x-bittorrent;x-scheme-handler/magnet;
EOF

# set association and reload
gvfs-mime --set x-scheme-handler/magnet deluge.desktop
sudo update-desktop-database

Acordei para mim no ubuntu 15.10 com instalações padrão para chrome e dilúvio.

    
por Nicolas Marshall 05.05.2016 / 14:36
-1

Meu Chrome estava usando a Transmissão por padrão. Eu queria usar o qBittorrent. No Ubuntu 14.04 eu removi Transmission usando:

sudo apt-get purge transmission-gtk

Então eu 'manualmente' iniciei o qBittorrent e fechei novamente. Da próxima vez que cliquei em um link magnético, fui solicitado pelo Chrome a permitir que ele chamasse um aplicativo externo. Eu permiti isso e o chrome então acionou o qBitorrent.

Assim, se você não precisa ter mais de um cliente de torrent no seu PC, removendo os outros e deixando o que deseja, você pode forçar o Chrome a usar o cliente desejado. Um pouco de uma solução de Chuck Norris, mas funcionou para mim.

    
por TheGurkha 27.09.2014 / 22:52
-2
cd /usr/bin/

sudo sed 's/elif \[ x\"\$GNOME_DESKTOP_SESSION_ID\" \!\= x\"\" \]\; then DE\=gnome\;/elif [ x"$GNOME_DESKTOP_SESSION_ID" != x"" ]; then DE=gnome;\n    elif [ x"$MATE_DESKTOP_SESSION_ID" != x"" ]; then DE=gnome;/g' -i xdg-*

Trabalhei para mim (Mint Mate 16 Petra).

    
por Ben2talk 14.02.2014 / 17:08