Existem dois arquivos controlando a inicialização do X em uma instalação padrão do Ubuntu: /etc/init/gdm.conf e /etc/init/failsafe-x.conf . Enquanto o primeiro pertence ao pacote gdm , o segundo pertence a x11-common e será acionado se o GDM não iniciar, o que acontece em particular quando você remove o GDM.
No entanto, você não precisa remover pacotes para impedir que o GDM seja iniciado; o suficiente para dizer ao sistema upstart para não iniciá-lo:
- edite os arquivos
/etc/init/gdm.confe/etc/failsafe-x.conf(pode ser uma boa ideia fazer uma cópia de backup dos arquivos antes da edição) -
altere a sub-rotina
start on ...existente com uma condição que não é cumprida em seu ambiente padrão; por exemplo, você pode querer iniciar o X apenas em "runlevel 5", que é o que tradicionalmente outras distribuições de Linux faziam:start on runlevel [5] -
salve suas alterações e reinicie
A documentação completa sobre os arquivos de configuração iniciantes pode ser lida por man 5 init .