16.04 Problemas de conexão Wi-Fi LTS com o adaptador Realtek

113

Eu descobri vários problemas com a conexão Wi-Fi depois de instalar o 16.04 LTS.

Primeiro, o Wi-Fi não se reconecta normalmente após o modo de suspensão ou hibernação. Às vezes, o ícone da rede se transforma em "setas para cima e para baixo" (não sei para que serve) depois de acordar, mas ainda está conectado. Às vezes, a rede é simplesmente perdida e não exibe nenhuma rede na lista, então simplesmente não há como usar o wifi.

Primeiramente, tentei reiniciar o gerenciador de rede executando sudo service network-manager restart . Funcionou, mas não foi uma resolução permanente.

Então, de acordo com outro tópico, adicionei SUSPEND_MODULES="iwlwifi" a

/etc/pm/config.d/config

Depois de fazer isso, o problema de reconexão parece estar corrigido (pode reconectar-se automaticamente e o ícone não muda mais.) No entanto, acho que a conexão wi-fi é perdida aleatoriamente (a cada 30 minutos) mesmo quando o computador está em execução. o ícone de rede permanece o estado conectado quando a conexão é perdida.

Outro problema depois de adicionar o código é: quando coloco meu computador no modo de suspensão, a tela é desligada por um segundo, mas depois liga por cerca de 5 segundos (durante os quais o sistema cortará a conexão Wi-Fi). E então o computador irá dormir depois desse incomum processo "bifásico".

Plz encontra informações sobre cartões sem fio abaixo

*-network               
       description: Wireless interface
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 00
       serial: b0:c0:90:5c:1c:d5
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=4.4.0-21-generic firmware=N/A ip=192.168.0.8 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 ioport:d000(size=256) memory:df200000-df203fff

00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Sky Lake PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 06)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (2) I219-V (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation GK208 [GeForce GT 730] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GK208 HDMI/DP Audio Controller (rev a1)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
03:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller (rev 01)

05/01/2016 Atualização: Eu não sei o que aconteceu, mas a questão piora agora. A conexão Wi-Fi é perdida a cada 5 minutos e eu tenho que reconectar ou reiniciar o gerenciador de rede.

    
por Lixu 25.04.2016 / 07:13
fonte

9 respostas

42

Finalmente, consegui corrigir os problemas depois de experimentar vários métodos diferentes.

  1. Obtenha detalhes da sua placa PCI sem fio executando sudo lshw -class network
  2. Obtenha as informações do seu modelo de cartão de acordo com a linha de produtos.
    Por exemplo, como você pode ver na descrição da pergunta, diz product: RTL8723BE PCIe Wireless Network Adapter , então o modelo do meu cartão é RTL8723BE

    Ou product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller , então o modelo do meu cartão é RTL8101/2/6E

  3. Conceda a permissão sudo chmod 755 /etc/pm/config.d/

  4. Abra ou crie config e adicione SUSPEND_MODULES="rtl8723be" (substitua rtl8723be pelo seu próprio número de modelo)
    Em seguida, execute o echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
    Finalmente reinicie seu sistema.

Agora o seu sistema deve ser capaz de se reconectar automaticamente depois de dormir, e a conexão Wi-Fi nunca se perdeu uma vez para mim depois de fazer isso.

"As setas para cima / para baixo são provavelmente um bug do gerenciador de rede que resulta em um gerenciador de rede pensando que o dispositivo wifi é realmente ethernet.", de acordo com Jeremy31. veja as informações do bug aqui Você deve conseguir consertá-lo instalando o NetworkManager-1.2.0.

Obrigado ao Jeremy31 por fornecer as soluções.

    
por Lixu 06.05.2016 / 05:09
fonte
37

Eu tenho exatamente o mesmo problema. Depois de acordar do sono, o wifi ainda funciona, mas as redes não aparecem. Eu resolvo o problema reiniciando o gerenciador de rede.

sudo service network-manager restart

Ainda é muito chato. Espero que eles resolvam esse problema em breve.

    
por eldosoa 28.04.2016 / 06:25
fonte
30

Este é um bug com certeza. Bug foi arquivado em link

    
por Shinjan 02.05.2016 / 19:22
fonte
10

Informações adicionais: Eu tenho o mesmo problema exato descrito pelo OP, mas apenas o problema em que o ícone do applet nm é alterado para as setas e não exibe informações de Wi-Fi. O wifi ainda funciona quando isso acontece.

$ killall nm-applet && nm-applet & 

Faz o truque para fazer com que o ícone seja exibido novamente, por isso é apenas uma solução alternativa para o caso de alguém querer colocá-lo em um script.

Pode confirmar este problema em dois computadores separados que executam o pacote xubuntu-desktop.

Além disso, ambos os computadores eu executei recentemente placas wifi da Intel. (algo nos moldes do AC-7260)

    
por Joel Cressy 26.04.2016 / 04:40
fonte
6

Eu estava tendo o mesmo problema. Eu consertei o problema de suspender a sessão criando este script em /etc/systemd/system/wifi-resume.service (o que o OP postou só funcionou para a sessão ativa ; na reinicialização ele teve que ser chamado novamente):

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Em seguida, basta emitir este comando no terminal para ativá-lo: sudo systemctl enable wifi-resume.service . Esta solução é de outra pergunta do askubuntu answer , e funciona tanto depois de suspender e depois de reiniciar.

No entanto, mesmo depois que isso foi corrigido, recebo o mesmo comportamento que costumava acontecer na sequência da suspensão quando tento alternar as redes wi-fi : o wifi está essencialmente inativo, com as duas setas e o applet diz " dispositivo não pronto ." Posso reiniciar o Wi-Fi emitindo sudo service network-manager restart , mas não consigo alternar as redes.

Alguém mais está experimentando isso e / ou tem uma solução ???

    
por Rsync 29.04.2016 / 03:20
fonte
2

Estou usando o LinxuMint 18 Mate (ubuntu16.04) e entro no mesmo problema.

Todo o resto acima não funcionou para mim no meu thinkpad T440S.

A única solução que parece funcionar até agora é a atualização do kernel para 4.6.3

  • Vá para este site .

  • Obtenha os seguintes arquivos:

    linux-headers-4.6.3-040603-generic_4.6.3-040603.201606241434_amd64.deb
    linux-headers-4.6.3-040603_4.6.3-040603.201606241434_all.deb
    linux-image-4.6.3-040603-generic_4.6.3-040603.201606241434_amd64.deb
    
  • De um terminal, vá para a pasta que contém os arquivos acima e execute:

    sudo dpkg -i *.deb
    sudo reboot
    

Se você estiver usando o Virtualbox, execute este sudo /sbin/vboxconfig

Caso você queira removê-los, execute:

sudo dpkg --purge linux-headers-4.6.3-040603 linux-headers-4.6.3-040603-generic 

Depois de mais alguns testes, a situação é quase a mesma, consegui wifi, mas meu nm-applet não consegue ver todo o WIFI ao meu redor. Portanto, não tenho certeza se isso é uma boa solução alternativa: -)

    
por SteF 09.08.2016 / 11:28
fonte
2

Não há solução agora, mas encontrei um script que me ajudou a manter o WLAN:

#!/bin/bash

# Ping you most used DNS Server and reconnect on fail


while true; do
  if ! ping -c 1 -w 1 8.8.8.8 > /dev/null; then

    # with "sudo iwconfig" you can examine your name of 'wlan0'
    nmcli d connect wlan0

  fi
  sleep 2;
done

para iniciar automaticamente este script, basta abrir gnome-session-properties e adicioná-lo à lista.

O script completo (sem reconectar) pode ser encontrado em esta página da web .

    
por Steffomio 17.10.2016 / 21:28
fonte
1

Defina o código do país WIFI para o domínio regulatório atual do Kernels, se não estiver definido

iw reg get

Para definir

sudo nano /etc/default/crda
REGDOMAIN=<ISOCODE>

Reinicie.

    
por Janghou 11.05.2016 / 11:34
fonte
1

apenas para adicionar a resposta aceita (com quatro etapas)

por algum motivo, apenas um passo foi suficiente para mim, mesmo que eu não saiba o que isso significa:

echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
    
por nyxee 24.09.2017 / 02:13
fonte