Gravidade do erro PCIe Bus = Corrigido

37

Eu tenho um novo HP Pavilion Gaming Notebook e uma nova instalação do Ubuntu 16.04. Quando pressiono Ctrl + Alt + F1, começo a ver os erros mostrados na imagem a seguir e não consigo interagir com o console:

Eu também vejo esses erros por um tempo toda vez que eu inicializo. Eu preciso fazer Ctrl + Alt + F1 para acessar um terminal não gráfico para instalar alguns drivers da Nvidia. O que está acontecendo?

O que está causando o problema parece ser: Ponte PCI 00: 1c.5 [0604]: Porta Raiz # 6 do PCI Express Sunrise Point-H [8086: a115] (rev f1)

[email protected]:~$ lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Sky Lake Host Bridge/DRAM Registers [8086:1910] (rev 07)
00:01.0 PCI bridge [0604]: Intel Corporation Sky Lake PCIe Controller (x16) [8086:1901] (rev 07)
00:02.0 VGA compatible controller [0300]: Intel Corporation Skylake Integrated Graphics [8086:191b] (rev 06)
00:04.0 Signal processing controller [1180]: Intel Corporation Skylake Processor Thermal Subsystem [8086:1903] (rev 07)
00:14.0 USB controller [0c03]: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller [8086:a12f] (rev 31)
00:14.2 Signal processing controller [1180]: Intel Corporation Sunrise Point-H Thermal subsystem [8086:a131] (rev 31)
00:16.0 Communication controller [0780]: Intel Corporation Sunrise Point-H CSME HECI #1 [8086:a13a] (rev 31)
00:17.0 SATA controller [0106]: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] [8086:a103] (rev 31)
00:1c.0 PCI bridge [0604]: Intel Corporation Sunrise Point-H PCI Express Root Port #5 [8086:a114] (rev f1)
00:1c.5 PCI bridge [0604]: Intel Corporation Sunrise Point-H PCI Express Root Port #6 [8086:a115] (rev f1)
00:1c.6 PCI bridge [0604]: Intel Corporation Sunrise Point-H PCI Express Root Port #7 [8086:a116] (rev f1)
00:1f.0 ISA bridge [0601]: Intel Corporation Sunrise Point-H LPC Controller [8086:a14e] (rev 31)
00:1f.2 Memory controller [0580]: Intel Corporation Sunrise Point-H PMC [8086:a121] (rev 31)
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-H HD Audio [8086:a170] (rev 31)
00:1f.4 SMBus [0c05]: Intel Corporation Sunrise Point-H SMBus [8086:a123] (rev 31)
01:00.0 3D controller [0302]: NVIDIA Corporation GM107M [GeForce GTX 950M] [10de:139a] (rev a2)
07:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader [10ec:522a] (rev 01)
08:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 0a)
    
por João Abrantes 13.05.2016 / 18:15

2 respostas

50

Tente isso,

Use este link ( sobre o parâmetro de adição ao kernel aqui ) para entender sobre adicionar o parâmetro de inicialização do kernel temporariamente e torná-lo permanente. Então,

Adicione o parâmetro pci=nomsi

E reinicie.

Se o problema for resolvido, faça a alteração permanente. Se não funcionar, tente

pci=noaer

da mesma forma e torná-lo permanente, se isso funciona.

(* A razão para a aparência está relacionada aos recentes CPUs da arquitetura Intel Skylake e ao adaptador sem fio Realtek rtl8723be.

A equipe do ubuntu sabe disso. Leia mais aqui Erro de barramento Bug_track_ubuntu_PCIe )

    
por ankit7540 13.05.2016 / 18:33
6

Aqui já são fornecidas respostas que também me ajudaram muito. Eu uso o modo de texto do Ubuntu 16.04 e assim

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi"

não me ajudou. Aqui o que eu mudei foi - (em /etc/default/grub )

GRUB_DISTRIBUTOR='lsb_release -i -s 2> /dev/null || echo Debian'
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi"
GRUB_CMDLINE_LINUX="text pci=nomsi"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'vbeinfo'
#GRUB_GFXMODE=640x480

que resolveu meu erro (NOTA - usei apenas pci=nomsi , e caso não funcione outra opção é pci=noaer ), isso pode ajudar a resolver qualquer pessoa que esteja enfrentando o mesmo erro.

    
por Ujjal Kumar Das 17.06.2017 / 08:42

Tags