14.04 O touchpad é muito sensível

36

Meu touchpad é muito sensível. Enquanto escreve, o cursor salta de repente para o local onde o cursor do mouse está. Eu nem estou tocando o touchpad! Eu tive o mesmo problema com o 12.04 e recentemente fiz um upgrade para o 14.04, o que não resolveu o problema.

Nas configurações do mouse e touchpad, existem apenas configurações para um mouse, não para um touchpad. Eu tentei isso:

sudo apt-get install gsynaptics

gpointing-device-settings

que não ajudou.

Então eu encontrei este , que pode descrever o meu problema.

Mas eu fico preso no meio do caminho. Ao colocar isso no terminal:

(Adicione o patch ao módulo psmouse :)

sudo dkms add -m psmouse -v elantech-v6

Eu entendo isso:

  

Erro! Não foi possível encontrar o diretório de origem do módulo.   Diretório: / usr / src / psmouse-elantech-v6 não existe.

Alguém pode ajudar?

    
por user293817 15.06.2014 / 18:15

7 respostas

40

xinput list

fornecerá o nome do seu dispositivo (procure por TouchPad)

xinput list-props "Touchpad Name"

Isso fornecerá as propriedades disponíveis do seu touchpad. Você provavelmente descobrirá que a propriedade ainda é baseada em "Synaptics ...", o que significa que você digitaria algo como:

xinput set-prop "Touchpad Name" "Synaptics Finger" 50 90 255

Eu uso as seguintes propriedades (substitua Nome do touchpad pelo seu do comando xinput list ) para que meu reduza a sensibilidade geral:

xinput set-prop "Touchpad Name" "Synaptics Noise Cancellation" 20 20
xinput set-prop "Touchpad Name" "Synaptics Finger" 50 90 255

Os 2 comandos acima parecem fazer o truque para mim. Antes deles, meu touchpad estava basicamente inutilizável.

    
por Matthew Fisher 20.10.2014 / 04:00
8

Que tal este manual que tem uma lista de comandos que você supostamente pode usar. Os argumentos "50 90 225", conforme fornecidos nas outras respostas, são explicados nesses documentos para representar os valores de "low, high e press." Eu não sei o que meus valores originais eram, mas ... "Synaptics Finger" 5 16 225 tornou meu sistema tolerável.

    
por emmagras 29.10.2014 / 22:50
7

Eu tive um problema semelhante com o Toshiba C-50 Isso resolveu meu problema:

xinput list
xinput list-props "SynPS/2 Synaptics TouchPad" | grep -i finger
xinput set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Finger" 50 90 255

Aqui, o SynPS / 2 Synaptics TouchPad é o nome do seu touchpad que é listado quando você digita na lista xinput no terminal. Substitua SynPS / 2 Synaptics TouchPad pelo nome do seu dispositivo.

Fonte

    
por yask 15.06.2014 / 18:24
3

Existe uma ferramenta de linha de comando chamada synclient . Se você escrever man synclient no console, diz:

  

Este programa permite que você mude seu driver Synaptics TouchPad   para os parâmetros do servidor XOrg / XFree86 enquanto o X está sendo executado.

Há também uma GUI para a ferramenta, chamada gpointing-device-settings , mas não oferece quase tantas opções quanto a ferramenta de linha de comando. A única ressalva para usar a ferramenta de linha de comando é que existem tantas opções.

Você pode ler este artigo de Jack Wallen para saber mais detalhes.

    
por Hrvoje T 03.01.2016 / 22:58
3

A solução geral para esse problema não é reduzir a sensibilidade do touchpad, mas ativar a detecção de palma para que descansar a palma da mão durante a digitação não acione um clique. Por exemplo, eu tenho libinput instalado e coloquei o seguinte em /etc/X11/xorg.conf.d/90-libinput.conf :

Section "InputClass"                                                                                                                        
        Identifier "libinput touchpad catchall"                                                                                             
        MatchIsTouchpad "on"                                                                                                                
        MatchDevicePath "/dev/input/event*"                                                                                                 
        Driver "libinput"                                                                                                                   
        Option "Tapping" "True"                                                                                                             
        Option "PalmDetection" "True"                                                                                                       
        Option "TappingDragLock" "True"                                                                                                     
EndSection                                                                                                                                  

Para mais informações, confira estes outros posts relevantes:

por Andrew Mao 22.12.2017 / 00:19
0

Eu tive esse problema em muitas variantes do Linux. Atualmente estou no Elementary OS Loki. Eu tinha automatizado a correção desse problema criando o seguinte script de shell em /etc/X11/Xsession.d/56touchpadfix:

export 'xinput list | grep -i touchpad | awk '{ print  }''
xinput --set-prop "$id" "Synaptics Noise Cancellation" 20 20
xinput --set-prop "$id" "Synaptics Finger" 35 45 250
xinput --set-prop "$id" "Synaptics Scrolling Distance" 180 180
true

Você precisa ajustar os valores para o seu hardware. O meu trabalho para o portátil da série Sony SVS.

    
por Ganesh 27.11.2017 / 11:46
0

Se você tem um Dell, existe uma solução para isso. Isso também pode ser aplicável mesmo se você não tiver um laptop Dell, contanto que você atualize determinadas etapas. Eu tenho uma Dell Inpsiron 13 7000 series e a seguinte solução funcionou perfeitamente para mim.

Estas instruções vêm diretamente da Dell neste artigo Precisão / XPS: correção geral do problema do touchpad / mouse do Ubuntu . A questão parece ser que os drivers da Synaptics se sobrepõem aos da Dell. Você precisa desativar o Synaptics.

A primeira parte fez maravilhas por mim. Aqui está o script que eles sugerem adicionar a sudo gedit /usr/share/X11/xorg.conf.d/51-synaptics-quirks.conf . Não recomendo seguir as soluções da resposta aceita, pois essa rota parece criar outros problemas.

# Disable generic Synaptics device, as we're using
# "DLL0704:01 06CB:76AE Touchpad"
# Having multiple touchpad devices running confuses syndaemon
Section "InputClass"
    Identifier "SynPS/2 Synaptics TouchPad"
    MatchProduct "SynPS/2 Synaptics TouchPad"
    MatchIsTouchpad "on"
    MatchOS "Linux"
    MatchDevicePath "/dev/input/event*"
    Option "Ignore" "on"
EndSection

Para comparação de compatibilidade, tenho um Dell Inspiron 13 série 7000 com xinput list

[email protected]:~$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                     id=10   [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                     id=11   [slave  pointer  (2)]
⎜   ↳ ELAN Touchscreen                          id=13   [slave  pointer  (2)]
⎜   ↳ DELL0741:00 06CB:7E7E Touchpad            id=14   [slave  pointer  (2)]
...

O Synaptics não está nessa lista porque foi desativado pelo script acima. Antes de adicionar este script, sugiro executar xinput --test <id>" (para mim 14 ). Se você receber uma saída em um terminal, isso significa que seu dispositivo está funcionando (seu dispositivo está "ligado").

Após a reinicialização, você precisará instalar libinput com o seguinte comando sudo apt-get install xserver-xorg-input-libinput libinput-tools .

Após a instalação de libinput , você precisará atualizar sudo gedit /usr/share/X11/xorg.conf.d/90-libinput.conf de acordo com suas preferências. Aqui está o meu, por exemplo

# Match on all types of devices but tablet devices and joysticks
Section "InputClass"
        Identifier "libinput pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
    Option "Tapping" "True"
    Option "TapingDrag" "True"
    Option "DisableWhileTyping" "True"
    Option "AccelProfile" "adaptive"
    Option "NaturalScrolling" "True"
    Option "AccelSpeed" "0.2"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

E é isso, não há mais touchpad sensível!

    
por Jon 14.05.2018 / 00:19

Tags