Autenticação PAM / Login

4

Estou tendo um pequeno problema no Ubuntu, onde qualquer comando que exija privilégios de root leva mais tempo para executar do que o normal. Consegui identificar o culpado para a causa depois de verificar meu /var/log/auth.log e acredito que tenha a ver com krb5 PAM para autenticação.

Não muito tempo atrás eu tinha instalado recentemente o SLiM, um Simple Login Manager para Ubuntu, que requer o uso do PAM para autenticar o login em uma conta de usuário a partir da tela de login principal. Eu só estou tentando descobrir como eu só posso ter PAM Authentications apenas para as telas de login principais e não para todo o sistema, porque a qualquer momento eu quero correr sudo do Terminal ou um diálogo de autenticação aparece para eu digitar senhas até 1-2 minutos apenas para autenticar um determinado comando ou tarefa.

Existe algum pacote específico de pam_krb5 que eu possa remover com segurança e que eu realmente não preciso consertar isso ou ...?

aqui está um pequeno resumo dos meus registros de autenticação.

Jan 31 15:43:59 VAIO polkit-agent-helper-1[26330]: pam_krb5(polkit-1:auth): authentication failure; logname=alkaris uid=1000 euid=0 tty= ruser=alkaris rhost=

Jan 31 15:44:00 VAIO polkit-agent-helper-1[26330]: pam_ecryptfs: pam_sm_authenticate: /home/alkaris is already mounted

Jan 31 15:48:42 VAIO sudo: pam_krb5(sudo:auth): authentication failure; logname=alkaris uid=1000 euid=0 tty=/dev/pts/4 ruser=alkaris rhost=

Jan 31 15:48:43 VAIO sudo: pam_unix(sudo:session): session opened for user root by alkaris(uid=0)

Jan 31 15:51:43 VAIO sudo: pam_unix(sudo:session): session closed for user root

Jan 31 15:51:46 VAIO sudo: pam_unix(sudo:session): session opened for user root by alkaris(uid=0)

Jan 31 15:51:46 VAIO su[26595]: pam_unix(su:session): session opened for user root by alkaris(uid=0)

Jan 31 15:52:26 VAIO su[26595]: pam_unix(su:session): session closed for user root

Jan 31 15:52:26 VAIO sudo: pam_unix(sudo:session): session closed for user root

Jan 31 15:53:56 VAIO sudo: pam_krb5(sudo:auth): authentication failure; logname=alkaris uid=1000 euid=0 tty=/dev/pts/4 ruser=alkaris rhost=

Jan 31 15:54:05 VAIO sudo: pam_unix(sudo:auth): authentication failure; logname=alkaris uid=1000 euid=0 tty=/dev/pts/4 ruser=alkaris rhost= user=alkaris

Jan 31 15:54:18 VAIO sudo: pam_krb5(sudo:auth): authentication failure; logname=alkaris uid=1000 euid=0 tty=/dev/pts/4 ruser=alkaris rhost=

Jan 31 15:55:33 VAIO sudo: pam_unix(sudo:session): session opened for user root by alkaris(uid=0)

Jan 31 15:56:55 VAIO sudo: pam_unix(sudo:session): session closed for user root

Jan 31 16:09:01 VAIO CRON[26694]: pam_unix(cron:session): session opened for user root by (uid=0)

Jan 31 16:09:02 VAIO CRON[26694]: pam_unix(cron:session): session closed for user root

Jan 31 16:17:01 VAIO CRON[26821]: pam_unix(cron:session): session opened for user root by (uid=0)

Jan 31 16:17:01 VAIO CRON[26821]: pam_unix(cron:session): session closed for user root

Jan 31 16:39:01 VAIO CRON[26956]: pam_unix(cron:session): session opened for user root by (uid=0)

Jan 31 16:39:01 VAIO CRON[26956]: pam_unix(cron:session): session closed for user root

se você precisar de uma impressão do que eu tenho atualmente instalado, em termos de pacote de autenticação do PAM, posso publicá-las.

    
por theguest 31.01.2014 / 06:24

1 resposta

1

Na verdade, o PAM está sempre ativado, mas você pode usar diferentes módulos de autenticação para diferentes serviços.

Se pam_krb5 não estiver sendo usado e for a causa dos problemas, você pode removê-lo (ou comentar) em /etc/pam.d/common-auth. pam_unix.so é o módulo de autenticação pam padrão.

Faça um backup do arquivo common-auth e deixe aberto um shell de root durante o teste para que você possa restaurar, se necessário. Cometer um erro nesse arquivo O bloqueará de sua máquina.

    
por 24.06.2014 / 09:33