Como eu desativo as atalhos de tecla F1 e F10 no gnome-terminal?

115

Como posso desativar as ligações de teclas F1 (ajuda) e F10 (menu de notificações)?

Primeiro eu preciso de utilitário de tela e segundo para sair de mc no console.

Não há tais ligações de teclas nas configurações do sistema Atalhos de teclado .

    
por Marko Kevac 27.04.2011 / 15:55
fonte

14 respostas

108

11,04

Desativando o atalho F1

  1. Em uma abertura do terminal gnome Editar ➜ Atalhos de teclado .

  2. Desça até o atalho Ajuda / Conteúdo , clique onde diz "F1" e pressione Backspace :

DesativandooatalhodoF10

  1. Instaleo compizconfig-settings-manager pacote.

    • Aviso:
  2. Abra o Gerenciador de configurações do CompizConfig .

    • Pressione Super para abrir o Dash, digite "Compiz" e pressione Enter
    • .
  3. Digite "unity" na entrada Filter e selecione o Ubuntu Unity Plugin .

  4. Clique no botão à direita da tecla para abrir o primeiro menu do painel e desmarque a caixa de seleção Ativado .

  5. IssodesabilitouoatalhoglobalF10,agoradesativaoatalhoF10dognome-terminal:

    • Emumgnome-terminal,abraAtalhosdeTeclados(Editar➜AtalhosdeTeclado)e
      desmarqueHabiliteatecladeatalhodomenu(F10porpadrão)

  6. F10 é mapeado para menubar_accel por algo no Ubuntu. Gnomo? Metacity Não sei exatamente o que é que rouba, mas a chave não chega ao Eclipse.

    • Execute o gconf-editor, navegue até / desktop / gnome / interface e role para baixo até menubar_accel e exclua o valor F10. [Stolen from here]
por Isaiah 23.06.2011 / 20:52
fonte
44

Desabilite F10 no terminal gnome em 12.04

Digite isto no console:

mkdir -p ~/.config/gtk-3.0
cat<<EOF > ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10"
}

* {
     gtk-key-bindings: NoKeyboardNavigation
}

EOF

Em seguida, feche todas as sessões do terminal. Agora deve funcionar como deveria (em mc , por exemplo).

por Paweł Gościcki 30.04.2012 / 21:25
fonte
23

inicie gconf-editor e siga /apps/gnome-terminal/keybindings/help

Descrição:

"Tecla de atalho para iniciar a ajuda. Expressa como uma string no mesmo formato usado para arquivos de recursos GTK +. Se você definir a opção para a string especial" disabled ", não haverá atalho de teclado para esta ação."

    
por Rinzwind 21.08.2011 / 22:28
fonte
7

Eu sou novo no Linux e essa tecla F10 me deixa louco. Todos os truques acima não funcionaram, mas eu encontrei agora uma solução (para o Ubuntu 11.10 com o Gnome 3 classic desktop). Em um terminal, digite o seguinte comando:

gsettings set org.gnome.desktop.interface menubar-accel ""

Com o dconf-editor, pode-se descobrir que o F10 realmente desapareceu. Note que esse tipo de truque parece ser altamente dependente da versão Gnome / Ubuntu.

    
por gast128 29.11.2011 / 20:34
fonte
4

Para sair do mc (com a tecla F10). Desativar "Chave para abrir o primeiro menu do painel" no plugin de unidade compiz (ccsm)

    
por kholis 29.04.2011 / 12:33
fonte
4

O @kholis está correto para desabilitar a F10 no Unity, mas se você é um novato como eu, precisa de um pouco mais de informações para fazer isso funcionar.

Se ainda não estiver instalado, instale o compizconfig-settings-manager:

sudo apt-get install compizconfig-settings-manager

Inicie o gerenciador de configurações recém-instalado e filtre por "unidade"

Edite "Chave para abrir o primeiro menu do painel" para desativá-lo ou alterá-lo para outra chave.

Ainda não encontrei uma maneira de mudar a F1.

por Ryan Sorensen 30.04.2011 / 19:36
fonte
3

A instrução no link (citado abaixo) também funciona no Ubuntu 11.04. (Parece desabilitar o F1 tanto no desktop quanto no terminal. Ou seja, o F1 não envia uma sequência ansi para o shell no terminal, se é isso que o OP queria.)

% bl0ck_qu0te%     
por David Andersson 22.08.2011 / 04:12
fonte
3

Você pode facilmente desativá-lo usando CCSM (Clique para instalar se você não o tiver instalado ).

Em seguida, vá para Desktop - > Plugin do Ubuntu Unity - > Tecla para abrir o primeiro menu do painel e desativá-lo ou alterá-lo para outro atalho de teclado.

Nota : parece que este método não funciona no Unity2D.

    
por Binarylife 27.10.2011 / 00:03
fonte
2

Esta é uma dica para os usuários do Thnkpad, especialmente o T60. Remapear a tecla F1 para escapar. Isso elimina o popup irritante da ajuda do terminal quando você aperta F1. Você costuma fazer isso por causa do posicionamento engraçado do ESC no T60s.

    
por ncmathsadist 03.12.2011 / 18:42
fonte
1

Se você quiser alterar isso apenas no Terminal Gnome , clique em Editar > Atalhos de teclado no terminal.

    
por Jeremy Bicha 30.04.2011 / 20:37
fonte
1

Eu recomendo usar o F1 como um atalho para outra coisa. Eu corro Tilda, um terminal de linha de comando estilo quake, e o atalho padrão é F1. Ele substitui a Ajuda, então eu nunca tenho ajuda para iniciar quando eu bato na F1. Mesmo que você não goste muito de Tilda, acertar F1 novamente para ocultá-lo é muito menos tedioso do que fechar a Ajuda após o lançamento acidental.

    
por titaniumtux 03.12.2011 / 20:23
fonte
1

12,04

F1 não parece fazer nada fora da caixa em 12.04
F10 parece simular um clique com o botão direito do mouse
Então, em resposta às especificidades da questão, não há necessidade de desativar a ajuda e as notificações.

Você ainda pode mapeá-los para outra coisa como esta:
O mapeamento de atalhos no 12.04 é feito simplesmente através do widget Teclado.

No launcher do Unity, ache o teclado.

Najanelaqueéaberta,selecioneaguiadeatalhoseosatalhospersonalizados.Cliquenosinaldemaisparaadicionarumnovoatalho.

Dê um nome a qualquer coisa que corresponda à funcionalidade que você está atribuindo a ela.
Digite o comando que você quer que ele seja executado no comando.

Noladodireitodajanela,cliqueondedizdesativado.IssodevealternarparaoNewAccelerator.

Agora é só apertar F10 .
O acelerador de atalhos personalizados que você definiu substitui o comportamento de simulação do botão direito do mouse. Você poderia definir este comando para echo 'nope' > /dev/null se você quiser que seu F10 não faça nada.

    
por RobotHumans 02.04.2012 / 19:50
fonte
1

12.04 Sem unidade - Desativar comportamento F1 e F11

Instalei o Ubuntu 12.04 / 64 e removi completamente o Unity dele após estas instruções. . Muitas das ferramentas que modificam o comportamento do Unity, portanto, não funcionam. Em particular, o CCSM não "vê" mais os atalhos de teclado.

Descobri que o método que usa Editar- > Atalhos de teclado na janela do terminal também não funcionou. Depois de brincar um pouco, descobri que, olhando mais para baixo na janela Atalhos de teclado na seção Teclas de atalho , F1 e F11 ainda estavam definidos para seus respectivos atalhos.

Para corrigir isso,

  1. Clique no botão "F11" no campo à direita da linha que define F11 como tela cheia. O texto será alterado para "Novo acelerador ...".

  2. Digite outra sequência de teclas menos censurável (como alt-F11) e essa combinação de chaves substituirá o atalho. Se alguém souber digitar "nada", informe-nos.

  3. Repita para a tecla F1.

por Wes Miller 20.11.2013 / 17:33
fonte
0

Ctrl + F1 também não funciona. A solução é a mesma que para Shift + F10. Não se esqueça do ponto e vírgula como separador!

Coloque isso em ~ / .config / gtk-3.0 / gtk.css:

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10";
     unbind "<control>F1";
}

* {
     gtk-key-bindings: NoKeyboardNavigation;
}
    
por egmont 16.03.2014 / 12:46
fonte