De acordo com Wikipedia ,
Administrative shares cannot be accessed by users without administrative privileges.
Para acessar \computername\c$ , a conta de serviço deve ser um membro do grupo Administradores Locais. O mesmo vale para \computername\admin$ .
Eu tentei contornar isso criando um novo compartilhamento chamado Users$ mapeado para C:\Users no computador local. Eu dei à conta de serviço Change direitos no compartilhamento e tentei dar Modify direitos na própria pasta. Eu tentei separadamente atribuir a propriedade de C:\Users à conta de serviço.
Isso não funcionou como eu esperava. Ao definir direitos, recebi um erro Access is Denied em várias subpastas (por exemplo, C:\Users\username\AppData\Local para cada usuário). Como eu só precisava de acesso a C:\Users\username\AppData\Roaming para cada usuário, isso ficava próximo a uma solução viável e era acessível a partir do outro computador usando \computername\Users$\username\AppData\Roaming . O lado negativo: Qualquer novo usuário que fizer login nessa máquina não herdou os direitos automaticamente. Eu tive que reatribuir direitos para cada novo usuário.
Por fim, o departamento de TI concedeu uma exceção de diretiva ao administrador local na conta de serviço em cada computador afetado, oferecendo acesso irrestrito a \computername\c$\Users\ .
Obrigado especialmente ao @Ramhound pela assistência neste assunto.