Tela parcial estranha piscando após atualização para 14.04

20

Eu tenho sido incomodado por esta questão por algumas semanas já. O problema começou quando atualizei para o 14.04. Partes da minha tela às vezes piscam, como mostrado em dois vídeos, nos links que eu anexei abaixo:

link

link

Eu estava tentando gravar com o VLC, mas de repente, quando eu começo a gravar, então ... ele pára de piscar :)

Eu não tenho idéia de onde posso registrar um bug para isso e com qual pacote ele pode estar conectado. Por favor, comente com o que pode ser conectado e como posso resolver isso.

Vou postar qualquer informação relevante sobre os pacotes, se necessário.

Eu uso nvidia-334 do pacote xorg edgers ( 334.21-0ubuntu1~xedgers14.04.1 ), mas também testei outros e é o mesmo problema.

    
por Patryk 20.05.2014 / 18:17
fonte

5 respostas

13

Isso funcionou para mim: link

Ativar Forçar redesenhos de tela cheia na opção de repintura em Soluções alternativas

Eu tive oscilações aleatórias semelhantes a isso (por exemplo, parte da página da Web piscou no Firefox (aceleração de hardware = ativado) ou o ícone da área de trabalho piscou ao desmarcá-la) e isso pareceu corrigir esse problema.

Estou usando os drivers da Nvidia 340.58, Lenovo Y500 GT 750m (único, sem otimização, com a tecnologia IntelHD desativada).

    
por Lindza 22.11.2014 / 16:21
fonte
6

É um bug no Compiz. Se isso afeta você, então você deve ir aqui e clicar em "este bug me afeta" .

Existe uma solução alternativa, mas pode tornar o sistema um pouco mais lento.

Instale Gerenciador de configurações do CompizConfig , depois vá para Composite e desative Unredirect fullscreen windows .

    
por nastys 27.05.2014 / 20:55
fonte
6

Instalei nvidia-331 (331.38-0ubuntu7) drivers e, por alguns dias, não experimentei nenhuma intermitência, então, provavelmente, foi um problema com os drivers ( xorg-egders versão 334 ou recente 337 )

    
por Patryk 29.05.2014 / 12:15
fonte
4

Instruções completas com base nas outras respostas aqui:

  • Instale o Compiz Config, a partir de um terminal, digite:

    sudo apt-get install compizconfig-settings-manager

  • No iniciador, execute Gerenciador de configurações do CompizConfig

  • Marque a caixa de seleção em "Utilitário - > Soluções alternativas - > Forçar redesenhos de tela cheia (troca de buffer) em repintura"

Também funcionou para mim, eu tenho um laptop Dell XPS com uma Nvidia GT 525m, usando o Ubuntu 14.04.

    
por Sebastián Ramírez 15.03.2015 / 14:06
fonte
-1

Eu tive um problema muito parecido com 2 GTX 680s em SLI e os mais recentes drivers NVIDIA em uma nova instalação do Ubuntu em RAID-0. Eu me lembrei antes de drivers Nvidia a tela era muito sólida e estável com drivers novos.

Mas depois de drivers da Nvidia as coisas acontecem para bagunçar .. e tela começou a piscar. Lembrei-me de selecionar um passo no instalador da Nvidia para permitir que o instalador gerasse o arquivo xorgs.conf.

Eu renomeie o xorg.conf para xorg.conf.bad-nvidia agora as coisas estão lindas. Só você não precisa do xorgs.conf criado por instaladores da nvidia.

    
por Frustrated Nvidia user 06.08.2014 / 17:26
fonte