Wifi cai e não irá reconectar até a reinicialização (14.04 com RTL8723BE) [fechado]

20

Eu tenho um novo laptop Sager NP2650 com uma nova instalação do Ubuntu 14.04LTS. Ele tem um adaptador sem fio Realtek RTL8723BE. Inicialmente, após a instalação, eu não tinha wireless, mas consegui fazê-lo funcionar depois de seguir as instruções deste thread: link . Eu tive que verificar uma versão anterior do driver do git como o segmento diz para obtê-lo para compilar no meu sistema.

O problema é que a conexão é perdida em aproximadamente uma hora, embora o Network Manager ainda a mostre como conectada. Se eu desabilitar e reativar o Wi-Fi ou a Rede, isso não funcionará. O wifi apenas infinitamente tenta se conectar, mas falha.

Se eu reiniciar, tudo funciona bem por um tempo.

Eu executei o script de diagnóstico sem fio encontrado em outro lugar no fórum e enviei meus resultados aqui:

link

Eu poderia usar alguma ajuda. Obrigado!

    
por themaninthewoods 29.04.2014 / 01:25
fonte

1 resposta

12

Eu tenho o mesmo problema. Para mim, a solução é remover e reinserir o módulo rtl8723be:

root@lenovob5400# rmmod rtl8723be && modprobe rtl8723be

Claro que não é uma solução, mas melhor que a reinicialização. Que vergonha o Ubuntu não funciona com essa placa wifi tão popular.

BTW, eu tentei o kernel 3.15, mas ele tem o mesmo problema (e alguns outros).

Ansioso por uma melhor solução. Vá pegar hackers! ; -)

Atualização:

Amigos, por favor votem no bug relacionado ao ubuntu .

Atualização 2:

Próximos ubuntu kernel 3.13.0-25.47 tem o # 1240940 bug corrigido, no entanto, depois de instalar este kernel do ppa, o módulo rtl8723be está lá de fato, mas eu não consegui me conectar. Atualmente estou usando o kernel padrão 3.13.0-24-genérico com o módulo do kernel rtl8723be de: link em 604aa9058fb9e5bb1cf571c99989d081f8fc8b9b commit.

Atualização 3:

Eu tentei o ndiswrapper 1.9 com drivers do winxp 64 (e cara, outros). Tudo falhou ao carregar:

[  327.503426] ndiswrapper version 1.59 loaded (smp=yes, preempt=no)
[  327.517958] ndiswrapper: driver netrtwlane (Realtek Semiconductor Corp.,08/02/2013,2010.5.0724.2013) loaded
[  327.519049] ndiswrapper (NdisWriteErrorLogEntry:188): log: C0001388, count: 1, return_address: ffffffffa05e5d9f
[  327.519052] ndiswrapper (NdisWriteErrorLogEntry:191): code: 0x605
[  327.519143] ndiswrapper (mp_init:211): couldn't initialize device: C001001E
[  327.519146] ndiswrapper (pnp_start_device:395): Windows driver couldn't initialize the device (C0000001)
[  327.519150] ndiswrapper (mp_halt:254): device ffff8800cd747880 is not initialized - not halting
[  327.519151] ndiswrapper: device eth%d removed
[  327.519380] ndiswrapper: probe of 0000:04:00.0 failed with error -22

Eu tentei mais um truque - adicionado o parâmetro fwlps=0 para o módulo rtl8723be . Por enquanto, tudo bem. Nós veremos ...

    
por Michał Šrajer 30.04.2014 / 22:06
fonte

Tags