Como faço para que o Sublime Text 2/3 não abra as abas anteriores ao iniciá-lo?

19

Toda vez que eu abro o Sublime, essas abas se abrem automaticamente. Como faço para corrigir isso. Não consigo encontrar nenhuma configuração para isso.

    
por BigSack 25.08.2012 / 04:37
fonte

3 respostas

16

Texto sublime 2

Verifique o conteúdo do diretório ~/.config/sublime-text-2/Settings de um arquivo chamado Session.sublime_session

Se esses arquivos estiverem incluídos lá, remova-os

Texto sublime 3

ST3 armazena os arquivos da sessão em:

~/.config/sublime-text-3/Local/Session.sublime_session
    
por Adonis K. Kakoulidis 25.08.2012 / 05:00
fonte
42

Existe, na verdade, uma solução melhor implementada no Sublime Text. Selecione Preferences-> Settings - User e defina remember_open_files e hot_exit como falso. O arquivo resultante deve ter esta aparência:

{
    "remember_open_files": false,
    "hot_exit": false
}

(Todas as configurações possíveis podem ser vistas em Settings - Default .)

Apenas reinicie o Sublime Text depois (pode ser necessário reiniciar o programa duas vezes, uma vez para aplicar as configurações) e ele deve iniciar sem nenhum arquivo aberto.

Observação: eu só consegui testar isso com o Sublime Text 3, mas tenho certeza de que essas configurações também existem na versão 2.

    
por Adam S 15.03.2013 / 18:48
fonte
1

Em Sublime Text 3 , abaixo funcionou para mim.

  

$ rm ~ / .config / sublime-text-3 / Local / Auto \ Salvar \   Session.sublime_session

    
por BTR Naidu 15.11.2017 / 09:15
fonte