Erro ao autenticar alguns pacotes durante a atualização

23

Quando tento atualizar meu Ubuntu 13.04 para 13.10, ele apresenta o seguinte erro:

It was not possible to authenticate some packages. This may be a 
transient network problem. You may want to try again later. See below 
for a list of unauthenticated packages.

Também durante o download dos arquivos, vejo erros como:

Err http://in.archive.ubuntu.com saucy-backports/restricted Translation-en_IN 

Eu tentei o link para uma pergunta semelhante mas isso não funciona. Eu não acho que tenha problemas com as chaves.

    
por Singularity 24.02.2014 / 02:43
fonte

1 resposta

43
  

Aviso importante de segurança

     

Esta resposta irá desativar um recurso de segurança crítico no Ubuntu. Isso impedirá que os pacotes de verificação do Ubuntu sejam os mesmos de quando eles foram construídos.

     

Isso poderia significa que suas atualizações estão comprometidas ou corrompidas.
  Isso poderia significar que há apenas um bug no modo como as atualizações de versão do Ubuntu são tratadas.

     

Eu não estou dizendo que você nunca deveria fazer isso, só estou pedindo para você estar ciente do que está fazendo. E coloque as coisas de volta depois de atualizar. Não deixe AllowUnauthenticated indefinidamente.

     

- Oli, Ask Ubuntu mod.

Isso funcionou para mim.

crie o arquivo /etc/update-manager/release-upgrades.d/unauth.cfg como root e adicione o seguinte.

[Distro]
AllowUnauthenticated=yes

Após a atualização, remova este arquivo.

    
por Singularity 25.02.2014 / 17:00
fonte