O Steam não abre no Ubuntu 15.10

19

Tente várias vezes, mas nada acontece. Tentei reinstalar o Steam junto com o Ubuntu, mas isso não fez nada também. Tentei outros fóruns com dicas úteis, mas não é bom. Estou ficando sem ideias e não sei o que mais posso fazer. Alguém pode me ajudar antes de eu começar a arrancar meu cabelo? Eu estou ficando louco.

    
por Travis Toompas 25.10.2015 / 07:43
fonte

2 respostas

27

Baseado em esta questão , execute os seguintes comandos :

mv ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1{,.disable}
mv ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6{,.disable}

A idéia é que o Steam usa suas próprias bibliotecas dinâmicas, mas o Ubuntu vem com algumas novas, ou algo assim, de qualquer maneira que funciona!

NOTA: Se você estiver instalando o Steam pela primeira vez, precisará executar os comandos uma segunda vez após a atualização inicial. Isso levará um tempo lonnnnnng!

ATUALIZAÇÃO:

Se você usar 16.10, os caras do Ubuntu forneceram um instalador modificado que cuida desse problema. Eu recomendaria instalar o Steam dos repositórios do Ubuntu

    
por Dan 26.10.2015 / 19:42
fonte
3

Com base na resposta de Daniel (eu não tenho o representante para comentar!), em um ubuntu-gnome vanilla 15.10 onde eu fiz um 'apt-get install steam' eu tive que rodar estes comandos modificados:

mv ~/.steam/steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6{,.disable}
mv ~/.steam/steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1{,.disable}

Então, basta alterar o local / compartilhamento que não estava presente no meu sistema

    
por Henri Cook 12.11.2015 / 22:57
fonte

Tags