Permissão negada ao baixar com transmissão deamon

21

Eu instalei o daemon de transmissão e xubuntu, configurei o caminho de download para meus programas de home / usuário / TV e receba uma permissão negada ao tentar baixar torrents por meio de transmissão.

Eu tentei chmod -r 777 nessa pasta sem sucesso.

por favor ajude!

saída de ps -ef | transmissão grep

[email protected]:~$ ps -ef | grep transmission
109       1023     1  1 21:46 ?        00:00:35 /usr/bin/transmission-daemon --config-dir /var/lib/transmission-daemon/info

[email protected]:~$ ps aux | grep transmission
109       1023  3.2  0.4  47684 16620 ?        Ssl  21:46   1:20     /usr/bin/transmission-daemon --config-dir /var/lib/transmission-daemon/info
chen      1852  0.0  0.0   4200   772 pts/0    S+   22:27   0:00 grep --color=auto transmission

enter code here
    
por Chen Kinnrot 23.11.2012 / 20:55

9 respostas

40

Supondo que o caminho para a pasta de download seja /home/chen/TV shows , execute o seguinte:

  • adicione chen ao grupo de transmissão debian

    sudo usermod -a -G debian-transmission chen
    
  • altere a propriedade da pasta

    sudo chgrp debian-transmission /home/chen/TV\ shows
    
  • conceder acesso de gravação ao grupo

    sudo chmod 770 /home/chen/TV\ shows
    
  • Pare o deamon com

    sudo service transmission-daemon stop
    
  • A última coisa a fazer é alterar a máscara de criação de arquivos, para que os arquivos baixados sejam gravados por chen.

    sudo nano /etc/transmission-daemon/settings.json
    

    … e altere "umask": 18 para "umask": 2 . Pressione Ctrl + O para salvar e Ctrl + X para sair.

Inicie o daemon com

sudo service transmission-daemon start
    
por mikewhatever 23.11.2012 / 21:58
4

Este é um problema de permissão com base no ID do usuário que está executando o Transmission. A transmissão configura um usuário padrão que você pode não esperar na primeira instalação. O nome do usuário é debian-transmission .

Vou explicar como mudar isso:

  1. Pare o daemon de transmissão sudo service transmission-daemon stop
  2. Abra o arquivo de configuração Transmission para edição: sudo nano /etc/init.d/transmission-daemon
  3. Localize a linha que diz USER=debian-transmission e altere-a para o usuário que possui a pasta em questão. Se você não estiver preocupado com problemas de segurança, também poderá usar USER=root neste arquivo. (Não recomendado, mas bom para resolução de problemas).
  4. Como alternativa (em vez do ponto número 3), modifique o pasta / etc / fstab para montar a pasta com as permissões corretas para o usuário que executa o daemon de transmissão.
  5. Iniciar o daemon de transmissão sudo service transmission-daemon start
por Terry 16.11.2013 / 08:09
3

Verifique se você está usando uma pasta "incompleta". O erro pode ser enganoso nesse caso e pode ser a pasta incompleta na qual você não tem acesso de gravação.

    
por blockdor 23.09.2015 / 19:41
1

Isso só aconteceu comigo. Eu encontrei esta página, fiquei intimidado com todo o jargão, então reiniciei o Transmission, reservei o arquivo torrent para um local diferente e salvei os dados do torrent no mesmo local diferente (desktop). Trabalhou como um encanto ...

    
por Alexia 31.07.2015 / 17:02
0

Isso pode ser um problema de perfil. A transmissão é executada sob o perfil sanitized_helper no apparmor.

Procure por reclamações em /var/log/kern.log. grep transm /var/log/kern.log , particularmente depois de tentar executar a transmissão e falhá-la.

    
por Jim Salter 24.11.2012 / 00:58
0

Como esse é o principal resultado de pesquisa no Google, para quem lê isso, passo mais de uma hora tentando fazer com que ele funcione. Acontece que a pasta de downloads especificada em settings.json é "Downloads" em vez de "downloads". Observe o caso.

    
por SomeGuest1425125125 23.11.2016 / 14:21
0

No meu caso, o problema era como a unidade estava sendo montada. Usando isso em /etc/fstab funcionou para mim:

UUID=2069-1A05  /mnt/ext   vfat   rw,user,exec,umask=0000   0   0
    
por davidcm 02.01.2017 / 20:24
-1

Eu tive o mesmo problema, e isso foi um erro que cometi ao vincular o diretório de download da transmissão ao meu diretório home / user /, alterei a propriedade do arquivo sym-link que, por consequência, também alterou a propriedade de o diretório de 'download' da transmissão ...

Acabei de aceitar a propriedade 'debian-transmission' e funcionou como um charme (sem necessidade de reiniciar o serviço)

#chown debian-transmission:debian-transmission /var/lib/transmission/downloads

(bem, você terá que verificar de acordo com sua própria distribuição linux qual é o proprietário correto e, eventualmente, também o caminho certo para o diretório de downloads)

    
por baobab33 09.12.2014 / 11:37
-1

Eu tive um problema semelhante com a transmissão. Recebi um erro de permissão durante o download, mesmo com as configurações corretas de permissão de pasta no HDD USB externo.

Eu apenas montei o disco rígido externo para o /home/pi/ com as mesmas permissões e funcionou bem.

mount /dev/sda /home/pi/USB-HDD-MOUNTED
As permissões

são drwxrwxrwx (0777) pi:debian-transmission . nome de usuário é alterado para pi em /etc/init.d/transmisssion-daemon .

    
por Akos 12.02.2016 / 11:00