Inicialização lenta e tempos de login Ubuntu 16.04

18

Ubuntu 16.04 de 64 bits levando cerca de 20 segundos da tela de login para a área de trabalho e cerca de 20 segundos do grub para a tela de login,

me diga quais serviços eu posso desativar com segurança, eu não uso o VirtualBox e Bluetooth com freqüência, todas as outras coisas são usadas como impressora, Wi-Fi etc.
saída de systemd-analyze

Startup finished in 5.145s (kernel) + 14.138s (userspace) = 19.284s

e saída de

systemd-analyze blame


 5.837s accounts-daemon.service
          5.444s dev-sda6.device
          4.864s grub-common.service
          4.105s lightdm.service
          4.075s ModemManager.service
          4.001s preload.service
          3.844s apparmor.service
          3.566s networking.service
          3.468s apport.service
          3.332s ondemand.service
          3.272s rsyslog.service
          3.269s systemd-logind.service
          3.253s alsa-restore.service
          3.241s gpu-manager.service
          3.226s avahi-daemon.service
          3.185s systemd-user-sessions.service
          3.185s pppd-dns.service
          2.508s NetworkManager.service
          2.003s user@1000.service
          1.640s plymouth-quit-wait.service
          1.245s colord.service
           712ms systemd-update-utmp.service
           687ms systemd-udevd.service
           669ms udisks2.service
           632ms polkitd.service
           602ms brltty.service
           572ms systemd-localed.service
           567ms systemd-backlight@backlight:intel_backlight.service
           543ms systemd-rfkill.service
           527ms systemd-tmpfiles-setup-dev.service
           519ms thermald.service
           490ms systemd-tmpfiles-setup.service
           464ms systemd-modules-load.service
           454ms systemd-tmpfiles-clean.service
           450ms systemd-timesyncd.service
           428ms systemd-journald.service
           371ms wpa_supplicant.service
           340ms ufw.service
           317ms systemd-random-seed.service
           284ms console-setup.service
           281ms plymouth-start.service
           270ms dev-hugepages.mount
           270ms sys-kernel-debug.mount
           224ms systemd-udev-trigger.service
           177ms dev-mqueue.mount
           168ms plymouth-read-write.service
           165ms upower.service
           131ms dns-clean.service
           103ms systemd-sysctl.service
           102ms dev-disk-by\x2duuid-8bd6db03\x2da87b\x2d4614\x2d927a\x2dd5916f3
            68ms systemd-hostnamed.service
            49ms systemd-journal-flush.service
            47ms kmod-static-nodes.service
            47ms snapd.socket
            32ms systemd-remount-fs.service
            28ms rc-local.service
            10ms resolvconf.service
            10ms rtkit-daemon.service
             9ms systemd-update-utmp-runlevel.service
             6ms ureadahead-stop.service
             4ms sys-fs-fuse-connections.mount lines 39-61/61 (END)

Além de:

systemd-analyze critical-chain

the time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @14.124s
└─lightdm.service @10.018s +4.105s
  └─systemd-user-sessions.service @6.731s +3.185s
    └─basic.target @6.625s
      └─sockets.target @6.625s
        └─snapd.socket @6.576s +47ms
          └─sysinit.target @6.574s
            └─swap.target @6.574s
              └─dev-disk-by\x2duuid-8bd6db03\x2da87b\x2d4614\x2d927a\x2dd5916f3c
                └─dev-disk-by\x2duuid-8bd6db03\x2da87b\x2d4614\x2d927a\x2dd5916f
lines 1-13/13 (END)

Estou usando um HDD com 7200 RPM, acho que o tempo de inicialização é bom, mas depois da tela de login, tenho que passar 20 segundos com uma tela em branco, já desativei alguns itens de inicialização como ORCA, BLUETOOTH, monitor de backup, acessibilidade etc, compartilhamento de arquivos pessoais e atualização de pasta de usuário etc, ainda nada está melhorando, como diagnosticar o culpado e tratá-lo.

    
por Kanhiya 25.05.2016 / 11:58

1 resposta

5

Tente remover algumas dependências não usadas e pacotes órfãos. Isso ajudará.
Funcionou no meu caso. Executar:

sudo apt autoremove && sudo apt autoclean

Além disso, você pode instalar o Gtkorphan ( sudo apt-get install gtkorphan ) para remover todos os pacotes órfãos e dependências deixados por outros aplicativos.

    
por Collin 11.09.2016 / 00:50