Após a atualização 14.04 para 16.04.1 o servidor Postgresql não inicia

20

Acabei de atualizar meu sistema a partir de 14.04. LTS para 16.04.1 LTS, postgresql não inicia no systemd:

/etc/init.d/postgresql start                                                                                                                                                                              
[ ok ] Starting postgresql (via systemctl): postgresql.service

# /etc/init.d/postgresql status                                                                                                                                                                             
● postgresql.service - PostgreSQL RDBMS
  Loaded: loaded (/lib/systemd/system/postgresql.service; enabled; vendor     preset: enabled)
  Active: active (exited) since Вт 2016-08-09 13:40:51 MSK; 3min 23s ago
  Process: 23142 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
  Main PID: 23142 (code=exited, status=0/SUCCESS)Seems that 

Parece que o script systemd contém dados errados:

# cat /lib/systemd/system/postgresql.service                                                                                                                                                                
# systemd service for managing all PostgreSQL clusters on the system. This
# service is actually a systemd target, but we are using a service since
# targets cannot be reloaded.

[Unit]
Description=PostgreSQL RDBMS

[Service]
Type=oneshot
ExecStart=/bin/true
ExecReload=/bin/true
RemainAfterExit=on

[Install]
WantedBy=multi-user.target

Qual deve ser o script correto para o postgresql?

    
por Artur Eshenbrener 09.08.2016 / 13:13

4 respostas

7

Isso deve funcionar imediatamente se você fornecer a versão correta e o nome do cluster.

Digamos que você esteja executando a versão 9.5 e o cluster seja chamado de main :

Iniciar: systemctl start postgresql@9.5-main

Parar: systemctl stop postgresql@9.5-main

Status: systemctl status postgresql@9.5-main

Ativar a inicialização automática na inicialização: systemctl enable postgresql@9.5-main

Desativar a inicialização automática na inicialização: systemctl disable postgresql@9.5-main

foo@postgres:~$ systemctl status postgresql@9.5-main
●  postgresql@9.5-main.service - PostgreSQL Cluster 9.5-main
   Loaded: loaded (/lib/systemd/system/postgresql@.service; disabled; vendor preset: enabled)
   Active: active (running) since Fri 2017-03-31 17:44:46 CEST; 59s ago
   Main PID: 4546 (postgres)
   CGroup: /system.slice/system-postgresql.slice/postgresql@9.5-main.service
           ├ ─ 4546 /usr/lib/postgresql/9.5/bin/postgres -D /var/lib/postgresql/9.5/main -c config_file=/etc/postgresql/9.5/main/postgresql.conf
           ├ ─ 4548 postgres: checkpointer process
           ├ ─ 4549 postgres: writer process
           ├ ─ 4550 postgres: wal writer process
           ├ ─ 4551 postgres: autovacuum launcher process
           └ ─ 4552 postgres: stats collector process

Mar 31 17:44:44 postgres postgres[4546]: [1-2] 2017-03-31 17:44:44 CEST [4546] @ HINT:  Future log output will go to log destination "syslog".
Mar 31 17:44:44 postgres postgres[4547]: [2-1] 2017-03-31 17:44:44 CEST [4547] @ LOG:  database system was shut down at 2017-03-31 17:44:43 CEST
Mar 31 17:44:44 postgres postgres[4547]: [3-1] 2017-03-31 17:44:44 CEST [4547] @ LOG:  MultiXact member wraparound protections are now enabled
Mar 31 17:44:44 postgres postgres[4546]: [2-1] 2017-03-31 17:44:44 CEST [4546] @ LOG:  database system is ready to accept connections
Mar 31 17:44:44 postgres postgres[4551]: [2-1] 2017-03-31 17:44:44 CEST [4551] @ LOG:  autovacuum launcher started
Mar 31 17:44:45 postgres postgres[4553]: [3-1] 2017-03-31 17:44:45 CEST [4553] [unknown]@[unknown] LOG:  incomplete startup packet
Mar 31 17:44:46 postgres systemd[1]: Started PostgreSQL Cluster 9.5-main.
Mar 31 17:44:47 postgres systemd[1]: Reloading PostgreSQL Cluster 9.5-main.
Mar 31 17:44:47 postgres postgres[4546]: [3-1] 2017-03-31 17:44:47 CEST [4546] @ LOG:  received SIGHUP, reloading configuration files
Mar 31 17:44:47 systemd[1]: Reloaded PostgreSQL Cluster 9.5-main.
    
por malte 31.03.2017 / 17:56
14

O Systemd deve usar o script de /etc/init.d . Em vez disso, o systemd usa algum tipo de arquivo de modelo. Para corrigir isso, siga estas etapas:

  1. Remover script de serviço inválido:

    # rm /lib/systemd/system/postgresql.service

  2. Recarregue os scripts do daemon:

    # systemctl daemon-reload

  3. Ativar o serviço postgresql:

    # systemctl enable postgresql

Depois disso, você poderá iniciar o postgres com as variantes preferidas: sudo systemctl start postgresql , sudo service postgresql start ou sudo /etc/init.d/postgresql start . Para verificar se o postgresql realmente é executado, verifique o status do serviço: sudo systemctl status postgresql . Parece que:

% sudo systemctl status postgresql                                                                                                                                                                          
● postgresql.service - LSB: PostgreSQL RDBMS server
   Loaded: loaded (/etc/init.d/postgresql; bad; vendor preset: enabled)
   Active: active (running) since Пт 2016-08-12 10:13:43 MSK; 1h 37min ago
     Docs: man:systemd-sysv-generator(8)
   CGroup: /system.slice/postgresql.service
           ├─4086 /usr/lib/postgresql/9.5/bin/postgres -D     /var/lib/postgresql/9.5/main -c  config_file=/etc/postgresql/9.5/main/postgresql.conf
           ├─4099 postgres: checkpointer process                                                                                              
           ├─4100 postgres: writer process                                                                                                    
           ├─4101 postgres: wal writer process                                                                                                
           ├─4102 postgres: autovacuum launcher process                                                                                       
           └─4103 postgres: stats collector process                                                                                           

авг 12 10:13:40 ubuntu-precise systemd[1]: Starting LSB: PostgreSQL RDBMS server...
авг 12 10:13:40 ubuntu-precise postgresql[4009]:  * Starting PostgreSQL 9.5 database server
авг 12 10:13:43 ubuntu-precise postgresql[4009]:    ...done.
авг 12 10:13:43 ubuntu-precise systemd[1]: Started LSB: PostgreSQL RDBMS server.
    
por Artur Eshenbrener 09.08.2016 / 13:13
0

Eu tive o mesmo problema depois de purgar o postges9 e instalei 10 no meu ubuntu16. Inicialmente editei o arquivo /lib/systemd/system/postgresql.service com o seguinte conteúdo:

[Unit]
Description=PostgreSQL RDBMS

[Service]
Type=notify
User=postgres
ExecStart=/usr/lib/postgresql/10/bin/postgres -D /analysis2/postgresql/data
ExecReload=/bin/kill -HUP $MAINPID
KillMode=mixed
KillSignal=SIGINT
TimeoutSec=0

[Install]
WantedBy=multi-user.target

E eu posso usar systemctl restart / stop / start para controlar o serviço postgresql. No entanto, por algum motivo, o arquivo acima foi sobrescrito (talvez após a atualização do sistema) e eu não pude executar o comando systemctl para iniciar e parar o servidor postgresql mais. Depois de algumas leituras, percebi que você não deveria editar o arquivo acima. Em vez disso, você deve usar systemctl edit foo para sobrescrever os padrões. Depois de seguir a solução sugerida pelo seguinte link, meu sistema parece estar funcionando corretamente com o postgresql.

Como faço para substituir ou configurar serviços do systemd?

    
por Kemin Zhou 04.01.2018 / 23:36
-1

Não é a melhor solução, mas isso resolve o problema sem ter que mergulhar em nada. Adicione isto ao cron:

@reboot sleep 5; systemctl start postgresql
    
por user3136936 24.08.2017 / 09:44