SQL - ocorreu um erro durante o aperto de mão de pré-login

12

Até ontem à noite, consegui me conectar ao meu servidor da minha máquina local. Agora, recebo o seguinte erro:

Uma conexão foi estabelecida com sucesso com o servidor, mas ocorreu um erro durante o handshake de pré-login. (provedor: Provedor SSL, erro: 0 - A operação de espera expirou.) (Provedor de dados .NET SqlClient)

Note que posso fazer logon no servidor real sem problemas.

Ontem, instalei o IIS na minha máquina e configurei um site usando meu endereço IP - não sei se isso tem alguma coisa a fazer.

Eu encontrei este artigo, segui os passos, mas não pareceu ajudar.

link

Também passei pelo seguinte artigo, alterei as configurações de TC / IP, reiniciei, mas nada.

Comecei a tentar sugestões de comentários também, mas parei quando percebi que poderia estar atrapalhando mais as coisas.

Então, por que isso está acontecendo / como posso corrigir?

    
por Rivka 30.08.2012 / 18:07

10 respostas

5

Na minha situação, eu tinha um filtro / proxy de conteúdo chamado Covenant Eyes que era a causa provável.

Eu tentei reparar a instalação do SQL Server 2012 e ele travou a instalação e ainda não resolveu o problema. Assim que eu gerasse um código de desinstalação e desinstalasse o filtro, eu poderia me conectar; Eu nem precisei reiniciar.

Verifique se há proxies e filtros de conteúdo na máquina e desative-os!

    
por 12.03.2013 / 21:07
6

Uma resposta proposta aqui: link

Sick of the problem? Dont know or care what winsock is or any of this low level crap means.

Go to a command prompt

do this

netsh Winsock reset

go on with your life and be happy.

    
por 12.03.2013 / 19:28
3

Na minha configuração particular, eu estava usando o armazenamento de dados da sessão em um banco de dados personalizado, eu também tinha os dados criptografados (Encrypt = True) através da seqüência de conexão, removendo isso resolveu o problema!

No entanto, suspeito que os dados não estão sendo criptografados com SSL, embora isso não seja um problema até que adicionemos mais servidores da Web!

    
por 14.11.2012 / 12:24
1

Eu fiz uma restauração do sistema e consegui me conectar agora.

    
por 31.08.2012 / 15:43
0

Abra o SQL Server Configuration Manager e verifique se o serviço do SQL Server está em execução:

econfiguradoparapermitirconexõesTCP/IP:

    
por 30.08.2012 / 22:01
0

This error occurred after the installation of a program which changes the Internet Protocol settings of your computer. Recently I got the same issue after the installation of Internet download manager because IDM has changed the IP settings that error comes so after uninstalling IDM from my PC and restarting the PC solve the problem.

Portanto, desinstale qualquer aplicativo que tenha alterado as configurações do Protocolo da Internet, como o gerenciador de downloads da Internet.

    
por 05.09.2013 / 09:06
0

Às vezes, esse erro ocorre devido à sobrecarga de conexões no SQL Server. Então, basta mudar seu banco de dados para Usuário Único e alterá-lo novamente para Multi usuário.

Ou simplesmente execute esta consulta.

use o mestre ALTER DATABASE DatabaseName SET SINGLE_USER COM ROLLBACK IMEDIATO ALTER DATABASE DatabaseName SET MULTI_USER

Isso resolveu meu problema. :) Aproveite .. !!

    
por 25.05.2017 / 10:11
0

Nenhuma dessas soluções funcionou para mim. O que funcionou foi o seguinte:

link

  • No SQL Server Configuration Manager

  • Selecione os serviços do SQL Server

  • Localize o serviço com problemas e visualize as Propriedades

  • Na guia Logon, altere a "Conta interna" para "Serviço de rede"

Disclaimer: Isso foi no meu PC local, então eu não tinha preocupações com segurança.

    
por 22.06.2017 / 15:36
0

Erro:

Connection Timeout Expired. The timeout period elapsed while attempting to consume the pre-login handshake failed or the server was unable to respond back in time. The duration spent while attempting to connect to this server was - [Pre-Login] initialization=11977; handshake=5138;

Resolução:

Esse problema pode ser resolvido modificando a string de conexão para definir o parâmetro TransparentNetworkIPResolution como false.

Exemplo:

Server=myServerName;
Database=myDataBase;
Trusted_Connection=True;
TransparentNetworkIPResolution = False

Quando o definimos como false na string de conexão, ele não atingirá o tempo limite de 500 ms e a conexão será bem-sucedida.

link

    
por 09.03.2018 / 06:07
-1

Tivemos o mesmo problema. Verificamos tudo, incluindo ping, telnet e amp; Conectividade RDP e finalmente percebi que isso começou a acontecer depois que nosso ISP mudou a rota. Depois de mudar a rota, começou a funcionar.

    
por 27.06.2018 / 09:43