Depois de renomear o nome do host, exclua & recriando /etc/machine-id executando systemd-machine-id-setup e reinicializando para aplicá-los, o systemd-journald voltou à vida!
Depois de excluir meu /var/log/journal por acidente, não consigo me recuperar das consequências. systemd-journald continua falhando de novo e de novo toda vez que eu tento iniciá-lo. quando eu corro:
$ journalctl --verify
PASS: /run/log/journal/system.journal
que não me aproxima um passo para resolvê-lo, porque /run/log/journal/system.journal é criado quando eu executo /usr/lib/systemd/systemd-journald diretamente, o que nele é gerado
$ /usr/lib/systemd/systemd-journald
Failed to open runtime journal: Invalid argument
Coisas que já experimentei:
/var/log/journal and / run / log / journal '. /var/log/journal de outra máquina para os dois caminhos, executando journalctl --verify para verificá-los e novamente com --file flag. /etc/systemd/journald.conf para Storage=volatile apenas para desativar /var/log/journald . Tente excluir /var/log/journal caso haja algum resíduo das tentativas de restauração anteriores. Em seguida, defina Storage=persistent em /etc/systemd/journald.conf e reinicie.
Normalmente, o systemd deve recriar /var/log/journal durante a reinicialização.
Se isso não ajudar, tente
mkdir -p /var/log/journal
systemd-tmpfiles --create --prefix /var/log/journal
Experimente: systemctl stop systemd-journald && strace systemctl start systemd-journald
Isso deve transmitir muito detalhes sobre o que está acontecendo enquanto o processo está sendo iniciado. As linhas finais podem fornecer uma pista porque continua a falhar.
Tags systemd journald journalctl