verifique se o seu DC instalou a atualização KB3002657 hoje à noite. veja link Eu tive o mesmo problema. A desinstalação desta atualização resolveu o problema para mim.
Temos a seguinte configuração:
Todas as máquinas estão no mesmo domínio. Todas as contas de usuário em uso são contas de domínio. O SQL executa uma instância de cada SQL Server 2005, 2008, 2008R2, 2012 e 2014.
Desde hoje à noite ( DC é reiniciado para instalar atualizações de segurança automáticas do Windows), o acesso às instâncias do SQL 2005, 2008 e 2008R2 por meio da autenticação do Windows não funciona mais corretamente:
Ao acessar uma dessas instâncias
o seguinte erro ocorre (é a mensagem 2008R2, as mensagens 2005/2008 são semelhantes):
Login failed. The login is from an untrusted domain and cannot be used with Windows authentication. (Microsoft SQL Server, Error: 18452)
Obviamente, o texto da mensagem não se aplica, pois existe apenas um domínio.
Agora, o mais surpreendente é: assim que o usuário estiver logado em SQL (iniciando uma sessão de RDP ou mesmo executando runas /user:MYDOMAIN\someuser cmd e mantendo a janela aberta), esse usuário pode acessar todo o SQL Instâncias do servidor de todos os clientes sem nenhum problema até que o processo em execução com as credenciais desse usuário seja fechado.
Isso significa que posso resolver esse problema executando o comando runas acima para todos os usuários em SQL uma vez (e mantendo as janelas abertas), mas, obviamente, algo está seriamente danificado. Eu suspeito que as atualizações de segurança desta noite no DC têm algo a ver com isso (já que foi a única coisa que mudou), mas eu prefiro evitar a desinstalação e reinicialização de cada uma delas (12 atualizações foram instaladas e < strong> DC é muito antigo e lento).
Alguém já encontrou esse problema antes e sabe como corrigi-lo permanentemente? Alguma outra idéia (além de passar os próximos dias se tornando um especialista em Kerberos)?
verifique se o seu DC instalou a atualização KB3002657 hoje à noite. veja link Eu tive o mesmo problema. A desinstalação desta atualização resolveu o problema para mim.
A seguinte correção via Diretiva de Grupo funcionou para mim:
gpupdate /force nos computadores e servidores afetados. Não tenho os detalhes exatos, mas estávamos tendo os mesmos sintomas e solução alternativa com a sessão do RDP. Eu avisei o grupo de TI sobre essa solução da simson, e eles disseram que desinstalariam a atualização de segurança, que havia sido aplicada no fim de semana. Isso parece ter resolvido o problema.