Isso deve ser bem possível. O cluster MySQL usa o mecanismo NDB (Database Database) para "replicar" as alterações entre os dois nós. Portanto, ele não usa os logs binários. Portanto, você pode configurar o outro servidor M3 para fazer a replicação de log binário direta.
Você poderia, teoricamente, usar qualquer mecanismo que quisesse para M3 , mas tenha cuidado com o fato de que determinada DML e a maioria das DDL falharão em determinados mecanismos (ou pelo menos se comportarão de maneira diferente). Portanto, o mais robusto seria ter M3 como um único nó NDB instance. Mas você poderia configurá-lo para usar MyISAM ou InnoDB , apenas perceber que isso poderia levar a problemas no caminho ...
Quanto a se é uma boa ideia, isso depende. Desde que o M1 - > M3 replicação é um relacionamento Mestre-Escravo (com M3 sendo o escravo), eu não vejo o mal nisso ...