Como configurar o cliente ldap?

2

Estou tendo um problema com frango e ovo configurando o cliente ldap no OmniOSCE, que é um fork do Solaris.

Pergunta

Pelo que eu posso dizer abaixo, então ldap_client e ldap_cachemgr precisam um do outro para funcionar, o que parece um problema de galinha e ovo?

E ldap_cachemgr suponha que seja um serviço que deve ser executado?

Plano de fundo

Isso é o que estou fazendo

echo "xx.xx.xx.xx    ldap.example.com" >> /etc/hosts
domainname imm
domainname > /etc/defaultdomain

cp -a /etc/nsswitch.conf{,_orig}

ldapclient manual \
  -a domainName=dc=example.com -a credentialLevel=self \
  -a defaultSearchBase=dc=xxx,dc=example,dc=com \
  -a defaultServerList=ldap.example.com

echo "imm" > /etc/defaultdomain

/usr/bin/cp -f /etc/nsswitch.conf{_orig,}

replace_args () {
  perl -i -slpe 's/^$string\s+\K.*/$add/' -- -string="$1" -add="$2" "$3"
}

replace_args 'passwd:'   'files ldap' /etc/nsswitch.conf
replace_args 'group:'    'files ldap' /etc/nsswitch.conf
replace_args 'netgroup:' 'files ldap' /etc/nsswitch.conf
replace_args 'hosts:'    'files dns'  /etc/nsswitch.conf
replace_args 'ipnodes:'  'files dns'  /etc/nsswitch.conf

function delete_line { ( sed -i "/$1/d" $2 ) };
delete_line ldap.example.com /etc/hosts

svcadm enable svc:/network/ldap/client

# ldaplist -l netgroup
ldaplist: LDAP configuration problem (Unable to load configuration '/var/ldap/ldap_client_file' ('').)
/var/ldap/ldap_client_file is empty.

/var/adm/messages tem

Apr 13 14:18:21 omniosce ldap_cachemgr[8369]: [ID 293258 daemon.error] libsldap: Status: 4  Mesg: Unable to open filename '/var/ldap/ldap_cl
ient_cred' for reading (errno=2).
Apr 13 14:18:21 omniosce ldap_cachemgr[8368]: [ID 703877 daemon.error] ldap_cachemgr: failed (rc = 255).
Apr 13 14:18:21 omniosce svc.startd[10]: [ID 652011 daemon.warning] svc:/network/ldap/client:default: Method "/lib/svc/method/ldap-client start" failed with exit status 1.
Apr 13 14:18:21 omniosce svc.startd[10]: [ID 748625 daemon.error] network/ldap/client:default failed: transitioned to maintenance (see 'svcs -xv' for details)
Apr 13 14:18:21 omniosce fmd: [ID 377184 daemon.error] SUNW-MSG-ID: SMF-8000-YX, TYPE: defect, VER: 1, SEVERITY: major
Apr 13 14:18:21 omniosce EVENT-TIME: Fri Apr 13 14:18:21 CEST 2018
Apr 13 14:18:21 omniosce PLATFORM: KVM, CSN: -, HOSTNAME: omniosce
Apr 13 14:18:21 omniosce SOURCE: software-diagnosis, REV: 0.1
Apr 13 14:18:21 omniosce EVENT-ID: 182b4afe-1cc8-68ea-8755-f9ee03c05462
Apr 13 14:18:21 omniosce DESC: A service failed - a method is failing in a retryable manner but too often.
Apr 13 14:18:21 omniosce   Refer to http://illumos.org/msg/SMF-8000-YX for more information.
Apr 13 14:18:21 omniosce AUTO-RESPONSE: The service has been placed into the maintenance state.
Apr 13 14:18:21 omniosce IMPACT: svc:/network/ldap/client:default is unavailable.
Apr 13 14:18:21 omniosce REC-ACTION: Run 'svcs -xv svc:/network/ldap/client:default' to determine the generic reason why the service failed, the location of any logfiles, and a list of other services impacted.
Apr 13 14:18:27 omniosce ldap_cachemgr[8484]: [ID 293258 daemon.error] libsldap: Status: 4  Mesg: Unable to open filename '/var/ldap/ldap_client_cred' for reading (errno=2).
Apr 13 14:18:27 omniosce ldap_cachemgr[8483]: [ID 703877 daemon.error] ldap_cachemgr: failed (rc = 255).
Apr 13 14:18:27 omniosce svc.startd[10]: [ID 652011 daemon.warning] svc:/network/ldap/client:default: Method "/lib/svc/method/ldap-client start" failed with exit status 1.
Apr 13 14:18:27 omniosce svc.startd[10]: [ID 748625 daemon.error] network/ldap/client:default failed: transitioned to maintenance (see 'svcs -xv' for details)
Apr 13 14:18:27 omniosce fmd: [ID 377184 daemon.error] SUNW-MSG-ID: SMF-8000-YX, TYPE: defect, VER: 1, SEVERITY: major
Apr 13 14:18:27 omniosce EVENT-TIME: Fri Apr 13 14:18:27 CEST 2018

svcs -xv svc:/network/ldap/client:default tem

svc:/network/ldap/client:default (LDAP client)
 State: maintenance since 13 April 2018 14:18:27 CEST
Reason: Start method failed repeatedly, last exited with status 1.
   See: http://illumos.org/msg/SMF-8000-KS
   See: man -M /usr/share/man -s 1M ldap_cachemgr
   See: /var/svc/log/network-ldap-client:default.log
Impact: This service is not running.

Eu até tentei copiar o /var/ldap/ldap_client_file de uma instalação de testes em funcionamento, onde de alguma forma eu consegui que funcionasse, mas não posso reproduzi-lo.

# svcadm restart svc:/network/ldap/client
# ldaplist -l netgroup
ldaplist: LDAP configuration problem (Unable to load configuration '/var/ldap/ldap_client_file' ('').)

Por algum motivo, não existe /var/ldap/ldap_client_file agora.

Não há costuras para ser um serviço de cache em execução

# svcs|grep cache
online         14:18:28 svc:/system/name-service-cache:default
    
por Sandra 16.04.2018 / 09:27

1 resposta

4

ldap_cachemgr é o cliente ldap no Solaris e, sim, ele deve continuar sempre sendo executado como um serviço.

Para configurar o cliente ldap, você precisa de dois arquivos em / var / ldap:

  • ldap_client_cred
  • ldap_client_file

ldap_client_cred contém as credenciais do usuário proxy, algo assim:

NS_LDAP_BINDDN= cn=proxyagent,ou=Profile,dc=example,dc=com 
NS_LDAP_BINDPASSWD= {NS1}47c4213f9c248484454e6782 

ldap_client_file contém as diretivas para se conectar ao seu servidor ldap:

NS_LDAP_FILE_VERSION= 2.0
NS_LDAP_SERVERS= SERVER_LDAP
NS_LDAP_SEARCH_BASEDN= dc=example,dc=com
NS_LDAP_AUTH= simple
NS_LDAP_SEARCH_REF= FALSE
NS_LDAP_SEARCH_SCOPE= one
NS_LDAP_SEARCH_TIME= 30
NS_LDAP_SERVER_PREF= SERVER_LDAP
NS_LDAP_PROFILE= my_profile
NS_LDAP_CREDENTIAL_LEVEL= proxy
NS_LDAP_BIND_TIME= 10
NS_LDAP_SERVICE_AUTH_METHOD= pam_ldap:simple

my_profile deve ser carregado no seu servidor ldap.

O último passo é incluir o ldap no nsswitch.conf e iniciar o cliente.

    
por 16.04.2018 / 09:40