Após algumas leituras, alterei a diretiva try_files :
# Old way: fallback to index.html
try_files $uri $uri/ /index.html;
# New way: serve a 404 response
try_files $uri $uri/ =404;
Outra opção seria:
# Fall back to this error page
try_files $uri $uri/ error_pages/404.html
Eu ainda tenho essa diretiva para lidar com a veiculação de index.html para mysite.com/ :
server {
# ...
index index.html index.html;
#...
}