No Debian squeeze , se você instalou o pure-ftpd dos repositórios, o script init.d parece estar com problemas:
/etc/init.d/pure-ftpd restart
Resultados no syslog contendo;
pure-ftpd: (?@?) [ERROR] Unable to start a standalone server: [Address already in use]
E uma espiada com netstat -ltpn mostra claramente que o pure-ftpd continua em execução, ou seja, restart não tenta parar o servidor, ele apenas tenta executar uma nova instância e falha.
A solução é matar o processo pré-ftpd. E, em seguida, inicie-o novamente com init.d (ou manualmente, como no exemplo de código de execução no OP.