Não, não há. Isso é considerado como um erro, explicado abaixo.
Nesse caso, onde você deseja redirecionar www para um site completamente diferente, você removerá o CNAME e o A e o substituirá por outro registro do tipo A ou CNAME , mas não ambos.
Observe também que CNAME funciona apenas como um alias para o nome canônico. Ele não executará qualquer redirecionamento real , pois o redirecionamento é uma função do protocolo HTTP, em vez do DNS.
Se um nome de host tiver um registro CNAME , ele não deverá ter outros registros de recursos de outro tipo. Referências:
RFC 1912, 2.4 CNAME records
A
CNAMErecord is not allowed to coexist with any other data. In other words, ifsuzy.podunk.xxis an alias forsue.podunk.xx, you can't also have anMXrecord forsuzy.podunk.edu, or anArecord, or even aTXTrecord. Especially do not try to combineCNAMEs andNSrecords
Se você usar um CNAME , o servidor DNS deverá retornar o registro CNAME e o registro A para o nome do host canônico para o qual ele está apontando. O mesmo se aplica aos registros IPv6 AAAA .
RFC 1034, 3.6.2 Aliases and canonical names
For example, suppose a name server was processing a query with for
USC-ISIC.ARPA, asking for typeAinformation, and had the following resource records:USC-ISIC.ARPA IN CNAME C.ISI.EDU C.ISI.EDU IN A 10.0.0.52Both of these RRs would be returned in the response to the type
Aquery, while a typeCNAMEor * query should return just theCNAME.
A única exceção é o DNSSEC.
RFC 2181, 10.1 permitido SIG , NXT e KEY registros, enquanto a definição usada atualmente é:
RFC 4035, 2.5 Changes to the CNAME Resource Record
If a
CNAMERRset is present at a name in a signed zone, appropriateRRSIGandNSECRRsets are REQUIRED at that name. AKEYRRset at that name for secure dynamic update purposes is also allowed ([RFC3007]). Other types MUST NOT be present at that name.This is a modification to the original
CNAMEdefinition given in [RFC1034]. The original definition of theCNAMERR did not allow any other types to coexist with aCNAMErecord, but a signed zone requiresNSECandRRSIGRRs for every authoritative name. To resolve this conflict, this specification modifies the definition of theCNAMEresource record to allow it to coexist withNSECandRRSIGRRs.