Sua pasta db pertence a root:root e você não deve executar o MongoDB como root . Se você estiver usando os padrões do MongoDB (você não menciona o sabor do Linux que está usando), o serviço será iniciado como o usuário mongod ou mongodb , não root , que é o comportamento correto.
Portanto, quando o processo mongod tentar criar / usar o arquivo mongod.lock , você receberá um erro de permissão. Você precisa alterar as permissões de /ebs/mongo/db apropriadamente. Isso pode ser feito com um dos seguintes comandos (como root ou com sudo):
chown -R mongodb:mongodb /ebs/mongo/db
Ou:
chown -R mongod:mongod /ebs/mongo/db
Você também desejará certificar-se de que qualquer logpath usado possa ser gravado pelo mesmo usuário. Eu basicamente respondi a este antes no StackOverflow com uma causa um pouco diferente, então dê uma olhada lá também.

