Estou tentando configurar algumas rotas do Cisco 1941. Ambos são roteadores idênticos. Cada um como um HWIC-1T (interface Smart Serial) e uma interface 3G HWIC-3G-HSPA. Esses roteadores devem ser enviados para sites remotos. Temos conectividade com um dos sites, mas se o site remoto cair, perderemos a conectividade com o site remoto B.
O HWIC-1T é a interface primária da WAN usando o frame relay unindo os dois locais remotos
Queremos que o HWIC-3G-HSPA seja utilizável para conectividade direta da matriz para o site remoto B, e também o HWIC-3G-HSPA seja usado para comms entre os locais remotos quando o frame relay estiver inativo ( acontece um pouco).
Inicialmente, tentei fazer o roteamento dinâmico usando o EIGRP. No entanto, em meu laboratório de laptop 1941-1941, não consegui obter conectividade de ponta a ponta. Posteriormente, estabeleci o roteamento estático e obtive conectividade de ponta a ponta, mas apenas através de retransmissão de quadros, não do HWIC-3G-HSPA.
A configuração do funcionamento higienizado para o site remoto A:
version 15.1
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname remoteA
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
enable secret 5 censored
!
no aaa new-model
clock timezone wst 8 0
!
no ipv6 cef
ip source-route
ip cef
!
ip domain name yourdomain.com
multilink bundle-name authenticated
!
chat-script gsm "" "ATDT*98*1#" TIMEOUT 30 "CONNECT"
!
username admin privilege 15 secret 5 censored
!
controller Cellular 0/1
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 192.168.2.5 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 10.1.1.2 255.255.255.252
encapsulation frame-relay
cdp enable
frame-relay interface-dlci 16
frame-relay lmi-type ansi
!
interface Cellular0/1/0
ip address negotiated
encapsulation ppp
dialer in-band
dialer idle-timeout 2147483
dialer string gsm
dialer-group 1
async mode interactive
ppp chap hostname censored
ppp chap password 7 censored
cdp enable
!
interface Cellular0/1/1
no ip address
encapsulation ppp
!
interface Dialer0
no ip address
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Serial0/0/0 210 permanent
ip route 0.0.0.0 0.0.0.0 Cellular0/1/0 220 permanent
ip route 172.31.2.0 255.255.255.0 Cellular0/1/0 permanent
ip route 192.168.3.0 255.255.255.0 10.1.1.1 permanent
ip route 192.168.3.0 255.255.255.0 Cellular0/1/0 210 permanent
!
access-list 1 permit any
dialer-list 1 protocol ip list 1
!
control-plane
!
line con 0
logging synchronous
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line 0/1/0
exec-timeout 0 0
script dialer gsm
login
modem InOut
no exec
transport input all
rxspeed 7200000
txspeed 5760000
line 0/1/1
no exec
rxspeed 7200000
txspeed 5760000
line vty 0 4
access-class 23 in
privilege level 15
password 7 censored
login local
transport input all
line vty 5 15
access-class 23 in
privilege level 15
password 7 censored
login local
transport input all
line vty 16 1370
password 7 censored
login
transport input all
!
scheduler allocate 20000 1000
end
A configuração do funcionamento higienizado para o site remoto B:
version 15.1
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname remoteB
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 censored
!
no aaa new-model
clock timezone wst 8 0
!
no ipv6 cef
ip source-route
ip cef
!
no ip domain lookup
ip domain name yourdomain.com
multilink bundle-name authenticated
!
chat-script gsm "" "ATDT*98*1#" TIMEOUT 30 "CONNECT"
username admin privilege 15 secret 5 censored
!
controller Cellular 0/1
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 192.168.3.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 10.1.1.1 255.255.255.252
encapsulation frame-relay
clock rate 2000000
cdp enable
frame-relay interface-dlci 16
frame-relay lmi-type ansi
frame-relay intf-type dce
!
interface Cellular0/1/0
ip address negotiated
encapsulation ppp
dialer in-band
dialer idle-timeout 2147483
dialer string gsm
dialer-group 1
async mode interactive
ppp chap hostname censored
ppp chap password 7 censored
ppp ipcp dns request
cdp enable
!
interface Cellular0/1/1
no ip address
encapsulation ppp
!
interface Dialer0
no ip address
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Serial0/0/0 210 permanent
ip route 0.0.0.0 0.0.0.0 Cellular0/1/0 220 permanent
ip route 172.31.2.0 255.255.255.0 Cellular0/1/0 permanent
ip route 192.168.2.0 255.255.255.0 10.1.1.2 permanent
ip route 192.168.2.0 255.255.255.0 Cellular0/1/0 210 permanent
!
kron occurrence PING in 1 recurring
policy-list ICMP
!
access-list 1 permit any
dialer-list 1 protocol ip list 1
!
control-plane
!
line con 0
logging synchronous
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line 0/1/0
exec-timeout 0 0
script dialer gsm
login
modem InOut
no exec
transport input all
rxspeed 7200000
txspeed 5760000
line 0/1/1
no exec
rxspeed 7200000
txspeed 5760000
line vty 0 4
access-class 23 in
privilege level 15
password 7 censored
login
transport input all
line vty 5 15
access-class 23 in
privilege level 15
password 7 censored
login
transport input all
line vty 16 1370
password 7 censored
login
transport input all
!
scheduler allocate 20000 1000
end
O último problema que estou tendo é que as interfaces 3G caem após apenas alguns minutos de inatividade. Eu tentei usar kron para pingar a interface local HWIC-3G-HSPA (celular 0/1/0) a cada minuto, mas isso não foi bem sucedido. Ping manualmente o IP atribuído (pela telco) para ce0 / 1/0 traz a interface para cima.
Alguma idéia?
Obrigado