AP openwrt encaminhado

1

Estou tentando usar um Alice Gate2 como cliente roteado para servir conexão com a Internet a uma smartTV via Ethernet. A topologia de rede deve ser a seguinte:

Internet - > (com fio) - > [R1] --- > (sem fio) ---- > [R2 (openwrt)] - (com fio) --- > smartTV

R1 está em 192.168.1.0 e R2 em 192.168.2.0

Eu segui o guia no wiki, mas acho que algo está faltando. Eu consegui conectar R2 ao AP wifi do R1, mas não sou capaz de pingar 192.168.1.1 de qualquer host no R2 lan. Além disso, o dhcp em R2 lan não está me atribuindo um ip.

Alguém por favor pode me ajudar a entender o que está perdendo?

aqui está a configuração:

/ etc / config / network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'
config switch 'eth1'
    option enable '1'
    option enable_vlan '1'
    option reset '1'
config interface 'lan'
    option ifname 'eth1'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.2.1'
    option netmask '255.255.255.0'
config interface 'wwan'
    option ifname 'wwan'
    option proto 'static'
    option ipaddr '192.168.1.2'
    option gateway '192.168.1.1'
    option dns '8.8.8.8'
    option netmask '255.255.255.0'

/ etc / config / wireless

config wifi-device 'radio0'
    option type 'mac80211'
    option mode '11'
    option txpower '13'
    option disabled '0'
    option channel '3'
    option macaddr 'xx:xx:xx:xx:xx:xx'
    option hwmode '11g'
config wifi-iface
    option device 'radio0'
    option network 'wwan'
    option ssid 'SSID'
    option encryption 'psk2+aes'
    option mode 'sta'
    option key 'PASSWORD'

/ etc / config / dhcp

config dnsmasq
    option domainneeded     1
    option boguspriv        1
    option filterwin2k      0  # enable for dial on demand
    option localise_queries 1
    option rebind_protection 0  # disable if upstream must serve RFC1918 address
    option rebind_localhost 1  # enable for RBL checking and similar services
    #list rebind_domain example.lan  # whitelist RFC1918 responses for domains
    option local    '/lan/'
    option domain   'lan'
    option expandhosts      1
    option nonegcache       0
    option authoritative    1
    option readethers       1
    option leasefile        '/tmp/dhcp.leases'
    option resolvfile       '/tmp/resolv.conf.auto'
    #list server            '/mycompany.local/1.2.3.4'
    #option nonwildcard     1
    #list interface         br-lan
    #list notinterface      lo
    #list bogusnxdomain     '64.94.110.11'
config dhcp lan
    option interface        lan
    option start    100
    option limit    150
    option leasetime        12h
config dhcp wan
    option interface        wan
    option ignore   1

/ etc / config / firewall

config defaults
    option syn_flood        1
    option input            ACCEPT
    option output           ACCEPT 
    option forward          REJECT
    option disable_ipv6     1
config zone
    option name             lan
    option network          'lan'
    option input            ACCEPT 
    option output           ACCEPT 
    option forward          REJECT

config zone
    option name             wan
    list network wan
    list network wan6
    list network wwan
    option input            REJECT
    option output           ACCEPT 
    option forward          REJECT
    option masq 1
    option mtu_fix
    option masq             1 
    option mtu_fix          1

config forwarding 
    option src              lan
    option dest             wan


config rule
    option name             Allow-DHCP-Renew
    option src              wan
    option proto            udp
    option dest_port        68
    option target           ACCEPT
    option family           ipv4


config rule
    option proto            icmp
    option icmp_type        echo-request
    option family           ipv4
    option target           ACCEPT

config rule
    option name             Allow-DHCPv6
    option src              wan
    option proto            udp
    option src_ip           fe80::/10
    option src_port         547
    option dest_ip          fe80::/10
    option dest_port        546
    option family           ipv6
    option target           ACCEPT

config rule
    option name             Allow-ICMPv6-Input
    option src              wan
    option proto    icmp
    list icmp_type          echo-request
    list icmp_type          destination-unreachable
    list icmp_type          packet-too-big
    list icmp_type          time-exceeded
    list icmp_type          bad-header
    list icmp_type          unknown-header-type
    list icmp_type          router-solicitation
    list icmp_type          neighbour-solicitation
    option limit            1000/sec
    option family           ipv6
    option target           ACCEPT

config rule                                   
    option name             Allow-ICMPv6-Forward
    option src              wan
    option dest             *
    option proto            icmp
    list icmp_type          echo-request
    list icmp_type          destination-unreachable
    list icmp_type          packet-too-big
    list icmp_type          time-exceeded
    list icmp_type          bad-header
    list icmp_type          unknown-header-type
    option limit            1000/sec
    option family           ipv6
    option target           ACCEPT

config include
    option path /etc/firewall.user
    
por Alessio Trivisonno 11.06.2016 / 18:35

0 respostas