O resolvedor DNS só será movido para os outros servidores de nomes se o primeiro retornar um erro (por exemplo,SERVFAIL) ou não puder ser alcançado. Se o servidor DNS retornar NXDOMAIN , o resolvedor considerará a resposta correta e não verificará as outras. NXDOMAIN é considerado uma resposta final definitiva de que o domínio solicitado não existe.
No seu caso, o primeiro namserver é alcançado e está lhe negando.
Nesse named.conf do namserver, você deve ter algo como allow-query { any; };
Ou
Uma solução pode ser alterar temporariamente a ordem dos servidores de nomes em /etc/resolv.conf & coloque 8.8.8.8 primeiro
Ou
Só para direcionar dig para usar 8.8.8.8 como o servidor DNS na linha de comando que você pode fazer:
dig @8.8.8.8 google.de