Rede sem fio não funciona depois de continuar no Ubuntu 14.04

78

[Atualizar]:
O mesmo problema existe no Kubuntu e é resolvido da mesma maneira.
[Resolvido]:
Ao aplicar o seguinte comando nmcli nm , obtive o seguinte:

Antes de suspender

RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN      
running         connected       enabled         enabled    enabled         enabled  

como você pode ver o estado está conectado e o resto está ativado e funcionando

Após suspender

RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN      
running         asleep          enabled         enabled    enabled         disabled

Como você pode ver que o estado está adormecido, o que significa que nosso querido gerente de rede ainda está cochilando, portanto, para resolver use a seguinte linha de comando:
sudo nmcli nm sleep false
isso diz ao gerente de rede para acordar. para tornar isso permenant:
crie um script em /etc/pm/sleep.d contendo o seguinte (e não se esqueça de marcar o script como executável):

#!/bin/sh

case "" in
        resume|thaw)
        nmcli nm sleep false
                ;;
esac

Graças a this

O problema original:

Acabei de baixar o Ubuntu 14.04 e instalei no meu laptop: ASUS X61SL com processador Intel P8400 Core2Duo x64.
Quando fecho a tampa, o sistema é suspenso, mas quando abro a tampa novamente e retoma, a rede sem fio não é ativada (a rede como um todo está desabilitada) e quando eu seleciono "Habilitar Rede" nada acontece. Esta é a informação sobre o meu adaptador sem fio:

$ lspci | grep -i wireless
02:00.0 Network controller: Qualcomm Atheros AR928X Wireless Network Adapter (PCI-Express) (rev 01)  

Este problema não estava presente no Ubuntu 13.04, Linux Mint Debian Edition ou Debian 7 wheezy (GNOME ou KDE).

Editar: poucos testes com os seguintes resultados:
O problema afeta minha rede sem fio e com fio.
Nota: Eu preciso adicionar a linha pci=nomsi ao grub para inicializar.
Quando sair manualmente, em seguida, suspender, em seguida, retomar o login em tudo funciona bem.
Ao suspender diretamente enquanto estiver logado, o problema acontece.
Bloquear e suspender causa o mesmo problema que suspender diretamente.
Além disso, este problema parece afetar a função de logout: se você escolheu efetuar logout no menu do usuário no painel de unidade, então não será feito logout, mas se você usar a linha de comando gnome-session-quit --logout , poderá efetuar logout. Agora com lshw -C network output:
Normal (rede totalmente funcional):

  *-network               
       description: Ethernet interface
       product: 191 Gigabit Ethernet Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: [email protected]:00:04.0
       logical name: eth0
       version: 02
       serial: 00:24:8c:1e:f8:53
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.4 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 memory:fddfcc00-fddfcc7f ioport:cc00(size=128)
  *-network
       description: Wireless interface
       product: AR928X Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: [email protected]:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:15:af:e2:13:db
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.13.0-24-generic firmware=N/A ip=6.6.6.8 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:fdff0000-fdffffff

Após o resumo ("/etc/pm/config.d" não contém "unload_modules"):

 *-network DISABLED      
       description: Ethernet interface
       product: 191 Gigabit Ethernet Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: [email protected]:00:04.0
       logical name: eth0
       version: 02
       serial: 00:24:8c:1e:f8:53
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.4 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 memory:fddfcc00-fddfcc7f ioport:cc00(size=128)
  *-network DISABLED
       description: Wireless interface
       product: AR928X Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: [email protected]:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:15:af:e2:13:db
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.13.0-24-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:fdff0000-fdffffff

Quando adicionei o arquivo unload_modules ao diretório "/etc/pm/config.d" como sugerido por aqui , depois de fazer logout, suspender, retomar e fazer login, a rede funciona, mas não consigo me conectar à minha rede sem fio.
Novamente o resultado de lshw -C network Após a retomada ("/etc/pm/config.d" contém "unload_modules"):

 *-network DISABLED      
       description: Ethernet interface
       product: 191 Gigabit Ethernet Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: [email protected]:00:04.0
       logical name: eth0
       version: 02
       serial: 00:24:8c:1e:f8:53
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.4 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 memory:fddfcc00-fddfcc7f ioport:cc00(size=128)
  *-network DISABLED
       description: Wireless interface
       product: AR928X Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: [email protected]:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:15:af:e2:13:db
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.13.0-24-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:fdff0000-fdffffff

O conteúdo de 'unload_modules ", em que:

SUSPEND_MODULES="$SUSPEND_MODULES ath9k"
SUSPEND_MODULES="$SUSPEND_MODULES sis190"

Onde 'ath9k' é o meu módulo sem fio e 'sis190' é o meu módulo Ethernet.

    
por Ossama Nasser 22.04.2014 / 15:13

5 respostas

27

As respostas acima não funcionaram para mim em 14.10. Depois de um pouco de tentativa e erro, acabei com isso,

#!/bin/sh

case "" in
  resume|thaw)
    nmcli r wifi off && nmcli r wifi on ;;
esac

Coloque isso em /etc/pm/sleep.d/10_resume_wifi
Torne-o executável sudo chmod 755 /etc/pm/sleep.d/10_resume_wifi e o problema deve ser corrigido imediatamente.

    
por Owais Lone 13.04.2015 / 22:03
21

Eu tenho uma solução, mas é só para reiniciar seu gerenciador de rede.

sudo service network-manager restart

Não é a solução permanente.

    
por hmjha 20.03.2016 / 11:40
4

O script que finalmente funcionou para mim:

$ cat /etc/pm/sleep.d/10_resume_wifi 
#!/bin/sh

case "" in
  resume|thaw) nmcli nm sleep false ;;
esac

$ ll /etc/pm/sleep.d/10_resume_wifi
-rwxr-xr-x 1 root root 70 mars  31 09:09 /etc/pm/sleep.d/10_resume_wifi

A outra resposta tem erros de digitação (eles podem ser corrigidos, eu sei), mas nunca funcionou para mim de qualquer maneira.

    
por Augustin Riedinger 31.03.2015 / 09:21
0

Isso funcionou para mim no Ubuntu 14.04 no laptop Dell Precision.

Em um terminal, digite:

sudo nano /etc/pm/sleep.d/10_resume_wifi

Em seguida, cole em (ctrl + v):

#!/bin/sh
case "" in
resume|thaw)
    nmcli nm wifi on
    ;;
esac

Em seguida, torne o script executável:

sudo chmod +x /etc/pm/sleep.d/10_resume_wifi

Teste a suspensão e acorde para ver o wifi ligado !!

    
por FizxMike 15.05.2016 / 02:05
-3

Você tentou fazer outro script como este entrar no kate:

#/bin/sh

    case ![1] in
        ./bin/sh
        network="true"
        nmcli nm -c sleep=false -network
    endasc

e salve-o como arquivo jsin7 em / etc / network, e chame-o de network.d e isso pode funcionar bem.

    
por Michael 30.05.2014 / 11:45