O MariaDB no Debian / Ubuntu, por padrão, autentica via sockets Unix e verifica o ID do usuário unix efetivo do usuário que está chamando mysql . Se você não executar mysql como root (ou com sudo ), isso falhará.
Para mudar isso de volta para o método clássico, faça o login no banco de dados com sudo ( sudo mysql -u root ) e altere seu usuário assim:
ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'test';
FLUSH PRIVILEGES;