Como desabilito a sessão de convidado?

180

Como faço para desativar a sessão de convidado no Ubuntu 11.10 ou superior? Eu não quero que as pessoas possam usar meu computador sem usar uma senha para entrar!

    
por Jeremy Bicha 22.09.2011 / 17:45
fonte

12 respostas

117

Atualizado em: 2016-agosto

Para o Ubuntu 16.04 LTS (15.10 ou posterior)

Adaptado de: LightDM Ubuntu Wiki - Configuração

  • Arquivos de configuração fornecidos pelo sistema em /usr/share/lightdm/ são não destinados a serem editáveis pelo usuário. Em vez disso, os usuários devem usar: /etc/lightdm/
  • Versões mais recentes do LightDM (Ubuntu 15.10 ou posterior) usam [Seat:*] em vez de [SeatDefaults]

Basta executar isso (uma vez) no terminal:

sudo sh -c 'printf "[Seat:*]\nallow-guest=false\n" >/etc/lightdm/lightdm.conf.d/50-no-guest.conf'

Para desfazer (restaurar a opção Convidado), remova o arquivo criado :

sudo rm /etc/lightdm/lightdm.conf.d/50-no-guest.conf

Para o Ubuntu 14.04 LTS (até 15.04)

Adaptado de: Fóruns do Ubuntu - localização dos arquivos de configuração lightdm em 14.04

Basta executar isso (uma vez) no terminal:

sudo sh -c 'printf "[SeatDefaults]\nallow-guest=false\n" >/usr/share/lightdm/lightdm.conf.d/50-no-guest.conf'

Você não terá mais a opção "Convidado" como login, no seu próximo login.

Para desfazer (restaurar a opção Convidado), remova o arquivo criado :

sudo rm /usr/share/lightdm/lightdm.conf.d/50-no-guest.conf

Para o Ubuntu 12.04 LTS (até 13.10)

Método mais simples.

Basta executar isso (uma vez) no terminal:

sudo /usr/lib/lightdm/lightdm-set-defaults -l false

Você não terá mais a opção "Convidado" como login, no seu próximo login.

  • Isso simplesmente anexa allow-guest=false a /etc/lightdm/lightdm.conf .

  • Deve funcionar a partir de 11.10 em diante (já que eles também usam LightDM ).

Para desfazer (restaurar a opção Convidado):

sudo /usr/lib/lightdm/lightdm-set-defaults -l true
    
por david6 28.07.2012 / 01:38
fonte
113
  

Use este método somente se você estiver usando o Ubuntu Desktop. Se você estiver usando outro sabor, como o Xubuntu ou o Lubuntu, consulte esta resposta .

Se você estiver usando o LightDM padrão, edite /etc/lightdm/lightdm.conf para que fique assim:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Se você estiver usando o GDM (que era o padrão nas versões anteriores do Ubuntu), desinstale o gdm-guest-session .

Para o Ubuntu 13.10 para 14.10 , o arquivo foi movido para /etc/lightdm/lightdm.conf.d/50-unity-greeter.conf

Para o Ubuntu 14.10 ou superior, o arquivo foi movido para /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf

    
por Jeremy Bicha 22.09.2011 / 17:48
fonte
23

Digite isto no terminal

gksu gedit /etc/lightdm/lightdm.conf

Você verá o seguinte:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu

Adicione allow-guest=false ao final para que seu resultado final seja:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Salve o documento e saia do editor de texto.

De volta ao terminal, reinicie o gerenciador de exibição. (Isso encerrará a sessão de login gráfica, encerrando imediatamente todos os programas em execução, portanto, certifique-se de que seu trabalho - como qualquer documento aberto - seja salvo primeiro!)

sudo restart lightdm

Com a sessão de login gráfica encerrada, você é retornado à tela de login, onde você notará que a conta de convidado está desativada.

É isso aí - a conta de convidado não pode mais ser usada.

    
por sarveshlad 25.10.2011 / 03:08
fonte
16

Você pode fazer isso usando o Ubuntu Tweak .

Para instalá-lo, use estes comandos:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

Após a instalação, navegue até Ajustes Configurações de login e desative a "conta Convidado".

    
por Eliran Malka 21.10.2012 / 19:54
fonte
11

Basta executar

gksudo gedit /etc/lightdm/lightdm.conf

Adicione a seguinte linha

allow-guest=false

Em seguida, (isso o desconectará imediatamente, encerrando todos os programas em execução na sua sessão gráfica, por isso salve seu trabalho primeiro):

sudo restart lightdm
    
por LnxSlck 27.07.2012 / 18:42
fonte
3

Para o Ubuntu 13.10 , adicione

allow-guest=false

para o arquivo /etc/lightdm/lightdm.conf.d/10-ubuntu.conf .

    
por uahummer 20.10.2013 / 15:27
fonte
3

13.04 e posterior

  1. Execute este comando em um terminal

    sudo /usr/lib/lightdm/lightdm-set-defaults -l false
    
  2. Reinicialize sua máquina ou reinicie lightdm com o seguinte comando: (Isso será feito imediatamente, salve seus dados)

    sudo restart lightdm
    

Aparentemente, funciona em 13.10 (não posso me testar, mas há um comentário aqui ).

Estou usando o 13.04 e tudo isso adiciona allow-guest=false a /etc/lightdm/lightdm.conf , mas pode ser diferente em 13.10.

Originalmente por david6 daqui: link

    
por kiri 21.10.2013 / 09:33
fonte
3

Como desativar esta opção no futuro

Acabei de me deparar com o mesmo problema na minha nova instalação do trusty / 14.04. Também para minha surpresa, não consegui encontrar a pasta lightdm.conf.d dentro de /etc/lightdm/ just users.conf .

Investigação

$ find / -iname *lightdm* 2>/dev/null | grep -v /mnt | grep -v /media | grep -v /home
[...]
/usr/share/lightdm/lightdm.conf.d
[...]

Aha, ai está você. O que há aí?

$ ls -1 /usr/share/lightdm/lightdm.conf.d/
50-greeter-wrapper.conf
50-guest-wrapper.conf
50-ubuntu.conf
50-unity-greeter.conf
50-xserver-command.conf

Ok, o que tem aí?

$ cat /usr/share/lightdm/lightdm.conf.d/*
[SeatDefaults]
greeter-wrapper=/usr/lib/lightdm/lightdm-greeter-session
[SeatDefaults]
guest-wrapper=/usr/lib/lightdm/lightdm-guest-session
[SeatDefaults]
user-session=ubuntu
[SeatDefaults]
greeter-session=unity-greeter
[SeatDefaults]
# Dump core
xserver-command=X -core

Conclusão

Encontramos vários arquivos de configuração semelhantes ao formato INI seguindo o esquema de nomenclatura de 50-${some-descriptive-name}.conf e configurando as chaves para a seção [SeatDefaults] .

Não vamos editar nenhum desses arquivos porque eles devem ser gerenciados pelo gerenciador de pacotes, mas agora devemos adicionar e gerenciar nossos bits de configuração customizada para /etc .

Solução

Diante do exposto, esse lightdm é o gerenciador de exibição e os arquivos de configuração são parecidos com os acima. A solução a seguir deve funcionar:

  1. Crie os diretórios ausentes:

    $ sudo mkdir -p /etc/lightdm/lightdm.conf.d
    
  2. Adicione um arquivo de configuração personalizado executando:

    $ sudo nano /etc/lightdm/lightdm.conf.d/50-disable-guest-session.conf
    

    e cole as seguintes linhas:

    [SeatDefaults]
    allow-guest=false
    

    Em seguida, salve ( Ctrl + O ) e feche ( Ctrl + X ).

  3. Agora faça o logout e mude para um terminal virtual ( Ctrl + Alt + F1 ) e execute:

    $ sudo service lightdm restart
    

    A opção de sessão de convidado deve agora desaparecer. Se algo não estiver funcionando corretamente, você agora sabe onde a configuração padrão está armazenada e que você não a alterou.

Leitura adicional

por LiveWireBT 16.03.2014 / 03:32
fonte
2

Instale o ubuntu-tweak, vá para a aba tweak, desligue o botão guest e reinicie. É isso aí!

Pode-se achar o terminal mais fácil, mas no caso da necessidade de ligar a conta do hóspede, então alguém teria que visitar esta página novamente e ver as instruções (ou melhor, desfazer). Essa é a vantagem da coisa GUI ... lembre-se facilmente.

    
por tadatma 27.09.2012 / 19:33
fonte
2

Alterar allow-guest=true para 'false' em /etc/lightdm/lightdm.conf

Você pode reiniciar ou reiniciar o serviço no terminal:

sudo restart lightdm

Supondo que você esteja usando lightdm , que é padrão em 11.10.

    
por filescraps 21.10.2011 / 12:42
fonte
0

Eu estou no mesmo caso, o arquivo /etc/lightdm/lightdm.conf não existe em UBUNTU 13.10.

Eu tento criar o arquivo /etc/lightdm/lightdm.conf com essa linha allow-guest=false , e o CRASH, o sistema não inicia corretamente, apenas o modo console ...

Eu tento editar o arquivo /etc/lightdm/lightdm.conf.d/10-ubuntu.conf e funciona corretamente.

Edite o arquivo

sudo vim /etc/lightdm/lightdm.conf.d/10-ubuntu.conf

E insira as linhas que você precisa

# to disable guest login
allow-guest=false
# to enable user login manually
greeter-show-manual-login=true

E o último, reinicie o seu sistema

sudo reboot

Eu acho que isso funciona bem se você reiniciar apenas o ligthgdm

sudo service lightdm restart
    
por Foncu 23.10.2013 / 16:05
fonte
0

Abra o terminal

gksudo gedit /etc/lightdm/lightdm.conf

Adicione a seguinte linha

allow-guest=false

Salve e saia do arquivo.

    
por scouser73 21.10.2013 / 09:29
fonte