Tela em branco após a instalação do driver restrito da nvidia

98

Eu instalei o atual driver restrito da nvidia e reiniciei minha máquina e agora eu recebo uma tela preta ou em branco.

Como posso corrigir isso?

    
por LaMinifalda 13.04.2017 / 14:23
fonte

16 respostas

72

Remover todos os pacotes relacionados à Nvidia

  1. Efetue login em um terminal: Ctrl + Alt + F1 (o terminal é visível com uma tela em branco)

  2. sudo apt-get remove --purge nvidia-*

Começar do zero

  1. sudo apt-get remove --purge xserver-xorg-video-nouveau xserver-xorg-video-nv

Reinstalar tudo

  1. sudo apt-get install nvidia-common
  2. sudo apt-get install xserver-xorg-video-nouveau
  3. sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core

Reconfigure o servidor X

  1. sudo dpkg-reconfigure xserver-xorg

Fonte: Wiki do Ubuntu

    
por Marco Scannadinari 17.11.2016 / 17:38
fonte
9
  1. Remova os drivers que possam estar causando o problema,
  2. abra o terminal e digite (abra-o no painel, usando o ícone do Ubuntu no canto esquerdo)

    sudo apt-get --purge remove nvidia
    

    ou

    sudo apt-get --purge remove nvidia-current
    

    (dependendo de qual você instalou) ou desative-os das configurações restritas do driver.

  3. reinicialização.

  4. depois, em um terminal, digite:

    sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
    sudo apt-get update
    sudo apt-get install nvidia-current nvidia-settings
    
  5. reinicialização.

por Uri Herrera 10.05.2011 / 08:32
fonte
5

Talvez o Ubuntu esteja funcionando, mas usando outra saída de cartão. Para mim, minha nVidia GeForce 7300 possui 2 saídas, uma VGA e uma DVI. Parece que a saída padrão quando você instala os drivers é para DVI, mas eu não tenho um monitor DVI, então eu consegui chegar ao Recovery Mode (disponível no GRUB quando você inicializa) e digite:

nvidia-xconfig --twinview --twinview-orientation="Clone"

Agora reinicie.

Este comando direciona os mesmos gráficos para as duas saídas. A partir daí, você pode continuar experimentando esse utilitário da nVidia até conseguir o que deseja. Para mais informações, digite:

nvidia-xconfig -A | less

Espero que ajude.

    
por Javier Rios 28.02.2012 / 18:36
fonte
5

No meu caso, foi um problema com o monitor dando meu GPU Nvidia um EDID ruim

Para depurar seu erro, você pode adicionar esta linha à seção de tela no arquivo /etc/X11/xorg.conf

Option         "ModeDebug" "true"

Agora, verifique seu /var/log/Xorg.0.log file .

Se você encontrar um erro como este:

NVIDIA(0): Unable to get display device DFP-0's EDID; cannot compute DPI

Depois, você pode resolvê-lo adicionando esta linha à seção de dispositivos

Option         "IgnoreEDIDChecksum" "DFP"
    
por Olav Grønås Gjerde 20.04.2013 / 12:55
fonte
3

Pressione Alt + Ctrl + F1 para chegar ao tty1 (terminal), depois execute:

sudo apt-get --purge remove nvidia*

Isso removerá qualquer pacote de driver da nvidia. Se isso ainda não funcionar, tente também:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.mybak

Isso removerá um arquivo de configuração do xorg corrompido se ele existir. Você precisará reiniciar depois de terminar esses comandos. (Ctrl + Alt + del)

PS. Se você tem uma placa nvidia optimus, não instale o x-swat ou qualquer outro driver nvidia. Os melhores drivers para os cartões nvidia optimus vêm do projeto bumblebee .

    
por Sepero 15.07.2012 / 17:38
fonte
2

Isso aconteceu comigo ao executar uma CPU AMD: Aprendi que era um IOMMU / AMD -v Bug = Incompatível com a Nvidia. A desativação das configurações do BIOS de virtualização corrigiu isso.

    
por TardisGuy 16.07.2012 / 14:32
fonte
1

O segmento nos fóruns do Ubuntu ajuda você?

Em suma, parece que os pacotes de cabeçalho linux para alguns dos kernels (notavelmente os kernels PAE) não estão instalados corretamente, e a compilação do driver nvidia falha silenciosamente ao instalar os pacotes nvidia.

    
por neutro 13.05.2011 / 19:58
fonte
0

Em relação ao título do tópico: Qual é a versão atual do driver nvidia restrito usado no Ubuntu natty?

Você pode encontrar qualquer coisa sobre lançamentos, versões, bugs, recursos solicitados no Launchpad . Para entender do que se trata, você pode fazer o tour deles .

A questão sobre a versão mais recente do driver nVidia pode ser encontrada em pacote binário “nvidia-current” no Ubuntu Natty i386 . Assim, a partir de 2011-04-20, a última versão é 270.41.06-0ubuntu1. Mas isso não é necessariamente o recomendado . O mais recente para mim sempre parece buggy (como 'rasgando' etc).

    
por Rinzwind 10.05.2011 / 08:33
fonte
0

Em vez de usar o nvidia-current você deve realmente tentar usar um driver nvidia mais antigo, por exemplo. o 173.xx. Isso resolveu o problema para mim. Basta iniciar o jockey-gtk e escolher o driver 173.xx. Então reinicie seu sistema.

    
por Wolf F. 14.05.2011 / 07:11
fonte
0

Experimente em /etc/default/grub :

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR='lsb_release -i -s 2> /dev/null || echo Debian'
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_GFXMODE=1680x1050x32

Substitua "1680x1050x32 | por sua resolução nativa (para executar vbeinfo no console do grub ao inicializar).

Em seguida, em /etc/grub.d/00_header :

set gfxmode=${GRUB_GFXMODE} <-- FIND THIS LINE
set gfxpayload=keep <-- ADD THIS LINE DIRECTLY BENEATH

Atualizar o grub:

sudo update-grub

Pode funcionar ...

    
por con-f-use 18.05.2011 / 19:16
fonte
0

Experimente acpi=off . Isso resolveu a minha inicialização no problema de tela em branco para o Ubuntu 11.10.

    
por VirusC 16.10.2011 / 12:14
fonte
0

Eu também tenho uma tela em branco, mas isso foi em um laptop com o cartão nVidia optimus 4200m. O Optimus não parece ser bem suportado no Ubuntu. Eu tive que desabilitar o otimus do BIOS e depois reinstalar o driver nividia. Mais aqui se você quiser ler o link

    
por Kaerax 13.01.2012 / 07:16
fonte
0

Eu estava recebendo uma tela preta ao iniciar. Eu tenho uma placa gráfica NVIDIA 6200. Renomear o xorg.config e a reinicialização funcionou para mim. O arquivo xorg.config criado por nvidia-xconfig: versão 304.51 (buildmeister@swio-display-x86-rhel47-06.nvidia.com) estava causando o problema.

    
por user155543 04.05.2013 / 17:45
fonte
0

O maior problema que tive foi ter um Macbook Pro para instalar os drivers da Nvidia !!!

A solução é alterar a Partição de Inicialização Principal para REMOVER EFI e usar o Legacy MBP.

Isso é discutido em algumas páginas da Web, mas não é tão fácil de seguir.

link

Usando essa ideia, inicializei a partir de um Live CD e depois usei o Gparted para remover a partição de inicialização EFI, alterei da EFI para a FAT32 e depois usei o Boot-Repair como uma inicialização herdada usando a partição principal com o 13.04 64 bit instalado

link

--- ATENÇÃO FAÇA O BACK UP DOS SEUS DADOS PRIMEIRO. VOCÊ PODERIA REALIZAR TUDO NO SEU HDD ---

Insira o Live CD - Inicialize como o Ubuntu Executar o Gparted - Mude a partição de inicialização do EFI de EFI para FAT32.

abra um novo Terminal e digite:

sudo add-apt-repositório ppa: yannubuntu / boot-repair & amp; & amp; sudo apt-get update

  • Pressione Enter.

  • Em seguida, digite:

sudo apt-get instalar -y boot-repair & amp; & amp; (boot-repair & amp;)

No reparo da inicialização, selecione OPÇÕES AVANÇADAS

Desmarque a opção Usar o arquivo EFI padrão nas opções principais Desmarque a partição / boot / efi em separado no GRUB LOCATION

siga as instruções sobre como usar o carregador de boot herdado que o Boot Repair lhe dará.

Agora instale e carregue os drivers NVidia como muitos post

Eu usei o método 2 nesta página link

Eu estava trabalhando nisso por provavelmente 18 horas e tentei TODAS as opções disponíveis. Quero dizer, cada possível maneira de instalar esses drivers malditos, e esta foi a única solução que funciona para o Macbook Pro 7.1 rodando 13.04 com Nvidia_current (nvidia_304)

    
por MB- 15.09.2013 / 05:01
fonte
0

Eu tentei de tudo aqui e a solução para mim foi mudar para o lightdm, funciona perfeitamente agora!

    
por James Heald 28.03.2017 / 16:53
fonte
-5

Basta instalar o ubuntu limpo ( sem atualizações, sem software ) conectar-se à internet, baixar o driver e instalar e reiniciar! Trabalhou para mim! Obrigado pelo meu vizinho !!! (essa foi a ideia dele)

    
por Lukas 02.07.2013 / 09:46
fonte

Tags