Onde posso encontrar o Vim 7.3?

34

O Vim 7.3 está fora, mas não está disponível nas fontes. Onde posso obter um pacote de instalação para a versão 7.3? Não quero instalá-lo manualmente.

    
por 1passenger 14.10.2010 / 22:10

8 respostas

29

Também não encontrei nenhum pacote oficial, por isso criei um PPA. Sinta-se à vontade para usá-lo:

link

apt-add-repository ppa:passy/vim
apt-get update
apt-get upgrade

Referência: Como usar os PPAs

    
por passy 14.10.2010 / 22:16
13

Eu criei o vim a partir de fontes usando essa sequência de comandos:

sudo apt-get build-dep vim-gnome
sudo apt-get install libssl-dev
mkdir -p ~/src
hg clone https://vim.googlecode.com/hg/ ~/src/vim
cd ~/src/vim
./configure --enable-multibyte --enable-pythoninterp --enable-cscope --enable-xim --with-features=big \
            --with-python-config-dir=/usr/lib/python2.7/config-$(dpkg-architecture -qDEB_HOST_MULTIARCH)
make

e eu corro em sem instalar usando este script de wrapper ~/bin/vim :

#!/bin/sh
vimhome=$HOME/src/vim
if test -x $vimhome/src/vim; then
    VIMRUNTIME=$vimhome/runtime $vimhome/src/vim "[email protected]"
else
    /usr/bin/vim "[email protected]"
fi

Mas eu fiz isso apenas porque não consegui encontrar um PPA naquela época.

    
por Marius Gedminas 15.10.2010 / 02:23
7

Vimwiki agora tem algumas instruções para construir e instalar o vim a partir do código-fonte, para qualquer outra pessoa que ache isso:

Este é o texto relevante:

  

Construindo GUI Vim no Ubuntu

     

Você precisa do desenvolvimento necessário   pacotes no Ubuntu para construir a GUI:

sudo apt-get install libncurses5-dev libgnome2-dev libgnomeui-dev  libgtk2.0-dev libatk1.0-dev libbonoboui2-dev libcairo2-dev libx11-dev libxpm-dev libxt-dev
     

Comandos para construir e instalar GUI Vim:

cd vim7
cd src
make distclean
./configure --with-features=huge --enable-gui=gnome2
make
sudo make install
    
por Nick Knowlson 22.02.2011 / 08:57
3

O PPA do Passy não funcionou para mim, então eu instalei pacotes vim do natty. A única coisa que você precisa além dos pacotes vim do natty são o ruby1.8 e o libruby1.8 debs.

Provavelmente não é o mais genial das soluções, mas funcionou bem para mim.

    
por miloshadzic 03.12.2010 / 17:58
2

O ppa funcionou para mim, mas eu tive que mudar meu .vimrc:

" Stops vim from complaining about split lines using \
set nocp

" Fixes backspace not working to dedent a line
set backspace=indent,eol,start
    
por ricobl 17.04.2011 / 22:13
2

Depois de pesquisar algumas vezes, encontrei um PPA com o vim 7.3 criado para 10.04, 10.10, 11.04 e 11.10 . Existem alguns pacotes lá, então dê uma olhada em toda a lista caso outro pacote seja atualizado e cause problemas para você. Se você quiser apenas pegar os pacotes vim, você pode baixá-los - aqui estão os links 10.04 e esta página fornece a lista completa com áreas expansíveis em cada pacote, mostrando a lista completa de links para pacotes individuais.

O encantamento mágico é:

sudo apt-add-repository ppa:blueyed/ppa
sudo apt-get update
sudo apt-get upgrade

Referência: Como usar os PPAs

    
por Hamish Downer 04.01.2012 / 00:48
1

Você pode compilá-lo a partir do código-fonte, no qual sempre pode obter as melhores e mais recentes. Você precisará seguir estas etapas: libncurses5-dev 1. sudo apt-get instalar build-essentials libncurses5-dev

  1. Receba as informações mais recentes no link

  2. Extraia o arquivo compactado para um diretório com bunzip2.

  3. Digite o diretório e digite:

    ./configure B. fazer C. sudo make install D. sudo ln -s / usr / local / bin / vim / usr / bin / vim

Concluído. Agora você tem a última versão do Vim no seu sistema.

    
por user4016 15.10.2010 / 01:52
1

O Vim 7.3 está nos repositórios do Ubuntu do Ubuntu 11.04 em diante.

    
por Flimm 23.05.2013 / 21:38

Tags