Os dispositivos USB montados automaticamente são somente de leitura

29

Desde que atualizei para o Ubuntu 12.10, o automout de dispositivos USB não funciona como esperado. Quando eu conecto um dispositivo de armazenamento, ele é reconhecido corretamente, mas não tenho privilégios de gravação nele. Eu pensei, que talvez as permissões de / media não estejam corretamente definidas, mas eu não sei, como elas devem ser. Eles são assim:

drwxr-xr-x  14 root  root   4096 Jan 13 19:37 media

Também verifiquei se meu usuário é membro do grupo plugdev e ele definitivamente é.

O que mais poderia ser a causa desse problema?

Atualização: aqui está a saída do dmesg depois de conectar um dispositivo de armazenamento USB: link

    
por user5950 25.01.2013 / 14:53

5 respostas

35

Eu acho que você está sofrendo o bug # 1021375

Você pode solucioná-lo renomeando a pasta ~ / .config / nautilus e, em seguida, efetuar logout e login novamente.

  1. mv ~/.config/nautilus ~/.config/nautilus-bak
  2. Logout
  3. Login.
por desgua 29.01.2014 / 20:43
20
sudo mount -o remount,rw /media/MonterFolderName

Isso deve resolver o problema. Não tenho certeza de como torná-lo permanente. Não tenho certeza se chmod funcionaria se, no primeiro caso, o USB não estiver montado no modo readwrite.

Testado no Ubuntu 12.10 e 13.

    
por Jalpesh 30.07.2013 / 12:28
11

Quando o USB é inserido, ele é montado no /media/<username> que você deve ter permissões através de uma lista de controle de acesso.

Você pode verificar quais são as permissões, por exemplo,

[email protected]:34:50:~$ getfacl /media/bcbc
# file: media/bcbc
# owner: root
# group: root
user::rwx
user:bcbc:r-x
group::---
mask::r-x
other::---

Se não houver lista de controle de acesso, basta excluir o diretório e recriá-lo com as permissões corretas.

sudo rmdir /media/<username>

Ou adicione a ACL:

sudo setfacl -m u:<username>:rx /media/<username>
    
por bcbc 03.02.2013 / 05:34
2

O problema parece ter desaparecido

Esta é uma pergunta de 5 anos no Ubuntu 12.10. O link dmesg não está mais disponível na pergunta do OP. Mas se eu conectar um Ubuntu 18.04 Live USB com armazenamento persistente dmesg revela:

$ dmesg | tail -n18
[115528.249547] usb-storage 1-9:1.0: USB Mass Storage device detected
[115528.250152] scsi host2: usb-storage 1-9:1.0
[115528.250474] usbcore: registered new interface driver usb-storage
[115528.255685] usbcore: registered new interface driver uas
[115529.281407] scsi 2:0:0:0: Direct-Access     Verbatim STORE N GO       PMAP PQ: 0 ANSI: 6
[115529.282090] sd 2:0:0:0: Attached scsi generic sg1 type 0
[115529.992200] sd 2:0:0:0: [sdb] 30261248 512-byte logical blocks: (15.5 GB/14.4 GiB)
[115529.992998] sd 2:0:0:0: [sdb] Write Protect is off
[115529.993006] sd 2:0:0:0: [sdb] Mode Sense: 23 00 00 00
[115529.993787] sd 2:0:0:0: [sdb] No Caching mode page found
[115529.993797] sd 2:0:0:0: [sdb] Assuming drive cache: write through
[115530.592616]  sdb: sdb1 sdb2 sdb3 sdb4 sdb5
[115530.596279] sd 2:0:0:0: [sdb] Attached SCSI removable disk
[115531.018019] EXT4-fs (sdb5): warning: mounting unchecked fs, running e2fsck is recommended
[115531.470201] EXT4-fs (sdb5): mounted filesystem without journal. Opts: (null)
[115531.480738] ISO 9660 Extensions: Microsoft Joliet Level 3
[115531.483397] ISO 9660 Extensions: Microsoft Joliet Level 3
[115531.512219] ISO 9660 Extensions: RRIP_1991A

Diferentemente de OP, não há aviso para somente leitura. Observe a linha:

sd 2:0:0:0: [sdb] Write Protect is off

Aparentemente, qualquer que tenha sido o problema há 5 anos, ele não existe mais hoje no Ubuntu 16.04 LTS . Também para a única outra versão do LTS hoje, 14.04 também não me lembro de ser um problema. Apenas os cartões SD RAM vêm à mente como sendo somente leitura, o que é um problema completamente diferente.

    
por WinEunuuchs2Unix 06.03.2018 / 04:03
1

Não há nada de errado com as opções de montagem e o arquivo fstab, até onde eu saiba, você só precisa usar o comando abaixo para obter as permissões necessárias na pasta de mídia. e vou explicar-lhe porquê.

1) suas permissões atuais na pasta, como você mencionou, são as seguintes. (Peça desculpas se você sabe disso e eu estou incomodando você com isso.)

drwxr-xr-x 14 root root 4096 Jan 13 19:37 media neste d significa diretório, primeiro grupo de rwx representa os direitos do usuário que possui esse objeto, que está no seu caso root.

segundo grupo de rwx representa os direitos do grupo que possui esse objeto & aqui você tem apenas r-x, o que significa que mesmo se você estiver no arquivo sudoers ou no grupo admin, você não tem direitos para escrever nele.

O terceiro grupo de rwx é ou outros usuários, que não são proprietários desse objeto nem do grupo que possui direitos de propriedade desse objeto. se o seu caso é novamente r-x apenas. então é por isso que você não tem permissões de gravação.

2) Então você precisa alterar as permissões da pasta de mídia. (Eu vou considerar que você está no arquivo de grupo admin ou sudoers, porque isso funcionará apenas nesse caso). então é isso que você precisa fazer.

$ sudo chmod -R 775 /media

3) Isso lhe dará permissões de gravação obrigatórias nas unidades montadas automaticamente.

Por favor, verifique e deixe-me saber se isso não funciona dirá o que mais pode ser feito para corrigir esse problema.

    
por Hrish 05.02.2013 / 21:06