Não é possível obter drivers nVidia trabalhando com 16.04, efetua logout logo após o login

31

Instalei o Ubuntu 16.04 beta 2 na segunda-feira, 18 de abril. Quando tento instalar o nvidia-current, o nvidia-361 ou a versão que o jockey instala, o lightdm não inicia completamente ou não consigo passar da janela de login. Quando eu me logar, o lightdm.log informa que eu fiz o login com sucesso, por alguns motivos ele mostra o volume do som que eu configurei e depois retorna para a tela de login.

Eu tenho um laptop com placa gráfica nVidia / Intel híbrida com a tecnologia Optimus (não preciso de comutação de GPU, mas quero que a nVidia funcione corretamente), o modelo exato da nVidia é o GT630M.

Aqui está o Xorg.0.log:

[    41.529] 
X.Org X Server 1.18.3
Release Date: 2016-04-04
[    41.529] X Protocol Version 11, Revision 0
[    41.529] Build Operating System: Linux 3.13.0-85-generic x86_64 Ubuntu
[    41.529] Current Operating System: Linux dugi 4.4.0-21-generic #37-Ubuntu SMP Mon Apr 18 18:33:37 UTC 2016 x86_64
[    41.529] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic root=UUID=77b76089-cd8b-4d0c-b074-1ec581c0a8a9 ro quiet splash
[    41.529] Build Date: 07 April 2016  09:18:50AM
[    41.529] xorg-server 2:1.18.3-1ubuntu2 (For technical support please see http://www.ubuntu.com/support) 
[    41.529] Current version of pixman: 0.33.6
[    41.529]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[    41.529] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    41.529] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Apr 22 00:40:13 2016
[    41.530] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    41.530] (==) No Layout section.  Using the first Screen section.
[    41.530] (==) No screen section available. Using defaults.
[    41.530] (**) |-->Screen "Default Screen Section" (0)
[    41.530] (**) |   |-->Monitor "<default monitor>"
[    41.530] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[    41.530] (==) Automatically adding devices
[    41.530] (==) Automatically enabling devices
[    41.530] (==) Automatically adding GPU devices
[    41.530] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    41.530] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    41.530]    Entry deleted from font path.
[    41.530] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    41.530]    Entry deleted from font path.
[    41.530] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    41.530]    Entry deleted from font path.
[    41.530] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    41.530]    Entry deleted from font path.
[    41.530] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    41.530]    Entry deleted from font path.
[    41.530] (==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/Type1,
    built-ins
[    41.530] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[    41.530] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[    41.530] (II) Loader magic: 0x55a83676cda0
[    41.530] (II) Module ABI versions:
[    41.530]    X.Org ANSI C Emulation: 0.4
[    41.530]    X.Org Video Driver: 20.0
[    41.530]    X.Org XInput driver : 22.1
[    41.530]    X.Org Server Extension : 9.0
[    41.530] (++) using VT number 7

[    41.530] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    41.531] (II) xfree86: Adding drm device (/dev/dri/card0)
[    41.532] (--) PCI:*(0:0:2:0) 8086:0166:1028:0590 rev 9, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[    41.532] (WW) "glamoregl" will not be loaded unless you've specified it to be loaded elsewhere.
[    41.532] (II) "glx" will be loaded by default.
[    41.532] (II) LoadModule: "glx"
[    41.532] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so
[    41.537] (II) Module glx: vendor="NVIDIA Corporation"
[    41.537]    compiled for 4.0.2, module version = 1.0.0
[    41.537]    Module class: X.Org Server Extension
[    41.537] (II) NVIDIA GLX Module  304.131  Sun Nov  8 22:03:20 PST 2015
[    41.537] (==) Matched intel as autoconfigured driver 0
[    41.537] (==) Matched intel as autoconfigured driver 1
[    41.537] (==) Matched modesetting as autoconfigured driver 2
[    41.537] (==) Matched fbdev as autoconfigured driver 3
[    41.537] (==) Matched vesa as autoconfigured driver 4
[    41.537] (==) Assigned the driver to the xf86ConfigLayout
[    41.537] (II) LoadModule: "intel"
[    41.537] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    41.537] (II) Module intel: vendor="X.Org Foundation"
[    41.537]    compiled for 1.18.1, module version = 2.99.917
[    41.537]    Module class: X.Org Video Driver
[    41.537]    ABI class: X.Org Video Driver, version 20.0
[    41.537] (II) LoadModule: "modesetting"
[    41.537] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    41.537] (II) Module modesetting: vendor="X.Org Foundation"
[    41.537]    compiled for 1.18.3, module version = 1.18.3
[    41.537]    Module class: X.Org Video Driver
[    41.537]    ABI class: X.Org Video Driver, version 20.0
[    41.537] (II) LoadModule: "fbdev"
[    41.538] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    41.538] (II) Module fbdev: vendor="X.Org Foundation"
[    41.538]    compiled for 1.18.1, module version = 0.4.4
[    41.538]    Module class: X.Org Video Driver
[    41.538]    ABI class: X.Org Video Driver, version 20.0
[    41.538] (II) LoadModule: "vesa"
[    41.538] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    41.538] (II) Module vesa: vendor="X.Org Foundation"
[    41.538]    compiled for 1.18.1, module version = 2.3.4
[    41.538]    Module class: X.Org Video Driver
[    41.538]    ABI class: X.Org Video Driver, version 20.0
[    41.538] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
    i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
    915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
    Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
    GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[    41.538] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[    41.538] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[    41.538] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[    41.538] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    41.538] (II) FBDEV: driver for framebuffer: fbdev
[    41.538] (II) VESA: driver for VESA chipsets: vesa
[    41.538] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20151010
[    41.538] (II) intel(0): SNA compiled: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1 (Timo Aaltonen <[email protected]>)
[    41.538] (II) intel(0): SNA compiled for use with valgrind
[    41.538] (WW) Falling back to old probe method for modesetting
[    41.538] (WW) Falling back to old probe method for fbdev
[    41.538] (II) Loading sub module "fbdevhw"
[    41.538] (II) LoadModule: "fbdevhw"
[    41.538] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    41.538] (II) Module fbdevhw: vendor="X.Org Foundation"
[    41.538]    compiled for 1.18.3, module version = 0.0.2
[    41.538]    ABI class: X.Org Video Driver, version 20.0
[    41.538] (WW) Falling back to old probe method for vesa
[    41.539] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 4000
[    41.539] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx; using a maximum of 2 threads
[    41.539] (II) intel(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
[    41.539] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[    41.539] (==) intel(0): RGB weight 888
[    41.539] (==) intel(0): Default visual is TrueColor
[    41.539] (II) intel(0): Output LVDS1 has no monitor section
[    41.552] (--) intel(0): Found backlight control interface intel_backlight (type 'raw') for output LVDS1
[    41.552] (II) intel(0): Enabled output LVDS1
[    41.552] (II) intel(0): Output VGA1 has no monitor section
[    41.552] (II) intel(0): Enabled output VGA1
[    41.552] (II) intel(0): Output HDMI1 has no monitor section
[    41.552] (II) intel(0): Enabled output HDMI1
[    41.552] (II) intel(0): Output DP1 has no monitor section
[    41.552] (II) intel(0): Enabled output DP1
[    41.552] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[    41.552] (II) intel(0): Output VIRTUAL1 has no monitor section
[    41.552] (II) intel(0): Enabled output VIRTUAL1
[    41.552] (--) intel(0): Output LVDS1 using initial mode 1366x768 on pipe 0
[    41.552] (==) intel(0): TearFree disabled
[    41.552] (==) intel(0): DPI set to (96, 96)
[    41.552] (II) Loading sub module "dri2"
[    41.552] (II) LoadModule: "dri2"
[    41.552] (II) Module "dri2" already built-in
[    41.552] (II) Loading sub module "present"
[    41.552] (II) LoadModule: "present"
[    41.552] (II) Module "present" already built-in
[    41.552] (II) UnloadModule: "modesetting"
[    41.552] (II) Unloading modesetting
[    41.552] (II) UnloadModule: "fbdev"
[    41.552] (II) Unloading fbdev
[    41.553] (II) UnloadSubModule: "fbdevhw"
[    41.553] (II) Unloading fbdevhw
[    41.553] (II) UnloadModule: "vesa"
[    41.553] (II) Unloading vesa
[    41.553] (==) Depth 24 pixmap format is 32 bpp
[    41.553] (II) intel(0): SNA initialized with Ivybridge (gen7, gt2) backend
[    41.553] (==) intel(0): Backing store enabled
[    41.553] (==) intel(0): Silken mouse enabled
[    41.553] (II) intel(0): HW Cursor enabled
[    41.553] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[    41.553] (==) intel(0): DPMS enabled
[    41.553] (==) intel(0): Display hotplug detection enabled
[    41.553] (II) intel(0): [DRI2] Setup complete
[    41.553] (II) intel(0): [DRI2]   DRI driver: i965
[    41.553] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[    41.553] (II) intel(0): direct rendering: DRI2 enabled
[    41.553] (II) intel(0): hardware support for Present enabled
[    41.553] (--) RandR disabled
[    41.556] (II) SELinux: Disabled on system
[    41.557] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
[    41.558] (II) intel(0): switch to mode [email protected] on LVDS1 using pipe 0, position (0, 0), rotation normal, reflection none
[    41.558] (II) intel(0): Setting screen physical size to 361 x 203
[    41.582] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[    41.582] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    41.582] (II) LoadModule: "evdev"
[    41.582] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    41.582] (II) Module evdev: vendor="X.Org Foundation"
[    41.582]    compiled for 1.18.1, module version = 2.10.1
[    41.582]    Module class: X.Org XInput Driver
[    41.582]    ABI class: X.Org XInput driver, version 22.1
[    41.582] (II) Using input driver 'evdev' for 'Power Button'
[    41.582] (**) Power Button: always reports core events
[    41.582] (**) evdev: Power Button: Device: "/dev/input/event3"
[    41.582] (--) evdev: Power Button: Vendor 0 Product 0x1
[    41.583] (--) evdev: Power Button: Found keys
[    41.583] (II) evdev: Power Button: Configuring as keyboard
[    41.583] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input3/event3"
[    41.583] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    41.583] (**) Option "xkb_rules" "evdev"
[    41.583] (**) Option "xkb_model" "pc105"
[    41.583] (**) Option "xkb_layout" "sk"
[    41.583] (**) Option "xkb_variant" "qwerty"
[    41.596] (II) config/udev: Adding input device Video Bus (/dev/input/event6)
[    41.596] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[    41.596] (II) Using input driver 'evdev' for 'Video Bus'
[    41.596] (**) Video Bus: always reports core events
[    41.596] (**) evdev: Video Bus: Device: "/dev/input/event6"
[    41.596] (--) evdev: Video Bus: Vendor 0 Product 0x6
[    41.596] (--) evdev: Video Bus: Found keys
[    41.596] (II) evdev: Video Bus: Configuring as keyboard
[    41.596] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:01/input/input8/event6"
[    41.596] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[    41.596] (**) Option "xkb_rules" "evdev"
[    41.596] (**) Option "xkb_model" "pc105"
[    41.596] (**) Option "xkb_layout" "sk"
[    41.596] (**) Option "xkb_variant" "qwerty"
[    41.596] (II) config/udev: Adding input device Video Bus (/dev/input/event5)
[    41.596] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[    41.596] (II) Using input driver 'evdev' for 'Video Bus'
[    41.596] (**) Video Bus: always reports core events
[    41.596] (**) evdev: Video Bus: Device: "/dev/input/event5"
[    41.596] (--) evdev: Video Bus: Vendor 0 Product 0x6
[    41.596] (--) evdev: Video Bus: Found keys
[    41.596] (II) evdev: Video Bus: Configuring as keyboard
[    41.596] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:19/LNXVIDEO:00/input/input7/event5"
[    41.596] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 8)
[    41.596] (**) Option "xkb_rules" "evdev"
[    41.596] (**) Option "xkb_model" "pc105"
[    41.596] (**) Option "xkb_layout" "sk"
[    41.596] (**) Option "xkb_variant" "qwerty"
[    41.597] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[    41.597] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    41.597] (II) Using input driver 'evdev' for 'Power Button'
[    41.597] (**) Power Button: always reports core events
[    41.597] (**) evdev: Power Button: Device: "/dev/input/event1"
[    41.597] (--) evdev: Power Button: Vendor 0 Product 0x1
[    41.597] (--) evdev: Power Button: Found keys
[    41.597] (II) evdev: Power Button: Configuring as keyboard
[    41.597] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input1/event1"
[    41.597] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 9)
[    41.597] (**) Option "xkb_rules" "evdev"
[    41.597] (**) Option "xkb_model" "pc105"
[    41.597] (**) Option "xkb_layout" "sk"
[    41.597] (**) Option "xkb_variant" "qwerty"
[    41.597] (II) config/udev: Adding input device Lid Switch (/dev/input/event0)
[    41.597] (II) No input driver specified, ignoring this device.
[    41.597] (II) This device may have been added with another device file.
[    41.598] (II) config/udev: Adding input device Sleep Button (/dev/input/event2)
[    41.598] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[    41.598] (II) Using input driver 'evdev' for 'Sleep Button'
[    41.598] (**) Sleep Button: always reports core events
[    41.598] (**) evdev: Sleep Button: Device: "/dev/input/event2"
[    41.598] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[    41.598] (--) evdev: Sleep Button: Found keys
[    41.598] (II) evdev: Sleep Button: Configuring as keyboard
[    41.598] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input2/event2"
[    41.598] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 10)
[    41.598] (**) Option "xkb_rules" "evdev"
[    41.598] (**) Option "xkb_model" "pc105"
[    41.598] (**) Option "xkb_layout" "sk"
[    41.598] (**) Option "xkb_variant" "qwerty"
[    41.598] (II) config/udev: Adding input device HID 04d9:1133 (/dev/input/event7)
[    41.598] (**) HID 04d9:1133: Applying InputClass "evdev pointer catchall"
[    41.598] (II) Using input driver 'evdev' for 'HID 04d9:1133'
[    41.598] (**) HID 04d9:1133: always reports core events
[    41.598] (**) evdev: HID 04d9:1133: Device: "/dev/input/event7"
[    41.652] (--) evdev: HID 04d9:1133: Vendor 0x4d9 Product 0x1133
[    41.652] (--) evdev: HID 04d9:1133: Found 3 mouse buttons
[    41.652] (--) evdev: HID 04d9:1133: Found scroll wheel(s)
[    41.652] (--) evdev: HID 04d9:1133: Found relative axes
[    41.652] (--) evdev: HID 04d9:1133: Found x and y relative axes
[    41.652] (II) evdev: HID 04d9:1133: Configuring as mouse
[    41.652] (II) evdev: HID 04d9:1133: Adding scrollwheel support
[    41.652] (**) evdev: HID 04d9:1133: YAxisMapping: buttons 4 and 5
[    41.652] (**) evdev: HID 04d9:1133: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    41.652] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2:1.0/0003:04D9:1133.0001/input/input9/event7"
[    41.652] (II) XINPUT: Adding extended input device "HID 04d9:1133" (type: MOUSE, id 11)
[    41.652] (II) evdev: HID 04d9:1133: initialized for relative axes.
[    41.652] (**) HID 04d9:1133: (accel) keeping acceleration scheme 1
[    41.652] (**) HID 04d9:1133: (accel) acceleration profile 0
[    41.652] (**) HID 04d9:1133: (accel) acceleration factor: 2.000
[    41.652] (**) HID 04d9:1133: (accel) acceleration threshold: 4
[    41.653] (II) config/udev: Adding input device HID 04d9:1133 (/dev/input/mouse0)
[    41.653] (II) No input driver specified, ignoring this device.
[    41.653] (II) This device may have been added with another device file.
[    41.653] (II) config/udev: Adding input device Laptop_Integrated_Webcam_HD (/dev/input/event10)
[    41.653] (**) Laptop_Integrated_Webcam_HD: Applying InputClass "evdev keyboard catchall"
[    41.653] (II) Using input driver 'evdev' for 'Laptop_Integrated_Webcam_HD'
[    41.653] (**) Laptop_Integrated_Webcam_HD: always reports core events
[    41.653] (**) evdev: Laptop_Integrated_Webcam_HD: Device: "/dev/input/event10"
[    41.653] (--) evdev: Laptop_Integrated_Webcam_HD: Vendor 0x1bcf Product 0x2982
[    41.653] (--) evdev: Laptop_Integrated_Webcam_HD: Found keys
[    41.653] (II) evdev: Laptop_Integrated_Webcam_HD: Configuring as keyboard
[    41.653] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.5/1-1.5:1.0/input/input12/event10"
[    41.653] (II) XINPUT: Adding extended input device "Laptop_Integrated_Webcam_HD" (type: KEYBOARD, id 12)
[    41.653] (**) Option "xkb_rules" "evdev"
[    41.653] (**) Option "xkb_model" "pc105"
[    41.653] (**) Option "xkb_layout" "sk"
[    41.653] (**) Option "xkb_variant" "qwerty"
[    41.653] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event12)
[    41.653] (II) No input driver specified, ignoring this device.
[    41.653] (II) This device may have been added with another device file.
[    41.654] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event13)
[    41.654] (II) No input driver specified, ignoring this device.
[    41.654] (II) This device may have been added with another device file.
[    41.654] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=3 (/dev/input/event14)
[    41.654] (II) No input driver specified, ignoring this device.
[    41.654] (II) This device may have been added with another device file.
[    41.654] (II) config/udev: Adding input device Atmel Atmel maXTouch Digitizer (/dev/input/event9)
[    41.654] (**) Atmel Atmel maXTouch Digitizer: Applying InputClass "evdev touchscreen catchall"
[    41.654] (II) Using input driver 'evdev' for 'Atmel Atmel maXTouch Digitizer'
[    41.654] (**) Atmel Atmel maXTouch Digitizer: always reports core events
[    41.654] (**) evdev: Atmel Atmel maXTouch Digitizer: Device: "/dev/input/event9"
[    41.709] (--) evdev: Atmel Atmel maXTouch Digitizer: Vendor 0x3eb Product 0x8803
[    41.709] (--) evdev: Atmel Atmel maXTouch Digitizer: Found absolute axes
[    41.709] (--) evdev: Atmel Atmel maXTouch Digitizer: Found absolute multitouch axes
[    41.709] (II) evdev: Atmel Atmel maXTouch Digitizer: No buttons found, faking one.
[    41.709] (--) evdev: Atmel Atmel maXTouch Digitizer: Found x and y absolute axes
[    41.709] (--) evdev: Atmel Atmel maXTouch Digitizer: Found absolute touchscreen
[    41.709] (II) evdev: Atmel Atmel maXTouch Digitizer: Configuring as touchscreen
[    41.709] (**) evdev: Atmel Atmel maXTouch Digitizer: YAxisMapping: buttons 4 and 5
[    41.709] (**) evdev: Atmel Atmel maXTouch Digitizer: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    41.709] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.5/2-1.5:1.0/0003:03EB:8803.0002/input/input10/event9"
[    41.709] (II) XINPUT: Adding extended input device "Atmel Atmel maXTouch Digitizer" (type: TOUCHSCREEN, id 13)
[    41.709] (II) evdev: Atmel Atmel maXTouch Digitizer: initialized for absolute axes.
[    41.709] (**) Atmel Atmel maXTouch Digitizer: (accel) keeping acceleration scheme 1
[    41.709] (**) Atmel Atmel maXTouch Digitizer: (accel) acceleration profile 0
[    41.709] (**) Atmel Atmel maXTouch Digitizer: (accel) acceleration factor: 2.000
[    41.709] (**) Atmel Atmel maXTouch Digitizer: (accel) acceleration threshold: 4
[    41.710] (II) config/udev: Adding input device Atmel Atmel maXTouch Digitizer (/dev/input/mouse2)
[    41.710] (II) No input driver specified, ignoring this device.
[    41.710] (II) This device may have been added with another device file.
[    41.710] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event4)
[    41.710] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    41.710] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[    41.710] (**) AT Translated Set 2 keyboard: always reports core events
[    41.710] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event4"
[    41.710] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[    41.710] (--) evdev: AT Translated Set 2 keyboard: Found keys
[    41.710] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[    41.710] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input4/event4"
[    41.710] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 14)
[    41.710] (**) Option "xkb_rules" "evdev"
[    41.710] (**) Option "xkb_model" "pc105"
[    41.710] (**) Option "xkb_layout" "sk"
[    41.710] (**) Option "xkb_variant" "qwerty"
[    41.710] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event8)
###/// A load of unrelated stuff about touchpad ///###
[    41.794] (**) Option "config_info" "udev:/sys/devices/virtual/input/input13/event11"
[    41.794] (II) XINPUT: Adding extended input device "Dell WMI hotkeys" (type: KEYBOARD, id 16)
[    41.794] (**) Option "xkb_rules" "evdev"
[    41.794] (**) Option "xkb_model" "pc105"
[    41.794] (**) Option "xkb_layout" "sk"
[    41.794] (**) Option "xkb_variant" "qwerty"
[    42.345] (II) intel(0): EDID vendor "CMN", prod id 5558
[    42.345] (II) intel(0): Printing DDC gathered Modelines:
[    42.345] (II) intel(0): Modeline "1366x768"x0.0   76.66  1366 1397 1462 1592  768 772 784 802 +hsync -vsync (48.2 kHz eP)
[    42.345] (II) intel(0): Modeline "1366x768"x0.0   51.01  1366 1380 1409 1592  768 770 777 800 +hsync -vsync (32.0 kHz e)

Este é o xorg.conf.XXXXXXXX em uso:

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:[email protected]:2:0"
    Option "AccelMethod" "None"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:[email protected]:0:0"
    Option "ConstrainCursor" "off"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
    Option "IgnoreDisplayDevices" "CRT"
EndSection

Por enquanto, estou preso a novos / intel, o que às vezes é bastante limitante. Alguma ideia do que pode estar acontecendo? Talvez o arquivo /etc/X11/xorg.conf que está faltando possa ser o problema, mas eu não sei porque não está lá.

Nota: A partir do lançamento principal do 16.04, o erro foi alterado de nenhum dispositivo detectado e nenhuma tela encontrada para Falha ao inicializar a extensão GLX (driver compatível com NVIDIA X não encontrado ) . Agora, o lightdm começa mais fácil, mas ainda não consigo passar da tela de login.

Editar mais: Eu tive boot seguro desativado o tempo todo. Eu instalei o bumblebee que adicionou o driver nvidia (tentei 304 e 340), mas ele não conseguiu iniciar programas usando a placa de vídeo nVidia. Uma investigação mais aprofundada mostrou que o modprobe para nvidia estava falhando devido a algo como isto:

could not insert 'nvidia': Unknown symbol in module, or unknown parameter (see dmesg)

Eu tentei uma versão posterior do driver (361), mas ela continuou falhando. Eu li em algum lugar que os drivers i915 estavam causando esse problema, mas eu não os instalei.

Mais informações: Esta parece ser a causa raiz. Com o driver da nVidia instalado junto com seu módulo DKMS, não consegui inseri-lo no kernel (usando o modprobe). O erro relatado foi que não é possível encontrar uma porta PCI específica (aquela em que deveria estar de acordo com o lspci). Eu não salvei as palavras exatas, desculpe por isso.

    
por Dugi 20.04.2016 / 21:00

6 respostas

11

Graças ao esforço coletivo da comunidade, consegui que funcionasse.

Primeiro, vá para um Terminal (pressionando ctrl - alt - f1 se não puder efetuar login, ou através do modo de recuperação ). Instale os drivers nVidia versão 364 (pacote nvidia-364).

sudo apt-get install nvidia-364

Se o pacote não for encontrado, adicione o ppa que o contém:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update

Reinicie o seu computador.

sudo reboot -i NOW

Se você não for devolvido à tela de login, mas conseguir ver apenas o plano de fundo, force-o a recriar as configurações do usuário (salvando um backup):

sudo mv ~/.config/dconf/user ~/.config/dconf/user.old

Em seguida, reinicie o lightdm:

sudo service lightdm restart

Se você deseja instalar o bumblebee, esteja ciente de que sua configuração será mal definida e ele procurará por nvidia-current mesmo que o nvidia-current não esteja instalado. Eu o editei para me referir a nvidia-364 (porque os arquivos instalados estão em / usr / lib / nvidia-364) e consegui iniciar programas com optirun.

    
por Dugi 24.04.2016 / 11:47
7

Eu tive alguns problemas com a Nvidia e 16.04 - finalmente consegui trabalhar. em um nvidia gtx980m (laptop de jogos Asus G752) - Eu sugiro certificar-se de tentar instalar a partir da linha de comando, e não simplesmente permitindo que os drivers proprietários do gui ... (leia mais)

Eu não estou recebendo o loop de inicialização descrito, mas eu estava recebendo baixa resolução (800x600) e não funcionaria de todo - mas o nouveau estava bem. (tudo através dos drivers gui)

Eu finalmente cai na linha de comando e instalei o mesmo pacote via "sudo apt-get install nvidia-xxx (no meu caso foi 361 - também tentei 352)

ele foi instalado como normal, mas um menu apareceu no terminal dizendo que a inicialização segura "UEFI" estava ativada e você teria que inserir uma senha para desativá-la na reinicialização "para inicializar em modo inseguro. Então Eu fiz isso.

Uma vez que isso foi feito, na reinicialização - com certeza um menu de janela UEFI apareceu e eu escolhi mudar o modo de inicialização para inseguro. Em seguida, ele me perguntou vários caracteres "por posição" (EG ... digite no personagem 6, em seguida, digite o caractere 4, etc), seguido por entrar cada vez. Eventualmente, após 3-4 caracteres, permitiu-me desligar a inicialização segura. Então a máquina reinicializou novamente, e disse "modo inseguro de inicialização" e os motoristas trabalharam então.

Também foi descoberto na instalação do virtualbox via synaptic, mas pelo menos funcionou e apareceu um menu usando esse método ....

espero que ajude ...

    
por biff 22.04.2016 / 09:37
4

Como faço para recuperar meu desktop?

Pressionando ctrl - alt - f1 da tela de login, você pode ir para uma linha de comando. Entre usando seu nome de usuário e senha. A partir desta linha de comando, você pode desinstalar os drivers nvidia executando os seguintes comandos:

sudo apt remove nvidia-361
sudo apt autoremove

Note que a versão específica da nvidia pode ser diferente. Você pode descobrir a versão do driver nvidia instalado executando apt search nvidia | grep installed | grep nvidia

ou se você quiser apenas mudar para a placa gráfica Intel sem remover o driver nvidia, execute

prime-select intel

Mas eu quero usar meu cartão nvidia!

Existem algumas opções que você pode experimentar:

Desativar inicialização segura

Como @biff disse, o Secure Boot pode bloquear o carregamento do driver da nvidia. Para desativar a inicialização segura, instale o driver nvidia usando a linha de comando . O Ubuntu solicitará que você desative a inicialização segura durante a instalação.

Instale o driver nvidia mais antigo

Alguns problemas podem ser corrigidos instalando o driver nvidia mais antigo.

    
por Galgalesh 24.04.2016 / 02:31
0

Eu tenho o mesmo problema. Executando o Ubuntu 16.04. Intel HD4600 e Nvidia 765M. Tentei todas as sugestões acima. Funcionou ao instalar usando o terminal, mas se eu usar vários monitores, ele se desativa e acabo em um loop de inicialização.

Li alguém sugerindo que o driver beta 364xx funciona.

    
por Ricardo 22.04.2016 / 14:20
0

No meu caso, apenas instalar a nvidia-364 resolveu o problema. Minha configuração é NVidia GTX 750Ti em ASUS H170 + Intel i7 6700 + 32GB DDR4 rodando Ubuntu 16.04.

    
por sudar 13.05.2016 / 14:36
0

Eu tenho uma GTX980 e não consegui fazer o login após a atualização para 16.04 (a partir de 15.10). Remova o nvidia:

sudo apt-get purge nvidia*

e logado. Funcionou, mas a resolução foi limitada a 800x600.

As seguintes etapas resolveram meu problema:

  1. Reinstalar a nvidia: sudo apt-get install nvidia-361
  2. Reinicie, vá para o BIOS e desabilite o Secure Boot

Obrigado biff pela dica para desativar a inicialização segura: -)

    
por ampersand 8 22.04.2016 / 14:16