Configuração para acesso público (externo) ao convidado ubuntu no ESXI 5

4

Estou configurando um sistema de demonstração em um servidor dedicado concedido. O sistema consiste em:

  • Host ESXI com 1 NIC atribuído (portanto, 1 IP estático)
  • convidado do Ubuntu de 64 bits como servidor

Eu instalei e configurei o sistema e a topologia de rede atual possui:

  • adaptador físico
  • Uma rede de gerenciamento na qual vejo o IP público atribuído que me é dado pelo provedor de servidor dedicado
  • Grupo de portas da máquina virtual em que meu convidado está sendo executado
  • Finalmente, um vSwitch entre o adaptador físico e as redes mencionadas acima

Eu posso acessar o host ESXI, do cliente vSphere também posso acessar meu convidado do Ubuntu. O convidado tem acesso à web (verificado por ping).

Minha pergunta: Que tipo de configuração básica permitiria que usuários externos acessassem serviços em execução no guest do Ubuntu?

Antes de fazer esta pergunta, eu naveguei um pouco e fiz a varredura das documentações do VMWare. Eu vi:

encaminhamento de porta via roteador Eu não tenho controle sobre o roteador.

usando o pfSense bem, este está parecendo uma solução, mas um pouco mais complicado do que eu esperava.

Existem maneiras mais simples de atingir meu objetivo?

Nota: Eu sou um desenvolvedor de software com um pouco de familiaridade de redes de computadores, virtualização e linux. Portanto, eu realmente aprecio soluções simples (se possível), explicações / instruções sobre o tema.

    
por Ozgun Alan 21.01.2013 / 10:26

1 resposta

0

vSwitches

É factível, mas a má notícia é que os vSwitches até hoje ainda não suportam NAT. Portanto, é necessário algum tipo de configuração como o pfSense VM como um front-end de roteamento.

pfSense Alternativa

Por outro lado, o pfSense não é a única opção, você pode usar uma VM simples do Linux (por exemplo, servidor Ubuntu) com o iptables para fazer o trabalho.

IP adicional - modo mais simples

Outra opção é obter IP adicional e configurar a VM para usar o modo de ponte, que é o mais fácil. Mas pode (muito provavelmente) vir com custo adicional.

    
por 23.01.2013 / 21:31
yii\base\ErrorException
Copied! Copy Stacktrace Search Stackoverflow Search Google Error

PHP Core Warning – yii\base\ErrorException

PHP Startup: Unable to load dynamic library 'memcached.so' (tried: /usr/lib/php/20190902/memcached.so (/usr/lib/php/20190902/memcached.so: undefined symbol: igbinary_serialize), /usr/lib/php/20190902/memcached.so.so (/usr/lib/php/20190902/memcached.so.so: cannot open shared object file: No such file or directory))

$_GET = [
    'id' => '328423',
    'url' => 'configuration-for-public-external-access-to-ubuntu-guest-on-esxi-5',
];

$_COOKIE = [
    'advanced-frontend' => 'ert365d83qnrlmdm8mtds1u3nv',
    '_csrf-frontend' => 'c612cb4e867f02fad91f6f9f8c0bea06acf08d12557b433a0cf8cdfa211a267fa:2:{i:0;s:14:"_csrf-frontend";i:1;s:32:"1hU5EJfvfupTq458zc9z_jH3zNN0vYxZ";}',
];

$_SESSION = [
    '__flash' => [],
];