Configure o roteamento através de vlans + roteamento estático

1

Eu tenho problema para configurar minha rede. Entre switches eu criei vlans: 5,6,9 e 10. Vlan 9 é a vlan nativa. PC1 está na vlan 5 e PC0 está na vlan 6. Eu configurei R1 que é possível se comunicar através de diferentes vlans (o ping do PC0 para o PC1 funciona bem). Agora eu quero pingar a interface R3 se0 / 2 do PC1, mas não tenho resposta. Aqui estão meus arquivos de configuração:

INTERRUPTOR S1:

Current configuration : 942 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S1
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet1/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet2/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet3/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet4/1
!
interface FastEthernet5/1
!
interface FastEthernet6/1
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet7/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet8/1
!
interface FastEthernet9/1
 switchport trunk native vlan 99
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

INTERRUPTOR S2:

Current configuration : 830 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S2
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet1/1
!
interface FastEthernet2/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet3/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet4/1
!
interface FastEthernet5/1
!
interface FastEthernet6/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet7/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet8/1
 switchport access vlan 6
 switchport mode access
!
interface FastEthernet9/1
!
interface Vlan1
 no ip address
 shutdown
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

SWITCH S3:

Current configuration : 830 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S3
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet1/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet2/1
!
interface FastEthernet3/1
!
interface FastEthernet4/1
!
interface FastEthernet5/1
!
interface FastEthernet6/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet7/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet8/1
 switchport access vlan 5
 switchport mode access
!
interface FastEthernet9/1
!
interface Vlan1
 no ip address
 shutdown
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

ROUTER R1 :

Current configuration : 1039 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.5
 encapsulation dot1Q 5
 ip address 192.168.5.1 255.255.255.0
!
interface FastEthernet0/0.6
 encapsulation dot1Q 6
 ip address 192.168.6.1 255.255.255.0
!
interface FastEthernet0/0.9
 encapsulation dot1Q 9
 ip address 192.168.9.1 255.255.255.0
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.10.2 
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

ROUTER R2 :

Current configuration : 649 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.10.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 172.16.1.2 255.255.255.0
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

ROUTER R3 :

Current configuration : 690 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 172.16.1.1 255.255.255.0
 clock rate 64000
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.1.2 
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

TABELAS DE ROUTIGOS, R1:

R1#sh ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.10.2 to network 0.0.0.0

C    192.168.5.0/24 is directly connected, FastEthernet0/0.5
C    192.168.6.0/24 is directly connected, FastEthernet0/0.6
C    192.168.9.0/24 is directly connected, FastEthernet0/0.9
C    192.168.10.0/24 is directly connected, FastEthernet0/0.10
S*   0.0.0.0/0 [1/0] via 192.168.10.2

ROUTIG TABLES, R2:

R2#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Serial2/0
C    192.168.10.0/24 is directly connected, FastEthernet0/0

ROUTIG TABLES, R3:

R3#sh ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.16.1.2 to network 0.0.0.0

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Serial2/0
S*   0.0.0.0/0 [1/0] via 172.16.1.2

Minha topologia: link

Como posso alterar minha configuração de rede para fazer ping de PC0 / PC1 para 172.16.1.2 ou 172.16.1.1?

    
por Brian Brown 13.01.2013 / 14:25

1 resposta

1

Não posso adicionar comentários, mas, até onde eu sei, você não tem rota de PC0 / PC1 para alcançar R3.

Você pode alcançar de PC0 a PC1 porque eles estão um pouco conectados na mesma rede, mesmo que em VLANs diferentes. Você precisará construir uma tabela de roteamento em toda a sua rede para que seus PCs possam alcançar o R2 / R3.

A rota básica que você precisa adicionar está apontando 172.16.1.0/24 para o endereço IP interno de R2.

    
por 13.01.2013 / 16:12