Após a reinicialização, preciso logar todas as vezes no Chrome

23

Se eu reiniciar o Ubuntu, eu preciso fazer logon em cada site e na conta do Google Chrome. Qual é a razão? Meu sistema é Ubuntu 16.04 e Google Chrome 53.0.2785.101 (64 bits).

    
por Novah 09.09.2016 / 07:28
fonte

6 respostas

15

Tive o mesmo problema. Meu sistema é Ubuntu 16.04 e Google Chrome 53.0.2785.101 (64 bits).

Aqui está minha solução alternativa:

  1. Ir para configurações do sistema do Ubuntu - > Contas on-line
  2. adicione sua conta do Google lá
  3. ativado o alternador (não tenho certeza se é necessário)
  4. acesse o navegador Google Chrome e faça login novamente
  5. feche a janela do navegador

Nota : você deve evitar que processos cromo sejam executados depois de fechar a janela. Para fazer isso, acesse as configurações do Chrome > Configurações avançadas (na parte inferior) > Desmarque a opção "Continuar executando aplicativos em segundo plano quando o Google Chrome está fechado"

Depois que fiz isso, o Chrome parou de desativar a autenticação depois de fazer logout no Ubuntu e também depois de reinicializar

    
por Igor Bukin 11.09.2016 / 23:34
fonte
5

Você precisa ativar esse recurso em Privacy configurações. Você pode chegar lá seguindo as configurações do Chrome:

Ative a gravação de senhas

  1. Clique no ícone do menu do Chrome (os três pontos no canto superior direito).
  2. Clique em Configurações
  3. Clique em Mostrar configurações avançadas (novo na parte inferior da página)
  4. (Em Privacidade - Senhas e formulários ) Coloque marcas de verificação sob o seguinte:
    • Ativar preenchimento automático para preencher formulários da web
    • Oferta Salve suas senhas da web

As senhas podem ser salvas mesmo com cookies desativados. Você ainda pode verificar suas configurações de cookie com as etapas abaixo.

Ativar ou desativar cookies

  1. Clique no ícone do menu do Chrome
  2. Clique em Configurações
  3. Clique em Mostrar configurações avançadas
  4. Na seção Privacidade, selecione Configurações de conteúdo
  5. Selecione Permitir que os dados locais sejam definidos

Se todas as configurações estiverem definidas para salvar senhas e elas ainda falharem, verifique a integridade da configuração do Chrome, traga-a para os padrões com as etapas a seguir.

Primeira saída do Chrome. Em seguida, execute esses comandos para remover temporariamente as configurações atuais.

$ cd ~/.config
$ mv google-chrome google-chrome.bak

Você pode recuperar as configurações anteriores renomeando google-chrome.bak para original.

O problema foi resolvido conforme detalhado na seção de comentários do bate-papo , renomeando o diretório inicial para um backup nome, criando um novo diretório inicial onde o Google Chrome funcionava. Em seguida, o diretório de backup foi migrado para o novo espaço.

    
por L. D. James 09.09.2016 / 08:47
fonte
2

Solução alternativa

Se a resposta acima não resolver o problema, a instalação da versão beta do Google Chrome poderá solucionar o problema.

apt install google-chrome-beta  

Isso parece não para resolvê-lo (entrada preservada por razões históricas):

Eu tenho o mesmo problema e depurei algumas horas de depuração.

O meu problema está apenas relacionado com google-chrome-stable Versão 53.0.2785.101 (64-bit) no Ubuntu 16.04.

Quando eu faço login em um site, os cookies são definidos corretamente. Quando eu fechar o cromo, sair, entrar novamente, os cookies ainda estão lá e está tudo bem. No entanto, se eu reinicializar , os cookies desaparecerem e eu precisar fazer o login novamente.

Eu fiz algumas depurações (reinstalando o chrome, revertendo para a configuração padrão, começando com uma configuração limpa, tudo como sugerido acima, ...) e o bug persiste.

Eu instalei google-chrome-unstable Versão 55.0.2853.0 dev (64-bit) e tudo funciona bem (enquanto estável ainda tem o problema). Então, esse é provavelmente um bug de software do Chrome.

Minha "solução": use o firefox / chrome-unstable por alguns dias / semanas, aguarde a atualização que corrige o problema para se propagar para o google-chrome-stable.

A propósito, estou usando o ubuntu 16.04 (systemd) com dm mapper / cryptsetup que foi atualizado a partir de 14.04 e ainda não tenho 100% de certeza que minha partição crypt é desmontada toda vez 100% corretamente (apesar do fs está sempre limpo). @Novah, você tem uma configuração semelhante?

É setembro de 2016 quando escrevo este conselho. Se não resolveu dentro de um mês automaticamente, minha resposta está errada ;-) Espero poupar você de muita depuração e frustração.

    
por corny 09.09.2016 / 23:39
fonte
1

Por favor, note que isto já é reportado ao Chromium Bug Tracker: link

    
por user597677 21.09.2016 / 21:50
fonte
0

Eu tive o mesmo problema, mas meu sistema é o Ubuntu 14.04.

Se o seu sistema também pedisse senha do chaveiro todo início do google chrome (também reinicie o sistema), acho que porque o Google Chrome não pode salvar sua senha do google porque sua senha do google salva é bloqueada pelo chaveiro. Você precisa ter certeza de que o chaveiro esteja desbloqueado antes de iniciar o Google Chrome, não depois. Aqui está a minha solução:

  1. Abra o Google Chrome.
  2. Faça login novamente na conta do Google como de costume e verifique se não há um ícone de aviso amarelo antes do seu nome de usuário no canto superior direito. (apenas faça)
  3. Feche o Google Chrome.
  4. Abra o Dash e abra a conta de usuário e desative o login automático.
  5. Reinicie o sistema.

Ao ativar o login automático como "desativado", achei que isso automaticamente desbloqueia o conjunto de chaves de cada sistema de login. Por isso, o Google Chrome pode obter a senha da sua conta do Google a partir do chaveiro.

Eu sei que há também outra solução sobre desativar chaveiro (por definir a senha do chaveiro como em branco), mas acho que não é seguro.

    
por mnemonic brian 18.10.2016 / 08:53
fonte
0

Eu estava enfrentando os mesmos problemas. Na nova instalação, eu instalei o chrome como root (não sudo). Depois de reiniciar o programa funcionou bem. Aprendendo isso, eu desinstalei o chrome do PC anterior e o instalei novamente como usuário root. Agora está tudo bem e o prompt de login irritante acabou.

sudo -i
apt-get remove google-chrome*
apt-get autoremove
apt-get clean  
apt-get install google-chrome-stable  
    
por Vikas Avnish 30.12.2016 / 05:47
fonte