Teclado numérico não funciona

21

Estou executando o Ubuntu 10.04, totalmente atualizado, de um disco rígido USB externo. Tudo funciona muito bem, exceto o teclado. O teclado numérico não está funcionando. As chaves não fazem nada, com ou sem o NumLock.

As preferências de teclado estão definidas para o PC genérico de 105 teclas (Intl). O teclado em si, neste computador, é o PS2.

Alguma ideia de onde procurar consertar isso?

    
por UrkoM 21.09.2010 / 05:16
fonte

4 respostas

30

Às vezes, em máquinas que eu conecto por meio de teclas de mouse VNC, fico misteriosamente habilitado. Talvez este seja o seu problema.

Clique no menu do sistema - > Preferências - > Teclado. Na aba Mouse Keys verifique se Ponteiro pode ser controlado usando o teclado está desativado.

    
por Javier Rivera 21.09.2010 / 08:50
fonte
13

Vou postar outra resposta porque demorei para descobrir. Parece que as coisas mudaram um pouco nos últimos lançamentos. A aba "Mouse Keys" não estava lá nas minhas preferências de teclado (Ubuntu 11.10, gnome shell), então a solução @ JavierRivera me colocou no caminho certo, mas não resolveu o problema de desligar o "ponteiro de controle usando o teclado" opção. Aqui é onde eu encontrei:

Settings > Universal Access > Pointing and Clicking

Também habilitei "Teclas numéricas do teclado funcionam como no Macintosh", já que estou usando um teclado imac. Esta opção é encontrada em:

Settings > Keyboard Layout > Layouts > Options > Miscellaneous compatibility options

que parece ser necessário para mim.

    
por Ian Hincks 06.03.2012 / 03:43
fonte
4

Para o Ubuntu 12.10:

  • Clique no menu do sistema - > Configurações do sistema - > Acesso Universal - > Apontar e clicar

  • Desative as "Teclas do mouse"

por pasdenom 08.08.2013 / 11:19
fonte
0

Se você estiver usando o XFCE4 (por exemplo, o Xubuntu):

  • Ir para o Gerenciador de configurações > Acessibilidade > Mouse
  • Desmarque a opção "Usar emulação de mouse"; se já estiver desmarcado, primeiro verifique-o e, em seguida, desmarque-o (suponho que, por qualquer motivo, a GUI não sabe o que o Numpad está emulando o mouse)
por Azmisov 23.11.2016 / 19:11
fonte