Ubuntu 16.04 drivers nvidia não funcionam

20

Acabei de instalar um novo Ubuntu 16.04,
instalar fresco limpo, logado na primeira e única coisa que fiz é selecionar o driver proprietário 361 para a nvidia, reiniciei a máquina.
anfter reinicialização eu posso fazer o login, mas a unidade não está mostrando, eu ainda posso clique direito embora e abrir terminal, tentei muitas respostas:
link1 link2

não ajudou, fiquei frustrado, inicializei em usb e instalei-o de novo, desta vez eu tentei 340 drivers mesmo problema.
eu quero dizer que isso é 16.04 LTS pelo amor de Deus.
Eu tenho dual grahpic cartões nvidia gt 740m, intel construído no laptop ASUS.

saída do grep "EE \ | WW" /var/log/Xorg.0.log:

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    23.758] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    23.758] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    23.758] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    23.758] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    23.758] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    23.761] (WW) "glamoregl" will not be loaded unless you've specified it to be loaded elsewhere.
[    25.323] (WW) Unresolved symbol: fbGetGCPrivateKey
[    25.448] (WW) NVIDIA(0): Unable to get display device for DPI computation.
[    25.613] (WW) modeset(G0): Option "AllowEmptyInitialConfiguration" is not used
[    25.613] (WW) modeset(G0): Option "IgnoreDisplayDevices" is not used
[    25.902] (EE) NVIDIA(0): Failed to initiate mode change.
[    25.902] (EE) NVIDIA(0): Failed to complete mode change
[    26.214] (WW) evdev: SteelSeries Sensei Raw Gaming Mouse: ignoring absolute axes.
[    26.216] (WW) evdev: SteelSeries SteelSeries Apex Raw Gaming Keyboard: ignoring absolute axes.
[    26.272] (II) XINPUT: Adding extended input device "USBest Technology SiS HID Touch Controller" (type: TOUCHSCREEN, id 16)

arquivo de log completo LOG

arquivo xorg.conf:

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0@0:2:0"
    Option "AccelMethod" "None"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:4@0:0:0"
    Option "ConstrainCursor" "off"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
    Option "IgnoreDisplayDevices" "CRT"
EndSection
    
por saeed hardan 23.04.2016 / 12:30
fonte

8 respostas

1

Encontrou a solução (desta vez para valer),
Eu decidi ser um especialista do Ubuntu, então eu fui para o Google e digitei:

  

debug ubuntu

então ele me deu a página Debug e eu selecionei a unidade.
em alguma parte eu precisava fazer:

$ unity --advanced-debug
GNU gdb (GDB) 7.2-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>

...

(gdb) set logging file unity.log
(gdb) set logging on
(gdb) b _exit
Function "_exit" not defined.
Make breakpoint pending on future shared library load? (y or [n])
[Answer yes (y)]

(gdb) run

[ and when compiz/unity crash, do...]

(gdb) bt full

[ then CTRL-D or re-run compiz to continue working ]

(gdb) run

depois de executar isso, notei o erro:
compiz (core) - Erro: Plugin 'opengl' não carregado.

eu procurei por esse erro no google e ele me deu esse tópico Unidade faltando? Não é possível ver painéis superiores ou laterais , a resposta aqui funciona.

    
por saeed hardan 27.04.2016 / 18:23
fonte
9

Eu também instalei o Ubuntu 16.04, limpei a instalação em um novo hd e tudo funcionou bem até que eu mudei para o driver NVIDIA. Após a reinicialização, não consegui passar da tela de login. A solução que funcionou para mim foi desativar a inicialização segura .

Enquanto estava preso no loop de login, mudei para o console Ctl+Alt+F1 , reinicializei e desativei a inicialização segura em UEFI . Agora tudo funciona com o driver nvidia instalado.

    
por Karhu 27.04.2016 / 22:37
fonte
3

Eu também tive esse problema. Eu apenas executo isso em um console (pressione Ctrl + Alt + F1 , na página de login para mostrar o primeiro virtual tty):

sudo apt-get purge nvidia*

Depois disso, reiniciei e, em seguida, pude fazer o login. Depois disso, eu instalei os drivers intel primeiro, e depois o nvidia-361.

Estes foram os passos que segui:

  1. sudo apt-get purge nvidia*
  2. reinicializar (agora eu tinha o driver de exibição do noveau funcionando)
  3. sudo apt-get install intel-microcode
  4. sudo apt-get install intel-gpu-tools
  5. Reinicialização (para teste, tudo estava funcionando bem)
  6. sudo apt-get install nvidia-361 (acho que nvidia-current é melhor opção a longo prazo).
  7. Reinicializar

Agora eu tenho estes (desculpe, eles estão em espanhol):

Drivers adicionais

    
por Shosta 23.04.2016 / 18:36
fonte
2

Eu também tenho um problema com o driver 16.04 e Nvidia 361.42. Você pode usar o prime-select intel ou o driver Nouveau como solução temporária. Eu tive problemas intermináveis ​​com os drivers oficiais da Nvidia Ubuntu ao longo dos anos, é muito acertar e errar. Eu pensei que a introdução do Steam OS e o crescente número de usuários / jogadores de Linux poderiam encorajá-los a suportar melhor o Linux: /

    
por neutreno 23.04.2016 / 12:52
fonte
1

Acho que encontrei a solução. Eu tive problemas terríveis com a instalação do 16.04 na minha máquina principal. Os drivers da Nvidia caem e você não pode entrar e você tem que recorrer ao sudo apt-get purge nvidia- *. O Chrome estava falhando.

Eu não tive nenhum problema com a minha máquina secundária que tem um BIOS tradicional. É apenas minha máquina principal com firmware UEFI. A coisa mais frustrante é que eu estava correndo 16.04 de uma compilação diária por alguns meses e era muito sólido.

Tenho notado que o instalador solicita uma senha se você fizer o download dos drivers durante a instalação. A solução é DESLIGAR O BOTÃO SEGURO. Instalar o Ubuntu (a partir da opção UEFI no Menu da Bios) prossegue sem falhas e o sistema parece estável. 16.04 não é perfeito, e. para instalar o Chrome você tem que usar o gdebi, mas pelo menos agora é utilizável.

    
por Roderic Jones 03.05.2016 / 17:09
fonte
1

Para mim, a solução depois de muita pesquisa foi desativar o UEFI no BIOS. Minha máquina roda apenas o Linux, então desabilitar o UEFI não era um grande problema.

Eu estava tendo problemas com o VirtualBox e NVIDIA e não consegui trabalhar com o Ubuntu 16. Eu estava procurando por "ubuntu 16 UEFI Virtual Box Falha kernel build" e deparei com um link em relação ao Virtualbox que me fez questionar o UEFI e desativá-lo.

Depois de desabilitar o UEFI, reinstalei o Ubuntu 16. Durante a instalação, a caixa de diálogo que tinha a entrada "Inicialização segura" não tinha esse conteúdo.

Estou feliz em informar que o Ubuntu 16 está rodando e não estou tendo problemas com NVIDIA ou VirtualBox! Ambos estão funcionando como esperado.

Obrigado àqueles que compartilharam seus conhecimentos para que eu pudesse seguir em frente.

    
por D.Howland 06.05.2016 / 03:33
fonte
1

O Ubuntu 16.04 vem com o xserver Xorg 1.18 e a configuração é um pouco diferente da anterior. Em uma configuração de GPU dupla, do wiki do Arch Linux , o / etc / X11 / xorg.conf deve ser assim:

Section "Module"
    Load "modesetting"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1:0:0"
    Option "AllowEmptyInitialConfiguration"
EndSection

Substitua PCI: 1: 0: 0 pelo seu nvidia Bus ID. Você pode verificar com:

$ lspci | grep -E "VGA|3D"

Funciona para meu laptop HP com dois GPUs: Intel (Skylake) e NVIDIA 940m. Lembre-se que é possível alternar entre eles com o comando prime-select (como root) ou com o aplicativo oficial nvidia-settings e reboot no seu computador.

    
por Jaime M. 23.05.2016 / 20:49
fonte
0

Eu tive um problema semelhante, mas meu problema em particular foi causado pelo ESET NOD32 Antivirus .

A instalação do driver, tanto dos repositórios do ubuntu quanto da instalação do driver NVIDIA manual, estava ficando presa na construção dos módulos DKMS.

Encontrei instruções sobre como desinstalar o ESET e, após a desinstalação, defini minha execução -nível de 3:

sudo systemctl enable multi-user.target
sudo systemctl set-default multi-user.target

Blacklist nouveau:

Edite /etc/modprobe.d/blacklist.conf como superusuário e adicione:

blacklist nouveau

Em seguida, limpe a NVIDIA e reinicie:

sudo apt purge nvidia*
sudo reboot

Uma vez no nível de execução 3, instalei manualmente o driver NVIDIA mais recente, defini o nível de execução de volta para 5 e reiniciei.

sudo sh ./NVIDIA...
sudo systemctl enable graphical.target
sudo systemctl set-default graphical.target
reboot

As coisas estavam finalmente funcionando, então eu reinstalei o antivírus. Terá que esperar por uma atualização do kernel para garantir que o driver NVIDIA seja reconstruído.

    
por DavidG 19.03.2017 / 04:18
fonte