Como duplicar todas as linhas marcadas no Notepad ++

0

Gostaria de ver todas as linhas marcadas e duplicá-las.

Esta seria uma maneira automatizada de pressionar F2 e depois Ctrl + D.

Eu tentei macros e dois \ 1 com localizar e substituir por expressões regulares.

--------------------- Exemplo antes ------------------------

hostname RTA 
interface Loopback0
 ip address 203.250.13.41 255.255.255.0
interface Ethernet0
 ip address 203.250.14.1 255.255.255.0
router ospf 10
 network 203.250.13.41 0.0.0.0 area 1
 network 203.250.0.0 0.0.255.255 area 0.0.0.0

existem 8 linhas de código acima. eu bookmark linhas 2 e amp; 4.

------------------------ Exemplo após -----------------

hostname RTA 
interface Loopback0
interface Loopback0
 ip address 203.250.13.41 255.255.255.0
interface Ethernet0
interface Ethernet0
 ip address 203.250.14.1 255.255.255.0
router ospf 10
 network 203.250.13.41 0.0.0.0 area 1
 network 203.250.0.0 0.0.255.255 area 0.0.0.0
    
por barryoff 27.05.2016 / 19:08

1 resposta

0

Minha solução deselegante para isso foi: -

-add "## BOOKmarked LiNe ##" para cada linha marcada como favorito

-run o seguinte em um arquivo vbs

-remove todas as entradas "## BOOKmarked LiNe ##".

outFile="C:\Users\user\Desktop\test_loop1-out.txt"
Set objFSO=CreateObject("Scripting.FileSystemObject")
Set objFS = CreateObject("Scripting.FileSystemObject")

Set objFileout = objFSO.CreateTextFile(outFile,True)

Set objFile = objFS.OpenTextFile(strFile)

Do Until objFile.AtEndOfStream
strLine= objFile.ReadLine
objFileout.Write strLine & vbCrLf
if strLine.contains("##BOOKmarked LiNe##") Then objFileout.Write strLine & vbCrLf
Loop
objFile.Close
objFileout.Close
    
por 31.07.2016 / 01:20

Tags