Problema ao reiniciar o Apache 2 [duplicado]

73

Estou tentando reiniciar o Apache 2:

sudo service apache2 restart

Mas veja o erro abaixo:

* Restarting web server apache2 

AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1.

Set the 'ServerName' directive globally to suppress this message

Eu tentei mudar

sudo gedit /etc/apache2/httpd.conf

Um arquivo em branco aparece e eu adicionei:

ServerName localhost

Mas esse erro não desaparece!

Como posso resolver este problema?

    
por Hamed Kamrava 06.08.2013 / 15:42

4 respostas

110

Eu encontrei isto: Como reinicio / recarrego o Apache quando ele não consegue determinar o nome do domínio?

  

Boas notícias! O Apache está reiniciando com sucesso. O Apache não tem certeza   onde você quer servir, por isso está escolhendo seu localhost (127.0.0.1)   por padrão. Para evitar que essa mensagem apareça, esclareça que você   deseja servir de localhost (127.0.0.1) adicionando a seguinte linha   no seu arquivo /etc/apache2/apache2.conf :

ServerName localhost
    
por Meintjes 06.08.2013 / 15:52
34

Especificar ServerName localhost em seus arquivos de configuração fora das seções do host virtual é a maneira de fazer isso.

Outras respostas sugerem que você deve modificar /etc/apache2/httpd.conf . Este arquivo é sobrescrito quando o apache é atualizado do apt. Para a configuração do Apache que você não deseja sobrescrever, você deve criar um novo arquivo. Aqui está o "caminho do Debian" para fazer essa mudança de configuração:

# create the configuration file in the "available" section
echo "ServerName localhost" | sudo tee /etc/apache2/conf-available/servername.conf
# enable it by creating a symlink to it from the "enabled" section
sudo a2enconf servername
# restart the server
sudo service apache2 restart
    
por Stephen Ostermiller 10.03.2014 / 21:03
4

Seu endereço IP local deve ser 127.0.0.1, em vez de 127.0.1.1. Por favor, configure seu arquivo /etc/hosts corretamente. Em seguida, edite o arquivo httpd.conf :

sudo -H gedit /etc/apache2/httpd.conf

Quando um arquivo em branco aparecer, adicione essa linha e salve:

ServerName localhost
    
por Masabza 02.03.2014 / 13:36
0

Aqui está outra solução:

Antes:

[[email protected] ~]# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd: httpd: apr_sockaddr_info_get() failed for centos.wks.local
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
                                                           [  OK  ]

Adicionado 192.168.226.131 centos.wks.local no arquivo /etc/hosts

Nota: 192.168.226.131 é o endereço IP do meu servidor Apache.

Depois:

[[email protected] ~]# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd:                                            [  OK  ]
    
por Rahul Patil 06.08.2013 / 16:02

Tags