Você moveu todos os arquivos de / var / lib / mysql para / storage / mysql-data antes de iniciar o mysql? Além disso, verifique se as permissões do novo diretório são as mesmas do / var / lib / mysql
Eu estava procurando uma maneira de armazenar meus bancos de dados mysql em uma partição diferente da instalação padrão. Eu encontrei este link e segui os passos .
No entanto, depois de ter alterado a linha datadir = /var/lib/mysql em my.cnf para datadir = /storage/mysql-data , não consigo iniciar o serviço mysql novamente:
pieter@foxbox:~$ sudo service mysql start
start: Job failed to start
Quando eu altero o datadir de volta para o valor padrão, ele faz funcionar novamente. Por quê? Qual é o problema com a solução no link?
Estou no Ubuntu 12,04, 32 bits
Você moveu todos os arquivos de / var / lib / mysql para / storage / mysql-data antes de iniciar o mysql? Além disso, verifique se as permissões do novo diretório são as mesmas do / var / lib / mysql