Na parte inferior do seu arquivo de configuração, você tem smtpd_tls_security_level = encrypt , isso requer que todos os clientes SMTP de entrada usem o TLS. Se o cliente de entrada não suportar o TLS, a conexão falhará. (Isso parece ser o caso do gmx.net, dada a mensagem de erro.)
Se você definir smtpd_tls_security_level = may , será possível receber e-mails de servidores que não suportam TLS. (Isso parece ser definido mais acima em seu arquivo, mas é substituído pela configuração de criptografia mais tarde.)